summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-17 19:35:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-17 19:35:51 +0000
commit4390313287d60df8ddedd208e1c63cee145e4b3c (patch)
treeead97c91cd04fbba9587edf53124a1a051833c86 /media-sound
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-4390313287d60df8ddedd208e1c63cee145e4b3c.tar.gz
gentoo-2-4390313287d60df8ddedd208e1c63cee145e4b3c.tar.bz2
gentoo-2-4390313287d60df8ddedd208e1c63cee145e4b3c.zip
Fix brackets inside /usr/share/alsa/init/default wrt #281538.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.20-r5.ebuild94
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.20-init_default.patch12
3 files changed, 113 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index deee9321b411..fb30604b5c01 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.276 2009/08/17 05:03:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.277 2009/08/17 19:35:50 ssuominen Exp $
+
+*alsa-utils-1.0.20-r5 (17 Aug 2009)
+
+ 17 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-utils-1.0.20-r5.ebuild, +files/alsa-utils-1.0.20-init_default.patch:
+ Fix brackets inside /usr/share/alsa/init/default wrt #281538.
17 Aug 2009; Jeroen Roovers <jer@gentoo.org> alsa-utils-1.0.20-r4.ebuild:
Stable for HPPA (bug #280464).
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.20-r5.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.20-r5.ebuild
new file mode 100644
index 000000000000..d74a74e33c40
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.20-r5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.20-r5.ebuild,v 1.1 2009/08/17 19:35:50 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/_rc/rc}
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc nls minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ doc? ( app-text/xmlto )"
+RDEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if [[ -e "${ROOT}etc/modules.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modules.d/alsa found."
+ die "Move /etc/modules.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+
+ if [[ -e "${ROOT}etc/modprobe.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modprobe.d/alsa found."
+ die "Move /etc/modprobe.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-modprobe.d.patch \
+ "${FILESDIR}"/${P}-init_default.patch
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-xmlto"
+
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+ newdoc alsamixer/README README.alsamixer || die
+
+ newinitd "${FILESDIR}/alsasound.initd-r4" alsasound
+ newconfd "${FILESDIR}/alsasound.confd-r3" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.20-init_default.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.20-init_default.patch
new file mode 100644
index 000000000000..7671ee8f7d45
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.20-init_default.patch
@@ -0,0 +1,12 @@
+diff -ur alsa-utils-1.0.20.orig/alsactl/init/default alsa-utils-1.0.20/alsactl/init/default
+--- alsa-utils-1.0.20.orig/alsactl/init/default 2009-05-06 10:07:24.000000000 +0300
++++ alsa-utils-1.0.20/alsactl/init/default 2009-08-17 22:29:46.000000000 +0300
+@@ -49,7 +49,7 @@
+ CTL{name}="Headphone Playback Volume",PROGRAM=="__ctl_search",GOTO="headphone0_end"
+ # if master volume control is present, turn headphone volume to max
+ ENV{has_pmaster_vol}=="true",CTL{values}="0dB",RESULT=="0",GOTO="headphone0_end"
+-ENV{has_pmaster_vol}=="true",CTL{values)="100%",GOTO="headphone0_end"
++ENV{has_pmaster_vol}=="true",CTL{values}="100%",GOTO="headphone0_end"
+ CTL{values}="$env{pvolume}",RESULT!="0",CTL{values}="$env{ppercent}"
+ LABEL="headphone0_end"
+ CTL{name}="Headphone Playback Switch",PROGRAM=="__ctl_search", \