summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-03-27 16:28:40 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-03-27 16:28:40 +0000
commit4a79533f9e33227cfd8f20e292d4089fcf5a2e31 (patch)
tree449cb0190b0815f14cc870eacf867a26e411239a /media-sound
parentnew version of kismet, mostly a bugfix release but very worthwhile due to cha... (diff)
downloadgentoo-2-4a79533f9e33227cfd8f20e292d4089fcf5a2e31.tar.gz
gentoo-2-4a79533f9e33227cfd8f20e292d4089fcf5a2e31.tar.bz2
gentoo-2-4a79533f9e33227cfd8f20e292d4089fcf5a2e31.zip
Version bump to 0.6.1, wrt to bug #463272
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tomahawk/ChangeLog7
-rw-r--r--media-sound/tomahawk/tomahawk-0.6.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index 92049abf04ba..86735f56e9f4 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.22 2013/03/02 22:04:34 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.23 2013/03/27 16:28:40 ago Exp $
+
+*tomahawk-0.6.1 (27 Mar 2013)
+
+ 27 Mar 2013; Agostino Sarubbo <ago@gentoo.org> +tomahawk-0.6.1.ebuild:
+ Version bump to 0.6.1, wrt to bug #463272
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> tomahawk-0.5.5.ebuild,
tomahawk-0.6.0.ebuild, tomahawk-9999.ebuild:
diff --git a/media-sound/tomahawk/tomahawk-0.6.1.ebuild b/media-sound/tomahawk/tomahawk-0.6.1.ebuild
new file mode 100644
index 000000000000..1cb7b49b0ba7
--- /dev/null
+++ b/media-sound/tomahawk/tomahawk-0.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-0.6.1.ebuild,v 1.1 2013/03/27 16:28:40 ago Exp $
+
+EAPI=5
+
+QT_MINIMAL="4.7.0"
+
+CMAKE_MIN_VERSION="2.8.6"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.tomahawk-player.org/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ GIT_ECLASS="git-2"
+ EGIT_REPO_URI="git://github.com/tomahawk-player/${PN}.git"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils qt4-r2 ${GIT_ECLASS}
+
+DESCRIPTION="Qt playdar social music player"
+HOMEPAGE="http://tomahawk-player.org/"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+IUSE="debug jabber twitter"
+
+DEPEND="
+ app-crypt/qca
+ >=dev-cpp/clucene-2.3.3.4
+ >=dev-libs/boost-1.41
+ >=dev-libs/libattica-0.4.0
+ dev-libs/qjson
+ dev-libs/quazip
+ >=media-libs/liblastfm-1.0.1
+ >=media-libs/libechonest-2.0.1
+ >=media-libs/phonon-4.5.0
+ media-libs/taglib
+ x11-libs/libX11
+ >=dev-qt/qtcore-${QT_MINIMAL}:4
+ >=dev-qt/qtdbus-${QT_MINIMAL}:4
+ >=dev-qt/qtgui-${QT_MINIMAL}:4
+ >=dev-qt/qtsql-${QT_MINIMAL}:4[sqlite]
+ >=dev-qt/qtwebkit-${QT_MINIMAL}:4
+ jabber? ( >=net-libs/jreen-1.1.1 )
+ twitter? ( net-libs/qtweetlib )
+"
+RDEPEND="${DEPEND}
+ app-crypt/qca-ossl
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with jabber Jreen)
+ $(cmake-utils_use_with twitter QTweetLib)
+ )
+
+ if [[ ${PV} != *9999* ]]; then
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}