summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-06 14:09:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-06 14:09:08 +0000
commit65270cd62127057e404210ec0c424fb7ec559e8e (patch)
tree19ceb81da0a9bd7dbca48551c649d00c1a64ebff /media-sound
parentVersion bump with security fixes; drop old (diff)
downloadgentoo-2-65270cd62127057e404210ec0c424fb7ec559e8e.tar.gz
gentoo-2-65270cd62127057e404210ec0c424fb7ec559e8e.tar.bz2
gentoo-2-65270cd62127057e404210ec0c424fb7ec559e8e.zip
quick patch to fix build with ffmpeg2; bug #536232
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms2/ChangeLog8
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-ffmpeg2.patch15
-rw-r--r--media-sound/xmms2/xmms2-0.8-r2.ebuild5
3 files changed, 24 insertions, 4 deletions
diff --git a/media-sound/xmms2/ChangeLog b/media-sound/xmms2/ChangeLog
index 822755bc4124..4c310248694c 100644
--- a/media-sound/xmms2/ChangeLog
+++ b/media-sound/xmms2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/xmms2
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.37 2014/08/10 21:13:03 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/ChangeLog,v 1.38 2015/02/06 14:09:08 aballier Exp $
+
+ 06 Feb 2015; Alexis Ballier <aballier@gentoo.org> xmms2-0.8-r2.ebuild,
+ +files/xmms2-0.8-ffmpeg2.patch:
+ quick patch to fix build with ffmpeg2; bug #536232
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> xmms2-0.7-r2.ebuild,
xmms2-0.7-r3.ebuild, xmms2-0.8-r1.ebuild, xmms2-0.8-r2.ebuild:
diff --git a/media-sound/xmms2/files/xmms2-0.8-ffmpeg2.patch b/media-sound/xmms2/files/xmms2-0.8-ffmpeg2.patch
new file mode 100644
index 000000000000..2e9fac380ea0
--- /dev/null
+++ b/media-sound/xmms2/files/xmms2-0.8-ffmpeg2.patch
@@ -0,0 +1,15 @@
+Index: xmms2-0.8DrO_o/src/plugins/avcodec/avcodec.c
+===================================================================
+--- xmms2-0.8DrO_o.orig/src/plugins/avcodec/avcodec.c
++++ xmms2-0.8DrO_o/src/plugins/avcodec/avcodec.c
+@@ -29,6 +29,10 @@
+
+ #define AVCODEC_BUFFER_SIZE 16384
+
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
++#endif
++
+ typedef struct {
+ AVCodecContext *codecctx;
+
diff --git a/media-sound/xmms2/xmms2-0.8-r2.ebuild b/media-sound/xmms2/xmms2-0.8-r2.ebuild
index fecb6352b708..7efb7449f168 100644
--- a/media-sound/xmms2/xmms2-0.8-r2.ebuild
+++ b/media-sound/xmms2/xmms2-0.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r2.ebuild,v 1.4 2014/08/10 21:13:03 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms2/xmms2-0.8-r2.ebuild,v 1.5 2015/02/06 14:09:08 aballier Exp $
EAPI=3
@@ -112,6 +112,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}"-libav-9.patch #443256
epatch "${FILESDIR}/${P}"-cython-0.19.1.patch
epatch "${FILESDIR}/${P}"-memset.patch
+ epatch "${FILESDIR}/${P}"-ffmpeg2.patch #536232
if has_version dev-libs/libcdio-paranoia; then
sed -i -e 's:cdio/cdda.h:cdio/paranoia/cdda.h:' src/plugins/cdda/cdda.c || die