summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-08-13 21:57:52 +0000
committerCédric Krier <cedk@gentoo.org>2009-08-13 21:57:52 +0000
commit7dc3d1adb9d16eb656c9bb74920afc3bc4791b3b (patch)
treeb11e99e33a52049ec5a13137b86d4bea13ed2cba /media-sound
parentRemove old. Remove USE=selinux (bug #278169). (diff)
downloadgentoo-2-7dc3d1adb9d16eb656c9bb74920afc3bc4791b3b.tar.gz
gentoo-2-7dc3d1adb9d16eb656c9bb74920afc3bc4791b3b.tar.bz2
gentoo-2-7dc3d1adb9d16eb656c9bb74920afc3bc4791b3b.zip
Add multi-backend support, add default USE flag for bug #254738 and fix CFLAGS and cross-compile
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audicle/ChangeLog8
-rw-r--r--media-sound/audicle/audicle-1.0.0.6-r1.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/media-sound/audicle/ChangeLog b/media-sound/audicle/ChangeLog
index dfeb255fb079..f68a33ba9dd5 100644
--- a/media-sound/audicle/ChangeLog
+++ b/media-sound/audicle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audicle
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.3 2009/06/28 21:28:03 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/ChangeLog,v 1.4 2009/08/13 21:57:52 cedk Exp $
+
+*audicle-1.0.0.6-r1 (13 Aug 2009)
+
+ 13 Aug 2009; Cédric Krier <cedk@gentoo.org> +audicle-1.0.0.6-r1.ebuild:
+ Add multi-backend support, add default USE flag for bug #254738 and fix
+ CFLAGS and cross-compile
27 Jun 2009; Mark Loeser <halcy0n@gentoo.org> audicle-1.0.0.6.ebuild,
+files/audicle-1.0.0.6-gcc43.patch:
diff --git a/media-sound/audicle/audicle-1.0.0.6-r1.ebuild b/media-sound/audicle/audicle-1.0.0.6-r1.ebuild
new file mode 100644
index 000000000000..fe762df35358
--- /dev/null
+++ b/media-sound/audicle/audicle-1.0.0.6-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audicle/audicle-1.0.0.6-r1.ebuild,v 1.1 2009/08/13 21:57:52 cedk Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A Context-sensitive, On-the-fly Audio Programming Environ/mentality"
+HOMEPAGE="http://audicle.cs.princeton.edu/"
+SRC_URI="http://audicle.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+alsa jack oss truetype"
+
+RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile
+ virtual/glut
+ virtual/opengl
+ virtual/glu
+ >=x11-libs/gtk+-2
+ truetype? ( media-libs/ftgl
+ media-fonts/corefonts )
+ app-admin/eselect-audicle"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-font.patch"
+ epatch "${FILESDIR}/${P}-hid-smc.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ sed -i \
+ -e "s@../ftgl_lib/FTGL/include@/usr/include/FTGL@" \
+ -e "s@../ftgl_lib/FTGL/mac/build@/usr/lib@" \
+ -e "s/gcc -o/\$(CC) -o/" \
+ -e "s/-O3 -c/-c \$(CFLAGS)/" \
+ src/makefile.{alsa,jack,oss} || die "sed failed"
+}
+
+pkg_setup() {
+ if ! use alsa && ! use jack && ! use oss; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ fi
+}
+
+compile_backend() {
+ backend=$1
+ local config
+ use truetype && config="USE_FREETYPE_LIBS=1"
+ einfo "Compiling against ${backend}"
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) LEX=flex \
+ YACC=bison ${config} || die "emake failed"
+ mv audicle{,-${backend}}
+ emake -f makefile clean
+}
+
+src_compile() {
+ # when compile with athlon or athlon-xp flags
+ # audicle crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ use jack && compile_backend jack
+ use alsa && compile_backend alsa
+ use oss && compile_backend oss
+}
+
+src_install() {
+ use jack && dobin src/audicle-jack
+ use alsa && dobin src/audicle-alsa
+ use oss && dobin src/audicle-oss
+ dodoc AUTHORS PROGRAMMER README THANKS TODO VERSIONS
+}
+
+pkg_postinst() {
+ elog "Audicle now can use many audio engines, so you can specify audio engine"
+ elog "with audicle-{jack,alsa,oss}"
+ elog "Or you can use 'eselect audicle' to set the audio engine"
+
+ einfo "Calling eselect audicle update..."
+ eselect audicle update --if-unset
+}