summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-07-05 23:34:18 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-07-05 23:34:18 +0000
commit8a9660012be539fe6f2802375b343082f5af8adc (patch)
treedd62b71b39d0f0cf4ddc79a25f3831579d8b12d8 /media-sound
parentstable amd64, bug 230836 (diff)
downloadgentoo-2-8a9660012be539fe6f2802375b343082f5af8adc.tar.gz
gentoo-2-8a9660012be539fe6f2802375b343082f5af8adc.tar.bz2
gentoo-2-8a9660012be539fe6f2802375b343082f5af8adc.zip
Rev bump for libmtp-0.3.0 compat. Bug #230885.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-1.4.9.1-r1.ebuild111
-rw-r--r--media-sound/amarok/amarok-1.4.9.1.ebuild4
-rw-r--r--media-sound/amarok/files/amarok-1.4.9.1-libmtp-0.3.0-API.patch44
4 files changed, 165 insertions, 3 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 07f41435a00c..71001ce85f7c 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.265 2008/05/27 02:55:28 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.266 2008/07/05 23:34:18 loki_val Exp $
+
+*amarok-1.4.9.1-r1 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/amarok-1.4.9.1-libmtp-0.3.0-API.patch, amarok-1.4.9.1.ebuild,
+ +amarok-1.4.9.1-r1.ebuild:
+ Rev bump for libmtp-0.3.0 compat. Bug #230885.
27 May 2008; Ingmar Vanhassel <ingmar@gentoo.org>
files/amarok-1.4.9.1-helix+gcc-4.3.patch:
diff --git a/media-sound/amarok/amarok-1.4.9.1-r1.ebuild b/media-sound/amarok/amarok-1.4.9.1-r1.ebuild
new file mode 100644
index 000000000000..960323722a3a
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.9.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.9.1-r1.ebuild,v 1.1 2008/07/05 23:34:18 loki_val Exp $
+
+LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
+fr ga gl he hi hu id is it ja km ko ku lo lt mk ms nb nds ne nl nn pa
+pl pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz
+zh_CN zh_TW"
+
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde
+
+PKG_SUFFIX=""
+
+if [[ ${P/_pre} == ${P} ]]; then
+ MY_P="${P/_/-}"
+
+ if [[ ${P/_rc} == ${P} ]]; then
+ SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_rc*}"
+ fi
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mp4 kde mysql amazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz daap
+python"
+# kde: enables compilation of the konqueror sidebar plugin
+
+RDEPEND="kde? ( || ( =kde-base/konqueror-3.5* =kde-base/kdebase-3.5* ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ >=media-libs/taglib-1.4
+ mysql? ( >=virtual/mysql-4.0 )
+ postgres? ( virtual/postgresql-base )
+ opengl? ( virtual/opengl )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( >=media-libs/libgpod-0.5.2 )
+ mp4? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? (
+ media-video/realplayer
+ media-libs/alsa-lib )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ musicbrainz? ( media-libs/tunepimp )
+ =dev-lang/ruby-1.8*"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="${RDEPEND}
+ app-arch/unzip
+ python? ( dev-python/PyQt )
+ daap? ( www-servers/mongrel )"
+
+PATCHES=( "${FILESDIR}/${P}-helix+gcc-4.3.patch"
+ "${FILESDIR}/${P}-libmtp-0.3.0-API.patch" )
+
+need-kde 3.3
+
+src_compile() {
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) --without-xmms
+ $(use_with visualization libvisual)
+ $(use_enable amazon)
+ $(use_with ipod libgpod)
+ $(use_with mp4 mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ $(use_with mtp libmtp)
+ $(use_with musicbrainz)
+ $(use_with daap)
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # As much as I respect Ian, I'd rather leave Amarok to use mongrel
+ # from Portage, for security and policy reasons.
+ rm -rf "${D}"/usr/share/apps/amarok/ruby_lib/rbconfig \
+ "${D}"/usr/share/apps/amarok/ruby_lib/mongrel* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/rubygems* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/gem* \
+ "${D}"/usr/$(get_libdir)/ruby_lib
+
+ if ! use python; then
+ rm -r "${D}"/usr/share/apps/amarok/scripts/webcontrol \
+ || die "Unable to remove webcontrol."
+ fi
+}
diff --git a/media-sound/amarok/amarok-1.4.9.1.ebuild b/media-sound/amarok/amarok-1.4.9.1.ebuild
index 5a8eb330f75e..cde122269057 100644
--- a/media-sound/amarok/amarok-1.4.9.1.ebuild
+++ b/media-sound/amarok/amarok-1.4.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.9.1.ebuild,v 1.4 2008/05/19 20:07:28 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.9.1.ebuild,v 1.5 2008/07/05 23:34:18 loki_val Exp $
LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
fr ga gl he hi hu id is it ja km ko ku lo lt mk ms nb nds ne nl nn pa
@@ -56,7 +56,7 @@ RDEPEND="kde? ( || ( =kde-base/konqueror-3.5* =kde-base/kdebase-3.5* ) )
media-video/realplayer
media-libs/alsa-lib )
njb? ( >=media-libs/libnjb-2.2.4 )
- mtp? ( >=media-libs/libmtp-0.1.1 )
+ mtp? ( <=media-libs/libmtp-0.3.0 )
musicbrainz? ( media-libs/tunepimp )
=dev-lang/ruby-1.8*"
diff --git a/media-sound/amarok/files/amarok-1.4.9.1-libmtp-0.3.0-API.patch b/media-sound/amarok/files/amarok-1.4.9.1-libmtp-0.3.0-API.patch
new file mode 100644
index 000000000000..a4500070b3b6
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.9.1-libmtp-0.3.0-API.patch
@@ -0,0 +1,44 @@
+--- amarok/src/mediadevice/mtp/mtpmediadevice.cpp
++++ amarok/src/mediadevice/mtp/mtpmediadevice.cpp
+@@ -293,12 +293,13 @@
+ parent_id = getDefaultParentId();
+ }
+ debug() << "Parent id : " << parent_id << endl;
++ trackmeta->parent_id = parent_id;
+
+ m_critical_mutex.lock();
+ debug() << "Sending track... " << bundle.url().path().utf8() << endl;
+ int ret = LIBMTP_Send_Track_From_File(
+ m_device, bundle.url().path().utf8(), trackmeta,
+- progressCallback, this, parent_id
++ progressCallback, this
+ );
+ m_critical_mutex.unlock();
+
+@@ -529,7 +530,7 @@
+ for( MtpMediaItem *it = dynamic_cast<MtpMediaItem*>(items->first()); it; it = dynamic_cast<MtpMediaItem*>(items->next()) )
+ album_object->tracks[i++] = it->track()->id();
+ album_object->no_tracks = items->count();
+- ret = LIBMTP_Create_New_Album( m_device, album_object, 0 );
++ ret = LIBMTP_Create_New_Album( m_device, album_object );
+ if( ret != 0 )
+ {
+ debug() << "creating album failed : " << ret << endl;
+@@ -608,7 +609,7 @@
+ {
+ debug() << "Creating new folder '" << name << "' as a child of "<< parent_id << endl;
+ char *name_copy = qstrdup( name );
+- uint32_t new_folder_id = LIBMTP_Create_Folder( m_device, name_copy, parent_id );
++ uint32_t new_folder_id = LIBMTP_Create_Folder( m_device, name_copy, parent_id, 0 );
+ delete(name_copy);
+ debug() << "New folder ID: " << new_folder_id << endl;
+ if( new_folder_id == 0 )
+@@ -913,7 +914,7 @@
+ if( item->playlist()->id() == 0 )
+ {
+ debug() << "creating new playlist : " << metadata->name << endl;
+- int ret = LIBMTP_Create_New_Playlist( m_device, metadata, 0 );
++ int ret = LIBMTP_Create_New_Playlist( m_device, metadata );
+ if( ret == 0 )
+ {
+ item->playlist()->setId( metadata->playlist_id );