summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-27 09:35:22 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-27 09:35:22 +0000
commit989d6da4fcc29ca602a6cdf3c5835ae7a5473845 (patch)
treead0c9685e36aedd6dcb78c8001746a1ce4db459f /media-sound
parentSupport gnupg-2.1 building (#551822) (diff)
downloadgentoo-2-989d6da4fcc29ca602a6cdf3c5835ae7a5473845.tar.gz
gentoo-2-989d6da4fcc29ca602a6cdf3c5835ae7a5473845.tar.bz2
gentoo-2-989d6da4fcc29ca602a6cdf3c5835ae7a5473845.zip
Needs gnome-common (#553140)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gnac/ChangeLog8
-rw-r--r--media-sound/gnac/gnac-0.2.4.1.ebuild21
2 files changed, 17 insertions, 12 deletions
diff --git a/media-sound/gnac/ChangeLog b/media-sound/gnac/ChangeLog
index d68e2e82ab71..76fadbef60a7 100644
--- a/media-sound/gnac/ChangeLog
+++ b/media-sound/gnac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/gnac
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnac/ChangeLog,v 1.1 2012/08/28 00:51:56 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnac/ChangeLog,v 1.2 2015/06/27 09:35:22 pacho Exp $
+
+ 27 Jun 2015; Pacho Ramos <pacho@gentoo.org> gnac-0.2.4.1.ebuild:
+ Needs gnome-common (#553140)
*gnac-0.2.4.1 (28 Aug 2012)
@@ -8,4 +11,3 @@
+files/gnac-0.2.4.1-cflags.patch, +files/gnac-0.2.4.1-nls.patch,
+metadata.xml:
Initial import. Ebuild by me.
-
diff --git a/media-sound/gnac/gnac-0.2.4.1.ebuild b/media-sound/gnac/gnac-0.2.4.1.ebuild
index 835e194009ad..1dbaeab0f36e 100644
--- a/media-sound/gnac/gnac-0.2.4.1.ebuild
+++ b/media-sound/gnac/gnac-0.2.4.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnac/gnac-0.2.4.1.ebuild,v 1.1 2012/08/28 00:51:56 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnac/gnac-0.2.4.1.ebuild,v 1.2 2015/06/27 09:35:22 pacho Exp $
-EAPI=4
+EAPI=5
inherit eutils autotools gnome2
@@ -16,7 +16,8 @@ KEYWORDS="~amd64 ~x86"
LANGS=" cs da de en_GB es gl fr he hu it lt nb pt_BR pl ro ru sl sv te tr zh_CN"
IUSE="aac flac libnotify mp3 nls wavpack ${LANGS// / linguas_}"
-RDEPEND="x11-libs/gtk+:3
+RDEPEND="
+ x11-libs/gtk+:3
dev-libs/libunique:3
dev-libs/libxml2:2
libnotify? ( x11-libs/libnotify )
@@ -25,21 +26,23 @@ RDEPEND="x11-libs/gtk+:3
media-plugins/gst-plugins-gio:0.10
media-plugins/gst-plugins-meta:0.10[flac?,mp3?,wavpack?]
aac? ( media-plugins/gst-plugins-faac:0.10 )
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+"
DEPEND="${RDEPEND}
>=app-text/gnome-doc-utils-0.17.2
+ gnome-base/gnome-common
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
src_prepare() {
epatch "${FILESDIR}"/${P}-cflags.patch
epatch "${FILESDIR}"/${P}-nls.patch
- gnome2_src_prepare
eautoreconf
+ gnome2_src_prepare
}
src_configure() {
- G2CONF="${G2CONF} $(use_enable nls)"
- gnome2_src_configure
+ gnome2_src_configure $(use_enable nls)
}