summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 17:15:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 17:15:43 +0000
commitc8b8ef98f6c4965abcaf142fe4e014b4bf9ead46 (patch)
tree212eb14c1b8e6ab8a52d415da16540ac947344fd /media-sound
parentYet another empty IUSE (diff)
downloadgentoo-2-c8b8ef98f6c4965abcaf142fe4e014b4bf9ead46.tar.gz
gentoo-2-c8b8ef98f6c4965abcaf142fe4e014b4bf9ead46.tar.bz2
gentoo-2-c8b8ef98f6c4965abcaf142fe4e014b4bf9ead46.zip
Version bump with fftw compability patch wrt #268293, thanks to Robert Szczesiak for reporting.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/k3guitune/ChangeLog11
-rw-r--r--media-sound/k3guitune/files/k3guitune-1.01-fftw.patch19
-rw-r--r--media-sound/k3guitune/k3guitune-1.01.ebuild58
3 files changed, 86 insertions, 2 deletions
diff --git a/media-sound/k3guitune/ChangeLog b/media-sound/k3guitune/ChangeLog
index be10afb6e922..6823a9994a8f 100644
--- a/media-sound/k3guitune/ChangeLog
+++ b/media-sound/k3guitune/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/k3guitune
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/ChangeLog,v 1.18 2008/08/06 22:57:52 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/ChangeLog,v 1.19 2009/05/04 17:15:42 ssuominen Exp $
+
+*k3guitune-1.01 (04 May 2009)
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +k3guitune-1.01.ebuild, +files/k3guitune-1.01-fftw.patch:
+ Version bump with fftw compability patch wrt #268293, thanks to Robert
+ Szczesiak for reporting.
06 Aug 2008; Alexis Ballier <aballier@gentoo.org>
-files/k3guitune-0.4.1-configure.patch,
diff --git a/media-sound/k3guitune/files/k3guitune-1.01-fftw.patch b/media-sound/k3guitune/files/k3guitune-1.01-fftw.patch
new file mode 100644
index 000000000000..7a8648e010f4
--- /dev/null
+++ b/media-sound/k3guitune/files/k3guitune-1.01-fftw.patch
@@ -0,0 +1,19 @@
+diff -Naur k3guitune-1.01/k3guitune/osziview.cpp k3guitune-1.01_1/k3guitune/osziview.cpp
+--- k3guitune-1.01/k3guitune/osziview.cpp 2007-12-15 18:16:27.000000000 +0500
++++ k3guitune-1.01_1/k3guitune/osziview.cpp 2008-10-23 03:21:11.000000000 +0600
+@@ -254,12 +254,12 @@
+ }
+ fftw_in = (double*) fftw_malloc(sizeof(double) * nr);
+ fftw_out = (fftw_complex*) fftw_malloc(sizeof(fftw_complex) * nr);
+- fftw_p = fftw_plan_dft_r2c_1d(nr, fftw_in, fftw_out, FFTW_FORWARD);
++ fftw_p = fftw_plan_dft_r2c_1d(nr, fftw_in, fftw_out, FFTW_MEASURE);
+
+ fftw_in2 = (double*) fftw_malloc(sizeof(double) * nr * 2);
+ fftw_out2 = (fftw_complex*) fftw_malloc(sizeof(fftw_complex) * nr * 2);
+- fftw_p2 = fftw_plan_dft_r2c_1d(nr*2, fftw_in2, fftw_out2, FFTW_FORWARD);
+- fftw_p3 = fftw_plan_dft_c2r_1d(nr*2, fftw_out2, fftw_in2, FFTW_BACKWARD);
++ fftw_p2 = fftw_plan_dft_r2c_1d(nr*2, fftw_in2, fftw_out2, FFTW_MEASURE);
++ fftw_p3 = fftw_plan_dft_c2r_1d(nr*2, fftw_out2, fftw_in2, FFTW_MEASURE);
+ }
+
+ void OsziView::setNotch(bool n)
diff --git a/media-sound/k3guitune/k3guitune-1.01.ebuild b/media-sound/k3guitune/k3guitune-1.01.ebuild
new file mode 100644
index 000000000000..8d309bfe7034
--- /dev/null
+++ b/media-sound/k3guitune/k3guitune-1.01.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/k3guitune-1.01.ebuild,v 1.1 2009/05/04 17:15:42 ssuominen Exp $
+
+inherit kde eutils
+
+DESCRIPTION="A program for KDE that lets you tune musical instruments."
+HOMEPAGE="http://home.planet.nl/~lamer024/k3guitune.html"
+SRC_URI="http://home.planet.nl/~lamer024/files/${P}.tar.gz
+ mirror://gentoo/kde-admindir-3.5.5.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa oss jack"
+
+DEPEND="=sci-libs/fftw-3*
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-libs/bio2jack )"
+RDEPEND="${DEPEND}"
+
+need-kde 3.5
+
+LANGS="de fr nl sk"
+LANGS_DOC="de en nl"
+
+for X in ${LANGS} ${LANGS_DOC} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}"/${PN}-1.0-gcc43.patch \
+ "${FILESDIR}"/${P}-fftw.patch
+
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}.po"
+ done
+ cd "${S}/po"
+ sed -i -e "s:POFILES =.*:POFILES = ${MAKE_LANGS}:" Makefile.am \
+ || die "sed for translations failed"
+
+ MAKE_DOC=$(echo $(echo "${LINGUAS} ${LANGS_DOC}" | tr ' ' '\n' | sort | uniq -d))
+ [[ -n ${MAKE_DOC} ]] && MAKE_DOC=$(echo "${MAKE_DOC}" | tr '\n' ' ')
+ sed -i -e "s:^SUBDIRS =.*:SUBDIRS = ${MAKE_DOC} :" \
+ "${KDE_S}/doc/Makefile.am" || die "sed for docs locale failed"
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ local myconf="$(use_enable alsa)
+ $(use_enable arts)
+ $(use_enable oss)
+ $(use_enable jack)"
+
+ kde_src_compile
+}