summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-02-02 17:56:56 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-02-02 17:56:56 +0000
commitf826ea6bcc935a7db31792cb69a96f76694b7fe7 (patch)
treeedf699771b80869d127b16cbee019a36baab52f9 /media-sound
parentBump patchset to fix bug #208212 (diff)
downloadgentoo-2-f826ea6bcc935a7db31792cb69a96f76694b7fe7.tar.gz
gentoo-2-f826ea6bcc935a7db31792cb69a96f76694b7fe7.tar.bz2
gentoo-2-f826ea6bcc935a7db31792cb69a96f76694b7fe7.zip
Version bump, containing EQF (equalizer preset) and skin engine fixes.
(Portage version: 2.1.4.1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-1.4.6.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 08c1adb296f3..c44f93287a5a 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.142 2008/01/29 13:53:42 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.143 2008/02/02 17:56:56 chainsaw Exp $
+
+*audacious-1.4.6 (02 Feb 2008)
+
+ 02 Feb 2008; Tony Vroon <chainsaw@gentoo.org> +audacious-1.4.6.ebuild:
+ Version bump, containing EQF (equalizer preset) and skin engine fixes.
29 Jan 2008; Tony Vroon <chainsaw@gentoo.org> -audacious-1.3.2.ebuild,
-audacious-1.4.3.ebuild, -audacious-1.4.4.ebuild:
diff --git a/media-sound/audacious/audacious-1.4.6.ebuild b/media-sound/audacious/audacious-1.4.6.ebuild
new file mode 100644
index 000000000000..a9bd39ea854b
--- /dev/null
+++ b/media-sound/audacious/audacious-1.4.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.4.6.ebuild,v 1.1 2008/02/02 17:56:56 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet dbus nls libsamplerate"
+
+RDEPEND="dbus? ( >=dev-libs/dbus-glib-0.60 )
+ libsamplerate? ( media-libs/libsamplerate )
+ >=dev-libs/libmcs-0.6.0
+ >=dev-libs/libmowgli-0.5.0
+ dev-libs/libxml2
+ >=gnome-base/libglade-2.3.1
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.10"
+
+DEPEND="${RDEPEND}
+ !media-plugins/audacious-plugins-ugly
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.4.5"
+
+src_compile() {
+ econf \
+ $(use_enable chardet) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 1.4"
+ elog "Plugins compiled against 1.3 will not be loaded."
+ if ! useq dbus ; then
+ eerror "Unsupported configuration: D-Bus disabled"
+ ewarn "D-Bus has been disabled. Note that audtool will not be provided, you will not"
+ ewarn "be to able to get song information from scripts or control the player remotely."
+ ewarn "This configuration is provided for people heavily opposed to D-Bus that are able "
+ ewarn "to live with the loss of functionality that this implies. Reports about remote "
+ ewarn "control or multiple instances of Audacious being launched will be *closed*."
+ else
+ elog "Remote control is now only provided over D-Bus. Audacious offers both a private "
+ elog "interface and an MPRIS compliant interface on the bus. The older interface using "
+ elog "beepctrl.h is no longer present."
+ fi
+}