summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-08-13 19:46:29 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-08-13 19:46:29 +0000
commit2820d7825bfed8f7963d3fb85a1af8f450989863 (patch)
tree9603404500b5c1f6a5985ebb2d95ab780fbd2a14 /media-tv/ivtv
parentDon't install crontab task by default, inform user about the possibility inst... (diff)
downloadgentoo-2-2820d7825bfed8f7963d3fb85a1af8f450989863.tar.gz
gentoo-2-2820d7825bfed8f7963d3fb85a1af8f450989863.tar.bz2
gentoo-2-2820d7825bfed8f7963d3fb85a1af8f450989863.zip
Adding experimental 0.3.x releases
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog7
-rw-r--r--media-tv/ivtv/Manifest6
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.3.7c2
-rw-r--r--media-tv/ivtv/ivtv-0.3.7c.ebuild135
4 files changed, 147 insertions, 3 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 18c88417a674..407bbda16b2c 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.29 2005/07/28 08:47:09 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.30 2005/08/13 19:46:29 cardoe Exp $
+
+*ivtv-0.3.7c (13 Aug 2005)
+
+ 13 Aug 2005; Doug Goldstein <cardoe@gentoo.org> +ivtv-0.3.7c.ebuild:
+ Experimental ivtv 0.3.x ebuild
28 Jul 2005; Pieter Van den Abeele <pvdabeel@gentoo.org>
ivtv-0.2.0_rc3-r4.ebuild, ivtv-0.2.0_rc3-r5.ebuild:
diff --git a/media-tv/ivtv/Manifest b/media-tv/ivtv/Manifest
index d671081757e3..f48728a9cf60 100644
--- a/media-tv/ivtv/Manifest
+++ b/media-tv/ivtv/Manifest
@@ -1,6 +1,8 @@
+MD5 59afc9577a19c76a682de1f145552bc7 ChangeLog 4505
+MD5 5fd1eec1d1a95e7d0f6e93724781d251 ivtv-0.3.7c.ebuild 4206
+MD5 1b5dfd233a54a22de87bcb47627a7265 ivtv-0.2.0_rc3-r4.ebuild 3964
MD5 71007461e2e10f367a6a8f7a0b0d7d6a metadata.xml 465
MD5 28b327ad3b268ad20a14a516c72e9908 ivtv-0.2.0_rc3-r5.ebuild 3964
-MD5 1b5dfd233a54a22de87bcb47627a7265 ivtv-0.2.0_rc3-r4.ebuild 3964
-MD5 f5536736afed350184d5f726a7a99421 ChangeLog 4372
+MD5 a8e5872e973e678055f33614dec981c0 files/digest-ivtv-0.3.7c 130
MD5 994d47620b6a826a5d2cf84b3cb1bc5c files/digest-ivtv-0.2.0_rc3-r4 134
MD5 5458ad51769cecb853e0afb00ab63930 files/digest-ivtv-0.2.0_rc3-r5 134
diff --git a/media-tv/ivtv/files/digest-ivtv-0.3.7c b/media-tv/ivtv/files/digest-ivtv-0.3.7c
new file mode 100644
index 000000000000..4dbf8e674d7a
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.3.7c
@@ -0,0 +1,2 @@
+MD5 c6dc03b82fb386ba7488d12014a7474d ivtv-0.3.7c.tgz 665905
+MD5 173c5ce2c0f16da42a5316ef7cee6834 pvr_1.18.21.22168_inf.zip 676578
diff --git a/media-tv/ivtv/ivtv-0.3.7c.ebuild b/media-tv/ivtv/ivtv-0.3.7c.ebuild
new file mode 100644
index 000000000000..06b6dc6a3e6e
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.3.7c.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.3.7c.ebuild,v 1.1 2005/08/13 19:46:29 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://ivtv.writeme.ch"
+
+MY_P="${P/_/-}"
+FW_VER="pvr_1.18.21.22168_inf.zip"
+
+SRC_URI="http://www.ivtv.tv/releases/ivtv-0.3/${MY_P}.tgz
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER}"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-*"
+
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV"
+
+DEPEND="app-arch/unzip"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="ivtv(extra:${S}/driver)
+ msp3400(extra:${S}/driver)
+ saa7115(extra:${S}/driver)
+ tveeprom(extra:${S}/driver)
+ saa7127(extra:${S}/driver)
+ cx25840(extra:${S}/driver)"
+ linux_chkconfig_present FB && MODULE_NAMES="${MODULE_NAMES}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+
+ sed -e "s:^VERS26=.*:VERS26=${KV_MAJOR}.${KV_MINOR}:g" \
+ -i ${S}/driver/Makefile || die "sed failed"
+
+ sed -e "s:^KERNVER = .*:KERNVER = ${KV_FULL}:g" \
+ -i ${S}/driver/Makefile2.* || die "sed failed"
+
+ # This powerpc patch patches the source of the driver to disable DMA on ppc,
+ # instead PIO is used. Also, it force enables -fsigned-char and does not
+ # build some modules that contain x86 asm.
+
+ use ppc && epatch ${FILESDIR}/ppc-odw.patch
+
+ convert_to_m ${S}/driver/Makefile2.6
+}
+
+src_compile() {
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build driver "
+
+ cd ${S}/utils
+ make KERNELDIR=${KV_OUT_DIR} || die "failed to build utils "
+}
+
+src_install() {
+ cd ${S}/utils
+ dodir /lib/modules
+ ./ivtvfwextract.pl ${DISTDIR}/${FW_VER} \
+ ${D}/lib/modules/ivtv-fw-enc.bin \
+ ${D}/lib/modules/ivtv-fw-dec.bin
+
+ cd ${S}
+ dodoc README doc/*
+ cd ${S}/utils
+ newdoc README README.utils
+ dodoc README.mythtv-ivtv README.X11
+ dodoc lircd-g.conf lircd.conf lircrc
+
+ cd ${S}/utils
+ #should work... no idea why its not
+ #make KERNELDIR=${KERNEL_DIR} DESTDIR=${D} INSTALLDIR=/usr/bin install-sane || die "failed to install"
+ newbin fwapi ivtv-fwapi
+ newbin radio ivtv-radio
+ dobin ivtvctl
+
+ cd ${S}/driver
+ linux-mod_src_install || die "failed to install modules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "You now have a driver for the Hauppauge PVR PCI cards."
+ echo
+ einfo "In general, the following instructions suffice to conclude the"
+ einfo "installation. For more detailed instructions, please refer to the"
+ einfo "ivtv wiki listed as the home page of this ebuild."
+ echo
+ einfo "1) Ignore the above commands, only add 'ivtv' to /etc/modules.autoload.d/kernel-2.X"
+ echo
+ einfo "2) Also add a files called 'ivtv' to /etc/modules.d which contains"
+ einfo " the two lines:"
+ einfo " alias char-major-81 videodev"
+ einfo " alias char-major-81-0 ivtv"
+ echo
+ einfo "3) Then perform a 'update-modules'."
+ echo
+ # The MCE versions of the PVR cards come without remote control because (I
+ # assume) a remote control is included in Windows Media Center Edition. It
+ # is probably a good idea to just say that if your package comes with a
+ # remote then emerge lirc. Lirc should build all drivers anyway.
+ #
+ # einfo "To get the ir remote working, you'll need to emerge lirc"
+ # einfo "with the following set:"
+ # einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61 "
+ # einfo " --with-port=none --with-irq=none\" emerge lirc"
+ # echo
+ # einfo "You can also add the above LIRC_OPTS line to /etc/make.conf for"
+ # einfo "it to remain there for future updates."
+ # echo
+ # einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ # echo
+
+ einfo "The ptune* scripts have moved to media-tv/ivtv-ptune, emerge that to use those scripts"
+ echo
+
+ # Similar checks are performed by the make install in the drivers directory.
+
+ if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/msp3400.ko" ] ; then
+ ewarn "You have the msp3400 module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run 'update-modules'"
+ fi
+}