summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2003-06-18 18:35:21 +0000
committerBart Lauwers <blauwers@gentoo.org>2003-06-18 18:35:21 +0000
commit03e4f59b31a73c6412314960514c563698e8c617 (patch)
tree58fdae49fd611effec3c66c21fcc0174f7945815 /media-tv/nvtv/nvtv-0.4.5.ebuild
parentVersion bump per Bug#23040 (diff)
downloadgentoo-2-03e4f59b31a73c6412314960514c563698e8c617.tar.gz
gentoo-2-03e4f59b31a73c6412314960514c563698e8c617.tar.bz2
gentoo-2-03e4f59b31a73c6412314960514c563698e8c617.zip
Version bump per Bug#23040
Diffstat (limited to 'media-tv/nvtv/nvtv-0.4.5.ebuild')
-rw-r--r--media-tv/nvtv/nvtv-0.4.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-tv/nvtv/nvtv-0.4.5.ebuild b/media-tv/nvtv/nvtv-0.4.5.ebuild
new file mode 100644
index 000000000000..4b0dc5e0402a
--- /dev/null
+++ b/media-tv/nvtv/nvtv-0.4.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/nvtv-0.4.5.ebuild,v 1.1 2003/06/18 18:35:13 blauwers Exp $
+
+IUSE="X gtk gtk2"
+
+DESCRIPTION="TV-Out for NVidia cards"
+HOMEPAGE="http://sourceforge.net/projects/nv-tv-out/"
+SRC_URI="mirror://sourceforge/nv-tv-out/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="sys-apps/pciutils
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ X? ( >=x11-base/xfree-4.0 )"
+
+src_compile() {
+ local myconf
+
+ if use gtk2; then
+ myconf="${myconf} --with-gtk=gtk2"
+ elif use gtk; then
+ myconf="${myconf} --with-gtk=gtk1"
+ else
+ myconf="${myconf} --without-gtk";
+ fi
+
+ use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+
+ econf ${myconf}
+
+ # The CFLAGS don't seem to make it into the Makefile.
+ cd src
+ emake CXFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin src/nvtv
+ dosbin src/nvtvd
+
+ dodoc ANNOUNCE BUGS FAQ INSTALL README \
+ doc/USAGE doc/chips.txt doc/overview.txt \
+ doc/timing.txt xine/tvxine
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nvtv.start nvtv
+}