summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-01-14 22:14:26 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-01-14 22:14:26 +0000
commitf91eee5bb08254189370cfeb0c5f5c867c63c6e5 (patch)
tree191dc2ab00cc3d10b40be5de141484e74d21f613 /media-tv
parentadd perl scripts under USE=perl so it pulls in the perl depends (diff)
downloadgentoo-2-f91eee5bb08254189370cfeb0c5f5c867c63c6e5.tar.gz
gentoo-2-f91eee5bb08254189370cfeb0c5f5c867c63c6e5.tar.bz2
gentoo-2-f91eee5bb08254189370cfeb0c5f5c867c63c6e5.zip
add perl scripts under USE=perl so it pulls in the perl depends
(Portage version: 2.1.4)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog7
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.10.6-r13
-rw-r--r--media-tv/ivtv/ivtv-0.10.6-r1.ebuild156
3 files changed, 165 insertions, 1 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index e2575d33f13e..109c7a3935c7 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.99 2008/01/14 22:04:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.100 2008/01/14 22:14:25 cardoe Exp $
+
+*ivtv-0.10.6-r1 (14 Jan 2008)
+
+ 14 Jan 2008; Doug Klima <cardoe@gentoo.org> +ivtv-0.10.6-r1.ebuild:
+ add perl scripts under USE=perl so it pulls in the perl depends
*ivtv-1.0.3-r2 (14 Jan 2008)
diff --git a/media-tv/ivtv/files/digest-ivtv-0.10.6-r1 b/media-tv/ivtv/files/digest-ivtv-0.10.6-r1
new file mode 100644
index 000000000000..922893fa6aa7
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.10.6-r1
@@ -0,0 +1,3 @@
+MD5 4fb41304b73be4727e54f3bfcadfa056 ivtv-0.10.6.tar.gz 372404
+RMD160 94cf0e0c319549b2e10918625442f7306d6326f3 ivtv-0.10.6.tar.gz 372404
+SHA256 4cbb6b254bd051bdafca3054fe687b46428e5aadbc8b3ce5ca2fa8f88589ac61 ivtv-0.10.6.tar.gz 372404
diff --git a/media-tv/ivtv/ivtv-0.10.6-r1.ebuild b/media-tv/ivtv/ivtv-0.10.6-r1.ebuild
new file mode 100644
index 000000000000..cec88e51815f
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.10.6-r1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.10.6-r1.ebuild,v 1.1 2008/01/14 22:14:25 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/0.10.x/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fbcon perl"
+RDEPEND="|| ( >=sys-fs/udev-103 sys-apps/hotplug )"
+DEPEND="app-arch/unzip"
+PDEPEND="=media-tv/pvr-firmware-20070217
+ perl? (
+ dev-perl/Video-Frequencies
+ dev-perl/Video-ivtv
+ dev-perl/Config-IniFiles
+ virtual/perl-Getopt-Long
+ dev-perl/perl-tk )"
+
+pkg_setup() {
+
+ MODULE_NAMES="ivtv(extra:${S}/driver)
+ saa717x(extra:${S}/i2c-drivers)"
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="EXPERIMENTAL KMOD VIDEO_DEV I2C VIDEO_V4L1_COMPAT VIDEO_V4L2
+ !VIDEO_HELPER_CHIPS_AUTO
+ FW_LOADER VIDEO_WM8775 VIDEO_MSP3400 VIDEO_CX25840 VIDEO_TUNER
+ VIDEO_SAA711X VIDEO_CX2341X VIDEO_SAA7127 VIDEO_TVEEPROM"
+
+ if use fbcon; then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
+ fi
+
+ if ! ( kernel_is 2 6 18 || kernel_is 2 6 19 || kernel_is 2 6 20 \
+ || kernel_is 2 6 21 ); then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different ivtv driver"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ die "This only works on kernels 2.6.18 through 2.6.21"
+ fi
+
+ if kernel_is 2 6 20; then
+ ewarn
+ ewarn "For 2.6.20.x kernels, this module will *only* work against"
+ ewarn "these versions:"
+ ewarn ">=sys-kernel/gentoo-sources-2.6.20-r1"
+ ewarn ">=sys-kernel/vanilla-sources.2.6.20.2"
+ ewarn ""
+ epause 5
+ fi
+
+ if use fbcon; then
+ ewarn ""
+ ewarn "From the README regarding framebuffer support:"
+ ewarn ""
+ ewarn "ivtv-fb now requires that you enable the following kernel config"
+ ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
+ ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
+ ewarn "(the Trident module itself is not required)."
+ ewarn ""
+ ewarn "To get working console output, keep going to 'Console display"
+ ewarn "driver support', and enable 'Framebuffer Console support'."
+ ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
+ ewarn "have a list of fonts. Choose one. With the default OSD size,"
+ ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
+ ewarn ""
+ ewarn "This ebuild checks for all the correct kernel config options for"
+ ewarn "framebuffer use with the exception of choosing a font. Be sure"
+ ewarn "to pick one yourself!"
+ ewarn ""
+ fi
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_compile() {
+
+ cd "${S}/driver"
+ linux-mod_src_compile || die "failed to build driver"
+
+ cd "${S}/utils"
+ emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
+}
+
+src_install() {
+ cd "${S}/utils"
+ make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
+ use perl && dobin perl/*.pl
+
+ cd "${S}"
+ dodoc README* doc/* utils/README.X11 ChangeLog*
+ use perl && dodoc utils/perl/README.ptune
+
+ cd "${S}/driver"
+ linux-mod_src_install || die "failed to install modules"
+
+ # Add the aliases
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/ivtv ivtv
+}
+
+pkg_postinst() {
+
+ linux-mod_pkg_postinst
+
+ elog ""
+ elog "This version of the IVTV driver supports the following hardware:"
+ elog "Hauppauge WinTV PVR-250"
+ elog "Hauppauge WinTV PVR-350"
+ elog "Hauppauge WinTV PVR-150"
+ elog "Hauppauge WinTV PVR-500"
+ elog "AVerMedia M179"
+ elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
+ elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
+ elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
+ elog "Adaptec AVC-2410"
+ elog "Adaptec AVC-2010"
+ elog "Nagase Transgear 5000TV"
+ elog "AOpen VA2000MAX-STN6"
+ elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
+ elog "I/O Data GV-MVP/RX"
+ elog "I/O Data GV-MVP/RX2E"
+ elog "Gotview PCI DVD (preliminary support only)"
+ elog "Gotview PCI DVD2 Deluxe"
+ elog "Yuan MPC622"
+ elog ""
+ ewarn ""
+ ewarn "IMPORTANT: In case of problems first read this page:"
+ ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
+ ewarn ""
+ ewarn "If any of these conditions match your setup, you may want to look at the"
+ ewarn "README in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn " - Using MythTV, a PVR-350 and the ivtv-fb module"
+ ewarn " - Using the ivtv X driver and the ivtv-fb module"
+ ewarn " - You want to manually build ivtv against v4l-dvb"
+ ewarn ""
+ ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
+ ewarn "proper use and debugging utilities."
+ ewarn "They are also located in /usr/share/doc/${PF}/"
+ ewarn ""
+ ewarn "For more information, see the IVTV driver homepage at:"
+ ewarn "http://www.ivtvdriver.org/"
+}