summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2014-08-22 15:49:05 +0000
committerSteve Dibb <beandog@gentoo.org>2014-08-22 15:49:05 +0000
commitc96d1a33a9fe06ba18c6ec8ca81d2a65a30e09e4 (patch)
tree87eb4df0007401dd6222607c5197735aa480354a /media-video/acidrip
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-c96d1a33a9fe06ba18c6ec8ca81d2a65a30e09e4.tar.gz
gentoo-2-c96d1a33a9fe06ba18c6ec8ca81d2a65a30e09e4.tar.bz2
gentoo-2-c96d1a33a9fe06ba18c6ec8ca81d2a65a30e09e4.zip
Fix corner cases where dependency checks in Makefile can fail, relying on portage to ensure they are met instead, bug 299173
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-video/acidrip')
-rw-r--r--media-video/acidrip/ChangeLog9
-rw-r--r--media-video/acidrip/acidrip-0.14-r3.ebuild27
-rw-r--r--media-video/acidrip/files/acidrip-0.14-makefile.patch50
3 files changed, 85 insertions, 1 deletions
diff --git a/media-video/acidrip/ChangeLog b/media-video/acidrip/ChangeLog
index 044e45f9099b..5ce2931f9295 100644
--- a/media-video/acidrip/ChangeLog
+++ b/media-video/acidrip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/acidrip
# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/acidrip/ChangeLog,v 1.33 2014/07/27 16:57:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/acidrip/ChangeLog,v 1.34 2014/08/22 15:49:05 beandog Exp $
+
+*acidrip-0.14-r3 (22 Aug 2014)
+
+ 22 Aug 2014; Steve Dibb <beandog@gentoo.org> +acidrip-0.14-r3.ebuild,
+ +files/acidrip-0.14-makefile.patch:
+ Fix corner cases where dependency checks in Makefile can fail, relying on
+ portage to ensure they are met instead, bug 299173
27 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> -acidrip-0.14-r1.ebuild:
old
diff --git a/media-video/acidrip/acidrip-0.14-r3.ebuild b/media-video/acidrip/acidrip-0.14-r3.ebuild
new file mode 100644
index 000000000000..649e4e1b7981
--- /dev/null
+++ b/media-video/acidrip/acidrip-0.14-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/acidrip/acidrip-0.14-r3.ebuild,v 1.1 2014/08/22 15:49:05 beandog Exp $
+
+EAPI=5
+inherit perl-app
+
+DESCRIPTION="A gtk-perl mplayer/mencoder frontend for ripping DVDs"
+HOMEPAGE="http://sourceforge.net/acidrip/"
+SRC_URI="mirror://sourceforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="encode"
+
+RDEPEND="dev-lang/perl
+ dev-perl/gtk2-perl
+ media-video/lsdvd
+ media-video/mplayer[encode]
+ encode? ( >=media-sound/lame-3.92 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-mplayer.patch #168012
+ epatch "${FILESDIR}/${P}-makefile.patch" #299173
+}
diff --git a/media-video/acidrip/files/acidrip-0.14-makefile.patch b/media-video/acidrip/files/acidrip-0.14-makefile.patch
new file mode 100644
index 000000000000..bbaf340799c3
--- /dev/null
+++ b/media-video/acidrip/files/acidrip-0.14-makefile.patch
@@ -0,0 +1,50 @@
+--- acidrip-0.14/Makefile.PL.orig 2014-08-22 09:38:46.179128473 -0600
++++ acidrip-0.14/Makefile.PL 2014-08-22 09:40:33.045103299 -0600
+@@ -36,47 +36,7 @@
+ $_;
+ }
+
+-print "\nRunning additional test to be sure acidrip will work\n";
+-
+-print "test for lsdvd: ";
+-my $lsdvd = `lsdvd -V 2>&1`;
+-if ( $lsdvd !~ /0.(\d+)\s/ ) {
+-die "Not Found!\n\n***************\n" .
+- "AcidRip needs my little app \"lsdvd\" in order to see what is on your dvd\'s\n" .
+- "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+- "If it\'s simply not on your path then set the full path inside AcidRip.\n" .
+- "***************\n\n"
+-}
+-if ( $1 < 9 ) {
+-die "Too old!\n\n***************\n" .
+- "AcidRip needs at least version 0.9 of lsdvd, but version 0.$1 was found\n" .
+- "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+- "***************\n\n"
+-}
+-print "found\n";
+-
+-print "test for MPlayer: "; die "Not Found!\n\n***************\n" .
+- "AcidRip is based around the MPlayer video player. it has not been found on\n" .
+- "your current path. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+- "INSTALL for installation instructions.\n" .
+- "***************\n\n" if ( system "mplayer 2&>1 > /dev/null" ); print "found\n";
+-
+-print "test for MEncoder: "; die "Not Found!\n\n***************\n" .
+- "AcidRip uses MEncoder, which is part of MPlayer video player package. This\n" .
+- "was not found. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+- "INSTALL for installation instructions.\n" .
+- "***************\n\n" if ( system "mencoder -ovc help 2> /dev/null | grep MEncoder > /dev/null" ); print "found\n";
+-
+-print "test for MP3 support in mencoder: "; die "Not Found!\n\n***************\n" .
+- "MEncoder was found, however it does not have MP3 support built into it.\n" .
+- "If you DO want MP3 support you'll need to recompile mplayer with mp3 support\n" .
+- "See INSTALL or INSTALL.html for more information\n" .
+- "***************\n\n" if ( system "mencoder -oac help 2> /dev/null | grep mp3lame > /dev/null" ); print "found\n";
+-
+-print "Everything looks good here...\n";
+-
+ print "\nPlease send any feedback to me, I actually do want to know what you think of it.";
+ print "\nMaybe then I can make it suck less. acid_kewpie\@users.sourceforge.net\n\n";
+
+ exit(0);
+-