summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-19 20:05:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-19 20:05:00 +0000
commit073d8a8f83817e62e0a598af2555c7165038415b (patch)
treeccd73003853ce6b49c6f7b1e2c981298d071a247 /media-video/cheese/cheese-2.26.3.ebuild
parentVersion bump to 9.6.1, bug 274494. Fix bug 275684. Add xml useflags. append-f... (diff)
downloadgentoo-2-073d8a8f83817e62e0a598af2555c7165038415b.tar.gz
gentoo-2-073d8a8f83817e62e0a598af2555c7165038415b.tar.bz2
gentoo-2-073d8a8f83817e62e0a598af2555c7165038415b.zip
Version bump. Translation updates. Added a video sink to RDEPEND, bug #277480.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/cheese/cheese-2.26.3.ebuild')
-rw-r--r--media-video/cheese/cheese-2.26.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-video/cheese/cheese-2.26.3.ebuild b/media-video/cheese/cheese-2.26.3.ebuild
new file mode 100644
index 000000000000..fd22c5f7ee67
--- /dev/null
+++ b/media-video/cheese/cheese-2.26.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/cheese-2.26.3.ebuild,v 1.1 2009/07/19 20:05:00 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="http://www.gnome.org/projects/cheese/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="v4l"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.7
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/cairo-1.4.0
+ >=x11-libs/pango-1.18.0
+ >=sys-apps/dbus-1
+ >=sys-apps/hal-0.5.9
+ >=gnome-base/gconf-2.16.0
+ >=gnome-base/gnome-desktop-2.25.1
+ >=gnome-base/librsvg-2.18.0
+ >=gnome-extra/evolution-data-server-1.12
+
+ >=media-libs/gstreamer-0.10.16
+ >=media-libs/gst-plugins-base-0.10.16"
+RDEPEND="${COMMON_DEPEND}
+ >=media-plugins/gst-plugins-gconf-0.10
+ >=media-plugins/gst-plugins-ogg-0.10.16
+ >=media-plugins/gst-plugins-pango-0.10.16
+ >=media-plugins/gst-plugins-theora-0.10.16
+ >=media-plugins/gst-plugins-v4l2-0.10
+ >=media-plugins/gst-plugins-vorbis-0.10.16
+ v4l? ( >=media-plugins/gst-plugins-v4l-0.10 )
+ || ( >=media-plugins/gst-plugins-x-0.10
+ >=media-plugins/gst-plugins-xv-0.10 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ x11-proto/xf86vidmodeproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-scrollkeeper --disable-hildon"
+}