summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-06-11 13:26:57 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-06-11 13:26:57 +0000
commit53799eec8049974cbbd7ed670a8e765dd5de4017 (patch)
tree41d1bb703119a8c0133b0c6caa2dd7d9bd668863 /media-video/cinelerra
parentblah (Manifest recommit) (diff)
downloadgentoo-2-53799eec8049974cbbd7ed670a8e765dd5de4017.tar.gz
gentoo-2-53799eec8049974cbbd7ed670a8e765dd5de4017.tar.bz2
gentoo-2-53799eec8049974cbbd7ed670a8e765dd5de4017.zip
gcc-3.4 fixes...
Diffstat (limited to 'media-video/cinelerra')
-rw-r--r--media-video/cinelerra/ChangeLog7
-rw-r--r--media-video/cinelerra/cinelerra-1.2.0.ebuild5
-rw-r--r--media-video/cinelerra/files/cinelerra-1.2.0-gcc34.patch117
3 files changed, 127 insertions, 2 deletions
diff --git a/media-video/cinelerra/ChangeLog b/media-video/cinelerra/ChangeLog
index 3cb01bebe936..7aff48fc94f6 100644
--- a/media-video/cinelerra/ChangeLog
+++ b/media-video/cinelerra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cinelerra
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.20 2004/06/09 16:55:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.21 2004/06/11 13:26:57 kugelfang Exp $
+
+ 11 Jun 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/cinelerra-1.2.0-gcc34.patch, cinelerra-1.2.0.ebuild:
+ Added gcc-3.4 compatibility patch as well as a global #undef HAVE_V4L2 to
+ avoid a linker error. This is a workaround until upstream fixes.
09 Jun 2004; Aron Griffis <agriffis@gentoo.org> cinelerra-1.0.0.ebuild,
cinelerra-1.1.5.ebuild, cinelerra-1.1.7.ebuild, cinelerra-1.1.9.ebuild,
diff --git a/media-video/cinelerra/cinelerra-1.2.0.ebuild b/media-video/cinelerra/cinelerra-1.2.0.ebuild
index 00d5ab40852d..880d882564e1 100644
--- a/media-video/cinelerra/cinelerra-1.2.0.ebuild
+++ b/media-video/cinelerra/cinelerra-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/cinelerra-1.2.0.ebuild,v 1.4 2004/06/10 12:26:09 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/cinelerra-1.2.0.ebuild,v 1.5 2004/06/11 13:26:57 kugelfang Exp $
inherit gcc eutils flag-o-matic
export WANT_GCC_3="yes"
@@ -29,6 +29,7 @@ src_unpack() {
unpack ${A}
# epatch ${FILESDIR}/gcc-3.3.1-collate.patch
# epatch ${FILESDIR}/pthread_t_not_int.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
touch ${S}/hvirtual_config.h
}
@@ -39,6 +40,8 @@ src_compile() {
cd ${S}/quicktime/ffmpeg-0.4.8
econf ||die
+ echo "#undef HAVE_V4L2" >> ${S}/hvirtual_config.h
+
cd ${S}
make || die "make failed"
}
diff --git a/media-video/cinelerra/files/cinelerra-1.2.0-gcc34.patch b/media-video/cinelerra/files/cinelerra-1.2.0-gcc34.patch
new file mode 100644
index 000000000000..2f20199fff5f
--- /dev/null
+++ b/media-video/cinelerra/files/cinelerra-1.2.0-gcc34.patch
@@ -0,0 +1,117 @@
+--- cinelerra-1.2.0/guicast/arraylist.h.orig 2004-06-10 14:49:01.139700744 +0200
++++ cinelerra-1.2.0/guicast/arraylist.h 2004-06-10 14:47:51.215330864 +0200
+@@ -1,6 +1,8 @@
+ #ifndef ARRAYLIST_H
+ #define ARRAYLIST_H
+
++#include <stdio.h>
++
+ // designed for lists of track numbers
+
+ template<class TYPE>
+--- cinelerra-1.2.0/cinelerra/floatautos.C.orig 2004-06-10 15:29:51.105249368 +0200
++++ cinelerra-1.2.0/cinelerra/floatautos.C 2004-06-10 15:30:08.127661568 +0200
+@@ -249,8 +249,8 @@
+ float y0, y1, y2, y3;
+ float t;
+
+- previous = (FloatAuto*)get_prev_auto(position, direction, (Auto*)previous, 0);
+- next = (FloatAuto*)get_next_auto(position, direction, (Auto*)next, 0);
++ previous = (FloatAuto*)get_prev_auto(position, direction, (Auto*&)previous, 0);
++ next = (FloatAuto*)get_next_auto(position, direction, (Auto*&)next, 0);
+
+ // Constant
+ if(!next && !previous)
+--- cinelerra-1.2.0/cinelerra/recordmonitor.C.orig 2004-06-10 15:38:34.777639064 +0200
++++ cinelerra-1.2.0/cinelerra/recordmonitor.C 2004-06-10 15:43:29.064900600 +0200
+@@ -1004,7 +1004,7 @@
+
+ int RecVideoDVThread::start_rendering()
+ {
+- ((dv_t*)dv) = dv_new();
++ dv = (void*)dv_new();
+ return 0;
+ }
+
+--- cinelerra-1.2.0/cinelerra/panautos.C.orig 2004-06-10 16:01:26.943038216 +0200
++++ cinelerra-1.2.0/cinelerra/panautos.C 2004-06-10 16:02:04.583316024 +0200
+@@ -24,8 +24,8 @@
+ PanAuto* &previous,
+ PanAuto* &next)
+ {
+- previous = (PanAuto*)get_prev_auto(position, direction, (Auto*)previous);
+- next = (PanAuto*)get_next_auto(position, direction, (Auto*)next);
++ previous = (PanAuto*)get_prev_auto(position, direction, (Auto*&)previous);
++ next = (PanAuto*)get_next_auto(position, direction, (Auto*&)next);
+
+ // Constant
+ if(previous->handle_x == next->handle_x &&
+--- cinelerra-1.2.0/cinelerra/tracks.C.orig 2004-06-10 23:00:14.882010848 +0200
++++ cinelerra-1.2.0/cinelerra/tracks.C 2004-06-10 23:00:32.904271048 +0200
+@@ -295,7 +295,7 @@
+ mute_keyframe = (IntAuto*)current->automation->mute_autos->get_prev_auto(
+ unit_start,
+ PLAY_FORWARD,
+- (Auto*)mute_keyframe);
++ (Auto*&)mute_keyframe);
+
+ result +=
+ (current->play && type == PLAY) ||
+--- cinelerra-1.2.0/cinelerra/virtualnode.C.orig 2004-06-10 23:01:42.411704312 +0200
++++ cinelerra-1.2.0/cinelerra/virtualnode.C 2004-06-10 23:02:07.916826944 +0200
+@@ -472,8 +472,8 @@
+
+ IntAuto *prev_keyframe = 0;
+ IntAuto *next_keyframe = 0;
+- prev_keyframe = (IntAuto*)autos->get_prev_auto(input_position, direction, (Auto*)prev_keyframe);
+- next_keyframe = (IntAuto*)autos->get_next_auto(input_position, direction, (Auto*)next_keyframe);
++ prev_keyframe = (IntAuto*)autos->get_prev_auto(input_position, direction, (Auto*&)prev_keyframe);
++ next_keyframe = (IntAuto*)autos->get_next_auto(input_position, direction, (Auto*&)next_keyframe);
+
+ if(direction == PLAY_FORWARD)
+ {
+--- cinelerra-1.2.0/cinelerra/virtualanode.C.orig 2004-06-10 23:03:35.860457480 +0200
++++ cinelerra-1.2.0/cinelerra/virtualanode.C 2004-06-10 23:03:54.723589848 +0200
+@@ -492,8 +492,8 @@
+
+ PanAuto *prev_keyframe = 0;
+ PanAuto *next_keyframe = 0;
+- prev_keyframe = (PanAuto*)autos->get_prev_auto(input_position, direction, (Auto*)prev_keyframe);
+- next_keyframe = (PanAuto*)autos->get_next_auto(input_position, direction, (Auto*)next_keyframe);
++ prev_keyframe = (PanAuto*)autos->get_prev_auto(input_position, direction, (Auto*&)prev_keyframe);
++ next_keyframe = (PanAuto*)autos->get_next_auto(input_position, direction, (Auto*&)next_keyframe);
+
+ if(direction == PLAY_FORWARD)
+ {
+--- cinelerra-1.2.0/cinelerra/virtualvnode.C.orig 2004-06-10 23:04:43.955105520 +0200
++++ cinelerra-1.2.0/cinelerra/virtualvnode.C 2004-06-10 23:05:20.700519368 +0200
+@@ -315,7 +315,7 @@
+ (IntAuto*)track->automation->mode_autos->get_prev_auto(
+ start_position_project,
+ direction,
+- (Auto*)mode_keyframe);
++ (Auto*&)mode_keyframe);
+
+ int mode = mode_keyframe->value;
+
+--- cinelerra-1.2.0/cinelerra/videodevice.h.orig 2004-06-10 23:57:01.857071912 +0200
++++ cinelerra-1.2.0/cinelerra/videodevice.h 2004-06-10 23:54:45.938734640 +0200
+@@ -1,6 +1,7 @@
+ #ifndef VIDEODEVICE_H
+ #define VIDEODEVICE_H
+
++#include "../hvirtual_config.h"
+ #include "asset.inc"
+ #include "assets.inc"
+ #include "audio1394.inc"
+--- cinelerra-1.2.0/mplexhi/multplex.c.orig 2003-10-14 09:54:14.000000000 +0200
++++ cinelerra-1.2.0/mplexhi/multplex.c 2004-06-11 00:30:56.083822440 +0200
+@@ -340,7 +340,7 @@
+ bytepos_timecode ( bytes_output, current_SCR);
+ break;
+
+- default:
++ default: ;
+ }
+
+ }