summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-26 09:45:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-26 09:45:03 +0000
commit0799f6dda3b6fa6ae6d5a86f04b894ec84217221 (patch)
treeab33952bf18cfec2493e18bd75a76b9a82ff8d65 /media-video/clive/clive-1.0.2.ebuild
parentshorten description (diff)
downloadgentoo-2-0799f6dda3b6fa6ae6d5a86f04b894ec84217221.tar.gz
gentoo-2-0799f6dda3b6fa6ae6d5a86f04b894ec84217221.tar.bz2
gentoo-2-0799f6dda3b6fa6ae6d5a86f04b894ec84217221.zip
version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.3 x86_64)
Diffstat (limited to 'media-video/clive/clive-1.0.2.ebuild')
-rw-r--r--media-video/clive/clive-1.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-video/clive/clive-1.0.2.ebuild b/media-video/clive/clive-1.0.2.ebuild
new file mode 100644
index 000000000000..1fbd164be7cd
--- /dev/null
+++ b/media-video/clive/clive-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-1.0.2.ebuild,v 1.1 2008/10/26 09:45:03 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV}).x/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf $(use_with doc)
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README CHANGES
+ use doc && dohtml dox/html/*
+}