summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 12:51:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 12:51:59 +0000
commitd75ddefad368ae8875067c2984451de0f506e86e (patch)
tree31b7a95554164be73bc7fedf774a3c7f8f847ed2 /media-video/clive
parentkeyword ~x86-fbsd, bug #289983 (diff)
downloadgentoo-2-d75ddefad368ae8875067c2984451de0f506e86e.tar.gz
gentoo-2-d75ddefad368ae8875067c2984451de0f506e86e.tar.bz2
gentoo-2-d75ddefad368ae8875067c2984451de0f506e86e.zip
version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.7.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 5479edb68676..d7424b3dc415 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.57 2009/10/24 11:57:47 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.58 2009/10/27 12:51:59 aballier Exp $
+
+*clive-2.2.7 (27 Oct 2009)
+
+ 27 Oct 2009; Alexis Ballier <aballier@gentoo.org> +clive-2.2.7.ebuild:
+ version bump
24 Oct 2009; nixnut <nixnut@gentoo.org> clive-2.2.6.ebuild:
ppc stable #284544
diff --git a/media-video/clive/clive-2.2.7.ebuild b/media-video/clive/clive-2.2.7.ebuild
new file mode 100644
index 000000000000..7dc5fc9649c6
--- /dev/null
+++ b/media-video/clive/clive-2.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.7.ebuild,v 1.1 2009/10/27 12:51:59 aballier Exp $
+
+EAPI=2
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://clive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND=""
+
+SRC_TEST=do
+mydoc="TODO"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}