summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-07 21:18:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-07 21:18:15 +0000
commitf456d7f75306c4229ae6bec4852cc6b2914187da (patch)
tree5321120590948cd9be11652970722ae4f48374ee /media-video/clive
parentgnome-base/nautilus is always required since it's not only used for nautilus ... (diff)
downloadgentoo-2-f456d7f75306c4229ae6bec4852cc6b2914187da.tar.gz
gentoo-2-f456d7f75306c4229ae6bec4852cc6b2914187da.tar.bz2
gentoo-2-f456d7f75306c4229ae6bec4852cc6b2914187da.zip
version bump
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog9
-rw-r--r--media-video/clive/clive-2.2.21.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index a75516bfd13a..e1e8046db227 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.62 2010/11/15 07:25:57 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.63 2011/01/07 21:18:15 aballier Exp $
+
+*clive-2.2.21 (07 Jan 2011)
+
+ 07 Jan 2011; Alexis Ballier <aballier@gentoo.org> +clive-2.2.21.ebuild:
+ version bump
*clive-2.2.17 (15 Nov 2010)
diff --git a/media-video/clive/clive-2.2.21.ebuild b/media-video/clive/clive-2.2.21.ebuild
new file mode 100644
index 000000000000..f9d8a2a96ff7
--- /dev/null
+++ b/media-video/clive/clive-2.2.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.21.ebuild,v 1.1 2011/01/07 21:18:15 aballier Exp $
+
+EAPI=2
+
+inherit perl-app versionator
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND="test? ( dev-perl/Test-Pod
+ ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}