summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-11-16 14:35:45 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-11-16 14:35:45 +0000
commit6d3c27437327a5ed915bd7c8db2c88c7d26d2066 (patch)
tree6bf37e366dad7ece32e76ca201ba47f236c9776c /media-video/em8300-modules
parentDon't run grep in global scope of init script (bug #279477) (diff)
downloadgentoo-2-6d3c27437327a5ed915bd7c8db2c88c7d26d2066.tar.gz
gentoo-2-6d3c27437327a5ed915bd7c8db2c88c7d26d2066.tar.bz2
gentoo-2-6d3c27437327a5ed915bd7c8db2c88c7d26d2066.zip
Version bump. Thanks to Helmut Auer <helmut@helmutauer.de>.
(Portage version: 2.2_rc50/cvs/Linux i686)
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog8
-rw-r--r--media-video/em8300-modules/em8300-modules-0.17.4.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index 687b98a2c7cf..e8280f7f8159 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-modules
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.50 2009/06/18 15:11:51 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.51 2009/11/16 14:35:45 zzam Exp $
+
+*em8300-modules-0.17.4 (16 Nov 2009)
+
+ 16 Nov 2009; Matthias Schwarzott <zzam@gentoo.org>
+ +em8300-modules-0.17.4.ebuild:
+ Version bump. Thanks to Helmut Auer <helmut@helmutauer.de>.
*em8300-modules-0.17.2-r1 (18 Jun 2009)
diff --git a/media-video/em8300-modules/em8300-modules-0.17.4.ebuild b/media-video/em8300-modules/em8300-modules-0.17.4.ebuild
new file mode 100644
index 000000000000..9c764c90ad8d
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.17.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.17.4.ebuild,v 1.1 2009/11/16 14:35:45 zzam Exp $
+
+inherit eutils linux-mod
+
+MY_P="${P/-modules/}"
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${MY_P}.tar.gz"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CONFIG_CHECK="I2C_ALGOBIT"
+MODULE_NAMES="em8300(video:) bt865(video:) adv717x(video:)"
+
+S="${WORKDIR}/${MY_P}/modules"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/.."
+# epatch "${FILESDIR}/${P}-kernel-2.6.30.patch"
+}
+
+src_compile() {
+ set_arch_to_kernel
+ cd "${S}"
+ emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README-modoptions README-modules.conf
+
+ newsbin devices.sh em8300-devices.sh
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/modules.em8300 em8300.conf
+
+ insinto /etc/udev/rules.d
+ newins em8300-udev.rules 15-em8300.rules
+}
+
+pkg_preinst() {
+ linux-mod_pkg_preinst
+
+ local old1="${ROOT}/etc/modprobe.d/em8300"
+ local old2="${ROOT}/etc/modules.d/em8300"
+ local new="${ROOT}/etc/modprobe.d/em8300.conf"
+
+ if [[ ! -a ${new} ]]; then
+ if [[ -a ${old1} ]]; then
+ elog "Renaming em8300-modprobe configuration to em8300.conf"
+ mv "${old1}" "${new}"
+ elif [[ -a ${old2} ]]; then
+ elog "Moving old em8300 configuration in /etc/modules.d to new"
+ elog "location in /etc/modprobe.d"
+ mv "${old2}" "${new}"
+ fi
+ fi
+}