summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-03-16 22:34:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-03-16 22:34:43 +0000
commit7ae86c2db8fbd3140525354dc8cf8651c0ae24ce (patch)
tree9530dbd5002823de8cdbba6e18309f2388da153c /media-video/ffmpeg/ffmpeg-9999.ebuild
parentremoving unneeded deps (diff)
downloadgentoo-2-7ae86c2db8fbd3140525354dc8cf8651c0ae24ce.tar.gz
gentoo-2-7ae86c2db8fbd3140525354dc8cf8651c0ae24ce.tar.bz2
gentoo-2-7ae86c2db8fbd3140525354dc8cf8651c0ae24ce.zip
add webp useflag
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-9999.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 08ce3108cfa3..6e422ddf418b 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.151 2014/03/15 09:17:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.152 2014/03/16 22:34:43 aballier Exp $
EAPI="5"
@@ -46,7 +46,7 @@ IUSE="
ladspa libass libcaca libsoxr libv4l modplug mp3 +network openal opengl
openssl opus oss pic pulseaudio quvi rtmp schroedinger sdl speex ssh
static-libs test theora threads truetype twolame v4l vaapi vdpau vorbis vpx
- wavpack X x264 x265 xvid +zlib zvbi
+ wavpack webp X x264 x265 xvid +zlib zvbi
"
ARM_CPU_FEATURES="armv5te armv6 armv6t2 neon armvfp:vfp"
@@ -89,6 +89,7 @@ RDEPEND="
theora? ( >=media-libs/libtheora-1.1.1[encode] media-libs/libogg )
twolame? ( media-sound/twolame )
wavpack? ( media-sound/wavpack )
+ webp? ( media-libs/libwebp )
x264? ( >=media-libs/x264-0.0.20111017:= )
x265? ( >=media-libs/x265-0.9:= )
xvid? ( >=media-libs/xvid-1.1.0 )
@@ -182,7 +183,7 @@ src_configure() {
if use encode
then
ffuse="${ffuse} aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame"
- for i in aacplus faac theora twolame wavpack x264 x265 xvid; do
+ for i in aacplus faac theora twolame wavpack webp x264 x265 xvid; do
ffuse="${ffuse} ${i}:lib${i}"
done