summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-15 11:38:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-15 11:38:29 +0000
commit4a116ddb2875a11f8a1616a76c3543d19831fcc2 (patch)
treea623778b8316e6edd476399a6850a9d215f4a0b0 /media-video/ffmpeg
parentversion bump (diff)
downloadgentoo-2-4a116ddb2875a11f8a1616a76c3543d19831fcc2.tar.gz
gentoo-2-4a116ddb2875a11f8a1616a76c3543d19831fcc2.tar.bz2
gentoo-2-4a116ddb2875a11f8a1616a76c3543d19831fcc2.zip
add avconv useflag
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild16
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 15 insertions, 8 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 1a7bd869eb5b..7e17d26c2da6 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.508 2011/12/15 11:30:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.509 2011/12/15 11:38:29 aballier Exp $
+
+ 15 Dec 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add avconv useflag
*ffmpeg-0.9 (15 Dec 2011)
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 07182db34393..858c187a1a47 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.71 2011/12/15 11:25:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.72 2011/12/15 11:38:29 aballier Exp $
EAPI="4"
@@ -29,11 +29,11 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
IUSE="
- aac aacplus alsa amr ass bindist +bzip2 cdio celt cpudetection debug dirac doc
- +encode faac frei0r gnutls gsm +hardcoded-tables ieee1394 jack jpeg2k libv4l
- modplug mp3 network openal openssl oss pic pulseaudio +qt-faststart rtmp
- schroedinger sdl speex static-libs test theora threads truetype v4l vaapi
- vdpau vorbis vpx X x264 xvid +zlib
+ aac aacplus alsa amr ass avconv bindist +bzip2 cdio celt cpudetection debug
+ dirac doc +encode faac frei0r gnutls gsm +hardcoded-tables ieee1394 jack
+ jpeg2k libv4l modplug mp3 network openal openssl oss pic pulseaudio
+ +qt-faststart rtmp schroedinger sdl speex static-libs test theora threads
+ truetype v4l vaapi vdpau vorbis vpx X x264 xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -126,7 +126,9 @@ src_configure() {
use cpudetection && myconf="${myconf} --enable-runtime-cpudetect"
use openssl && myconf="${myconf} --enable-openssl --enable-nonfree"
- use gnutls && myconf="${myconf} --enable-gnutls"
+ for i in gnutls avconv ; do
+ use $i && myconf="${myconf} --enable-$i"
+ done
# Encoders
if use encode
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 6d07f0ea17e8..f15c4b8ea9d0 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -14,6 +14,7 @@
<flag name="ass">Enables <pkg>media-libs/libass</pkg> based subtitle renderer.</flag>
<flag name="aacplus">AAC+ encoding via <pkg>media-libs/libaacplus</pkg>.</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
+ <flag name="avconv">Build and install avconv, an alternative command line tool to ffmpeg from <pkg>media-video/libav</pkg>.</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>
<flag name="celt">Adds Xiph CELT/Opus audio decoding support via <pkg>media-libs/celt</pkg></flag>