summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-22 05:09:09 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-22 05:09:09 +0000
commit7b16ad7de3d15ff8fca1f2fbffc3637ceddc4276 (patch)
tree3f28551e686bba060befa1d56c4902f8c61d87cb /media-video/h264enc/h264enc-9.4.0.ebuild
parentwhitespace (diff)
downloadgentoo-2-7b16ad7de3d15ff8fca1f2fbffc3637ceddc4276.tar.gz
gentoo-2-7b16ad7de3d15ff8fca1f2fbffc3637ceddc4276.tar.bz2
gentoo-2-7b16ad7de3d15ff8fca1f2fbffc3637ceddc4276.zip
Version bump and remove old.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-video/h264enc/h264enc-9.4.0.ebuild')
-rw-r--r--media-video/h264enc/h264enc-9.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/h264enc/h264enc-9.4.0.ebuild b/media-video/h264enc/h264enc-9.4.0.ebuild
new file mode 100644
index 000000000000..755642d5a6de
--- /dev/null
+++ b/media-video/h264enc/h264enc-9.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/h264enc/h264enc-9.4.0.ebuild,v 1.1 2011/08/22 05:09:09 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Script to encode H.264/AVC/MPEG-4 Part 10 formats"
+HOMEPAGE="http://h264enc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac dvd flac lame matroska mp4 ogm vorbis"
+
+RDEPEND="
+ media-video/mplayer[encode,x264]
+ sys-apps/coreutils
+ sys-apps/pv
+ sys-devel/bc
+ sys-process/time
+ aac? (
+ media-libs/faac
+ media-sound/aacplusenc )
+ dvd? ( media-video/lsdvd )
+ flac? ( media-libs/flac )
+ lame? ( media-sound/lame )
+ matroska? ( media-video/mkvtoolnix )
+ mp4? ( >=media-video/gpac-0.4.5[a52] )
+ ogm? ( media-sound/ogmtools )
+ vorbis? ( media-sound/vorbis-tools )"
+DEPEND=""
+
+src_install() {
+ dobin ${PN}
+ doman man/${PN}.1
+ dodoc doc/*
+ docinto matrices
+ dodoc matrices/*
+}