summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-30 13:36:44 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-30 13:36:44 +0000
commit1726aa492f093edebc2de4ae868ccae8cd5a4827 (patch)
tree5f8d5e618322eae2a71a10b82e3e683a603b5dbf /media-video/kino
parentrobbat2 forgot to move mini-qmail to mail-mta too.. (diff)
downloadgentoo-2-1726aa492f093edebc2de4ae868ccae8cd5a4827.tar.gz
gentoo-2-1726aa492f093edebc2de4ae868ccae8cd5a4827.tar.bz2
gentoo-2-1726aa492f093edebc2de4ae868ccae8cd5a4827.zip
added gcc 3.4 fix. thanks to Malcolm Lashley for submitting it.
Diffstat (limited to 'media-video/kino')
-rw-r--r--media-video/kino/ChangeLog6
-rw-r--r--media-video/kino/files/kino_gcc34_fix12
-rw-r--r--media-video/kino/kino-0.7.1.ebuild7
3 files changed, 23 insertions, 2 deletions
diff --git a/media-video/kino/ChangeLog b/media-video/kino/ChangeLog
index a83065fdfb91..7f32d63a87bd 100644
--- a/media-video/kino/ChangeLog
+++ b/media-video/kino/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/kino
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.17 2004/05/11 17:18:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.18 2004/05/30 13:36:44 lv Exp $
+
+ 30 May 2004; Travis Tilley <lv@gentoo.org> +files/kino_gcc34_fix,
+ kino-0.7.1.ebuild:
+ added gcc 3.4 fix. thanks to Malcolm Lashley for submitting it.
11 May 2004; Patrick Kursawe <phosphan@gentoo.org> kino-0.7.1.ebuild:
Bumped gnome dependencies to 2.x, see bug #36242
diff --git a/media-video/kino/files/kino_gcc34_fix b/media-video/kino/files/kino_gcc34_fix
new file mode 100644
index 000000000000..62f3f3e1bb18
--- /dev/null
+++ b/media-video/kino/files/kino_gcc34_fix
@@ -0,0 +1,12 @@
+diff -Naur kino-0.7.1-orig/src/ieee1394io.h kino-0.7.1/src/ieee1394io.h
+--- kino-0.7.1-orig/src/ieee1394io.h 2004-05-30 09:30:00.195549632 +0100
++++ kino-0.7.1/src/ieee1394io.h 2004-05-30 09:30:20.897402472 +0100
+@@ -33,7 +33,7 @@
+
+ class IEEE1394Reader
+ {
+-private:
++protected:
+ /// the number of frames that had to be thrown away because
+ /// our inFrames queue did not contain available frames
+ static int droppedFrames;
diff --git a/media-video/kino/kino-0.7.1.ebuild b/media-video/kino/kino-0.7.1.ebuild
index 84997cd485b2..216d38b80e6e 100644
--- a/media-video/kino/kino-0.7.1.ebuild
+++ b/media-video/kino/kino-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-0.7.1.ebuild,v 1.3 2004/05/11 17:18:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-0.7.1.ebuild,v 1.4 2004/05/30 13:36:44 lv Exp $
DESCRIPTION="Kino is a non-linear DV editor for GNU/Linux"
HOMEPAGE="http://kino.schirmacher.de/"
@@ -26,6 +26,11 @@ DEPEND="x11-libs/gtk+
media-libs/libsamplerate
quicktime? ( virtual/quicktime )"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/kino_gcc34_fix
+}
+
src_compile() {
econf \
--disable-dependency-tracking \