summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-09-29 08:46:14 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-09-29 08:46:14 +0000
commita52c33fed91bccb769d7e60c3729b5ee10b2812b (patch)
tree4bc7bd633938d8c7563fd19a401a5f20910eb81b /media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild
parentInitial import. (diff)
downloadgentoo-2-a52c33fed91bccb769d7e60c3729b5ee10b2812b.tar.gz
gentoo-2-a52c33fed91bccb769d7e60c3729b5ee10b2812b.tar.bz2
gentoo-2-a52c33fed91bccb769d7e60c3729b5ee10b2812b.zip
Initial import.
Diffstat (limited to 'media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild')
-rw-r--r--media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild b/media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild
new file mode 100644
index 000000000000..ae21fd2090a7
--- /dev/null
+++ b/media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/linuxvideostudio/linuxvideostudio-0.1.7.ebuild,v 1.1 2003/09/29 08:46:09 phosphan Exp $
+
+DESCRIPTION="small-'n-simple GUI for the MJPEG-tools"
+HOMEPAGE="http://ronald.bitfreak.net/"
+SRC_URI="http://ronald.bitfreak.net/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="lirc"
+
+DEPEND=">=media-video/mjpegtools-1.6.0-r7
+ =x11-libs/gtk+-1.2*
+ media-libs/libpng
+ media-libs/jpeg
+ lirc? ( app-misc/lirc )"
+
+src_compile() {
+ local myconf
+ # setting the --with-lircd option somehow makes the test fail
+ if [ -z $(use lirc) ]; then
+ myconf="--without-lircd"
+ fi
+ econf $myconf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog README TODO README.stv ChangeLog.stv INSTALL.stv INSTALL
+}