summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-07-31 20:43:25 +0000
committerSteve Dibb <beandog@gentoo.org>2009-07-31 20:43:25 +0000
commitc2d34973335e7dd8d3060f41bfe5551ca2e2e770 (patch)
tree0ef4c8648b6122f714b677fbdcb2ba6e19163e4d /media-video/mplayer/mplayer-9999.ebuild
parentold (diff)
downloadgentoo-2-c2d34973335e7dd8d3060f41bfe5551ca2e2e770.tar.gz
gentoo-2-c2d34973335e7dd8d3060f41bfe5551ca2e2e770.tar.bz2
gentoo-2-c2d34973335e7dd8d3060f41bfe5551ca2e2e770.zip
Snapshot bump, add --language* options to check for correct LINGUAS variable to use for messages, documentation
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/mplayer/mplayer-9999.ebuild')
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 598f7ebaf4bb..99aeda03748c 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.11 2009/07/27 06:56:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.12 2009/07/31 20:43:25 beandog Exp $
EAPI="2"
@@ -279,7 +279,13 @@ src_configure() {
# MPlayer reads in the LINGUAS variable from make.conf, and sets
# the languages accordingly. Some will have to be altered to match
# upstream's naming scheme.
- [[ -n $LINGUAS ]] && LINGUAS="${LINGUAS/da/dk}"
+ if [[ -n $LINGUAS ]]; then
+ LINGUAS="${LINGUAS/da/dk}"
+ available_linguas=$(echo $LINGUAS | awk '{ print $1 }')
+ myconf_linguas=$(echo $LINGUAS | sed s/\ /,/)
+ myconf="${myconf} --language=${available_linguas} \
+ --language-doc=${myconf_linguas} --language-man=${myconf_linguas}"
+ fi
# mplayer ebuild uses "use foo || --disable-foo" to forcibly disable
# compilation in almost every situation. The reason for this is
@@ -560,7 +566,7 @@ src_configure() {
--libdir=/usr/$(get_libdir) \
${myconf}"
- #echo "CFLAGS=\"${CFLAGS}\" ./configure ${myconf}"
+ echo "CFLAGS=\"${CFLAGS}\" ./configure ${myconf}"
CFLAGS="${CFLAGS}" ./configure ${myconf} || die "configure died"
}