summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-03 01:42:22 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-03 01:42:22 +0000
commit7a6f6237b23b696e233c397acc0d48f5e0c84892 (patch)
tree9491631aa99ff8a539d2f9625622a83626de905c /media-video/nvtv
parentNew ebuild. (diff)
downloadgentoo-2-7a6f6237b23b696e233c397acc0d48f5e0c84892.tar.gz
gentoo-2-7a6f6237b23b696e233c397acc0d48f5e0c84892.tar.bz2
gentoo-2-7a6f6237b23b696e233c397acc0d48f5e0c84892.zip
Initial version of the ebuild, submitted by blauwers@cisco.com (Bart
Lauwers). Closes bug #2371.
Diffstat (limited to 'media-video/nvtv')
-rw-r--r--media-video/nvtv/ChangeLog13
-rw-r--r--media-video/nvtv/files/digest-nvtv-0.3.01
-rw-r--r--media-video/nvtv/files/nvtv.start21
-rw-r--r--media-video/nvtv/nvtv-0.3.0.ebuild44
4 files changed, 79 insertions, 0 deletions
diff --git a/media-video/nvtv/ChangeLog b/media-video/nvtv/ChangeLog
new file mode 100644
index 000000000000..64ca04a55f58
--- /dev/null
+++ b/media-video/nvtv/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-video/nvtv
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvtv/ChangeLog,v 1.1 2002/05/03 01:42:22 agenkin Exp $
+
+*nvtv-0.3.0-0 (03 May 2002)
+
+ 3 May 2002; Arcady Genkin <agenkin@thpoon.com> nvtv-0.3.0.ebuild :
+
+ Cleaned up a few things.
+
+ 3 May 2002; B.Lauwers <blauwers@cisco.com> ChangeLog, nvtv-0.3.0.ebuild :
+
+ Intial ebuild for nvtv from http://sourceforge.net/projects/nv-tv-out
diff --git a/media-video/nvtv/files/digest-nvtv-0.3.0 b/media-video/nvtv/files/digest-nvtv-0.3.0
new file mode 100644
index 000000000000..ff96fbd745a1
--- /dev/null
+++ b/media-video/nvtv/files/digest-nvtv-0.3.0
@@ -0,0 +1 @@
+MD5 1b5fb56588e9f54e055a3b81214b6ff5 nvtv-0.3.0.tar.gz 182683
diff --git a/media-video/nvtv/files/nvtv.start b/media-video/nvtv/files/nvtv.start
new file mode 100644
index 000000000000..a96a5c9695c6
--- /dev/null
+++ b/media-video/nvtv/files/nvtv.start
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/x11-base/xfree/files/4.2.0-r8/xfs.start,v 1.1 2002/03/14 23:52:57 azarah Exp
+
+depend() {
+ use modules logger
+}
+
+start() {
+ ebegin "Starting NVidia TV-Out Server"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nvtvd \
+ --background 1>&2
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NVidia TV-Out Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nvtvd 1>&2
+ eend $?
+}
diff --git a/media-video/nvtv/nvtv-0.3.0.ebuild b/media-video/nvtv/nvtv-0.3.0.ebuild
new file mode 100644
index 000000000000..8ea89b36327e
--- /dev/null
+++ b/media-video/nvtv/nvtv-0.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Lauwers <blauwers@cisco.com>
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvtv/nvtv-0.3.0.ebuild,v 1.1 2002/05/03 01:42:22 agenkin Exp $
+
+DESCRIPTION="TV-Out for NVidia cards."
+HOMEPAGE="http://sourceforge.net/projects/nv-tv-out"
+LICENSE="GPL-2"
+
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/nv-tv-out/${P}.tar.gz"
+
+DEPEND="sys-apps/pciutils"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+ cd src
+
+ use gtk && myconf="${myconf} --with-gtk" || myconf="${myconf} --without-gtk"
+ use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ # The CFLAGS don't seem to make it into the Makefile.
+ emake CXFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin src/nvtv
+ dosbin src/nvtvd
+
+ dodoc ANNOUNCE BUGS FAQ INSTALL README \
+ doc/USAGE doc/XFREE doc/chips.txt \
+ doc/overview.txt doc/timing.txt xine/tvxine
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nvtv.start nvtv
+}