summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-05-14 23:30:20 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-05-14 23:30:20 +0000
commit494c4ad871ba6622931a1e91ed14cf503d60407d (patch)
treed3256f4b3d2fb10f29bc70e586f0a78007e7f7e8 /media-video/qdvdauthor
parentDepend on virtual/pam as the code builds fine with OpenPAM. (diff)
downloadgentoo-2-494c4ad871ba6622931a1e91ed14cf503d60407d.tar.gz
gentoo-2-494c4ad871ba6622931a1e91ed14cf503d60407d.tar.bz2
gentoo-2-494c4ad871ba6622931a1e91ed14cf503d60407d.zip
removed old version.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog6
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild87
2 files changed, 5 insertions, 88 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 2c3c39356a8f..b6a642a92c1d 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/qdvdauthor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.21 2008/03/26 22:29:43 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.22 2008/05/14 23:30:20 sbriesen Exp $
+
+ 14 May 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ -qdvdauthor-1.0.0_rc3.ebuild:
+ removed old version.
26 Mar 2008; Stefan Briesenick <sbriesen@gentoo.org> Manifest:
fixed checksums + uploaded correct tarball to mirrors (solves bug
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild
deleted file mode 100644
index 1e1250e1d104..000000000000
--- a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0_rc3.ebuild,v 1.1 2008/01/06 03:16:34 sbriesen Exp $
-
-inherit eutils flag-o-matic qt3
-
-DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
-HOMEPAGE="http://qdvdauthor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qdvdauthor/${P/_rc/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xine mplayer"
-
-DEPEND=">=media-video/dvdauthor-0.6.11
- >=media-gfx/imagemagick-6.1.8.8
- >=media-video/mjpegtools-1.6.2
- >=media-video/dvd-slideshow-0.7.2
- xine? ( >=media-libs/xine-lib-1.1.0 )
- mplayer? ( media-video/mplayer )
- !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
- $(qt_min_version 3.2)"
-
-RDEPEND="${DEPEND}
- media-libs/netpbm
- media-video/videotrans
- media-sound/toolame
- media-sound/lame
- media-sound/sox"
-
-S="${WORKDIR}/${P/_rc*/}"
-
-# TODO:
-# media-video/dvd-slideshow -> optional
-# installing further tools -> needs evaluation
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # do not over-optimize (see bug #147250)
- replace-flags -O? -O2
- filter-flags -finline-functions
-
- # set our C(XX)FLAGS
- for PRO in */*.pro */*/*.pro; do
- echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
- echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
- done
-
- # full-qualify qmake in configure and append -nocache (see bug #118697)
- sed -i -e "s:make;\?[[:space:]]*\$:make ${MAKEOPTS};:g" \
- -e "s:\(/qmake\):\1 -nocache QMAKE=\$QTDIR/bin/qmake:g" configure
-
- # fixing defaults from /usr/local/bin to gentoo default /usr/bin
- sed -i -e "s:/usr/local/bin:/usr/bin:g" doc/sound.txt \
- qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp
-}
-
-src_compile() {
- local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
-
- # select backend (VLC is currently broken)
- #use vlc && myconf="${myconf} --with-vlc-support"
- use xine && myconf="${myconf} --with-xine-support"
- use mplayer && myconf="${myconf} --with-mplayer-support"
-
- # if no backend selected, use XINE as default
- if ! use xine && ! use mplayer; then
- myconf="${myconf} --with-xine-support"
- fi
-
- ./configure --qt-dir="${QTDIR}" ${myconf} || die "configure failed"
-}
-
-src_install() {
- make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
- make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
- make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
-
- dobin bin/{qdvdauthor,qslideshow,qplayer}
- dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
-
- domenu qdvdauthor.desktop
- doicon qdvdauthor.png
-}