summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-03-17 22:16:28 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-03-17 22:16:28 +0000
commit871c7e31494b6486f5d28ab3cd3ba3b913270881 (patch)
treea68d31a313873cde015e80b9d7d37a8797dca733 /media-video/qdvdauthor
parentAdd ~alpha/~sparc wrt #213496 (diff)
downloadgentoo-2-871c7e31494b6486f5d28ab3cd3ba3b913270881.tar.gz
gentoo-2-871c7e31494b6486f5d28ab3cd3ba3b913270881.tar.bz2
gentoo-2-871c7e31494b6486f5d28ab3cd3ba3b913270881.zip
some cleaups + removed old versions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog7
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild86
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild10
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0_rc1.ebuild89
-rw-r--r--media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild87
5 files changed, 11 insertions, 268 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
index 38e7d7b3b6fa..64efc72555a7 100644
--- a/media-video/qdvdauthor/ChangeLog
+++ b/media-video/qdvdauthor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/qdvdauthor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.19 2008/03/16 22:31:44 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.20 2008/03/17 22:16:28 sbriesen Exp $
+
+ 17 Mar 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ -qdvdauthor-0.1.4-r1.ebuild, -qdvdauthor-1.0.0_rc1.ebuild,
+ -qdvdauthor-1.0.0_rc2.ebuild, qdvdauthor-1.0.0.ebuild:
+ some cleaups + removed old versions.
*qdvdauthor-1.0.0 (16 Mar 2008)
diff --git a/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild b/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild
deleted file mode 100644
index 91be83d20403..000000000000
--- a/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.1.4-r1.ebuild,v 1.1 2007/02/10 23:45:51 sbriesen Exp $
-
-inherit eutils flag-o-matic qt3
-
-DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
-HOMEPAGE="http://qdvdauthor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qdvdauthor/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xine mplayer"
-
-DEPEND=">=media-video/dvdauthor-0.6.11
- >=media-gfx/imagemagick-6.1.8.8
- >=media-video/mjpegtools-1.6.2
- >=media-video/dvd-slideshow-0.7.2
- xine? ( >=media-libs/xine-lib-1.1.0 )
- mplayer? ( media-video/mplayer )
- !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
- $(qt_min_version 3.2)"
-
-RDEPEND="${DEPEND}
- media-libs/netpbm
- media-video/videotrans
- media-sound/toolame
- media-sound/lame
- media-sound/sox"
-
-# TODO:
-# media-video/dvd-slideshow -> optional
-# installing further tools -> needs evaluation
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # do not over-optimize (see bug #147250)
- replace-flags -O? -O2
- filter-flags -finline-functions
-
- # set our C(XX)FLAGS
- for PRO in */*.pro */*/*.pro; do
- echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
- echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
- done
-
- # full-qualify qmake in configure and append -nocache (see bug #118697)
- sed -i -e "s:make;:make ${MAKEOPTS};:g" \
- -e "s:qmake:\${QTDIR}/bin/qmake -nocache QMAKE=\${QTDIR}/bin/qmake:g" configure
-
- # fixing defaults from /usr/local/bin to gentoo default /usr/bin
- sed -i "s:/usr/local/bin:/usr/bin:g" qdvdauthor/qdvdauthor.cpp \
- qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp doc/sound.txt
-}
-
-src_compile() {
- local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
-
- # select backend (VLC is currently broken)
- #use vlc && myconf="${myconf} --with-vlc-support"
- use xine && myconf="${myconf} --with-xine-support"
- use mplayer && myconf="${myconf} --with-mplayer-support"
-
- # if no backend selected, use XINE as default
- if ! use xine && ! use mplayer; then
- myconf="${myconf} --with-xine-support"
- fi
-
- ./configure ${myconf} || die "configure failed"
-}
-
-src_install() {
- make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
- make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
- make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
-
- dobin bin/{qdvdauthor,qslideshow,qplayer}
- dodoc CHANGELOG README TODO doc/{ISO_639,lookinto,render*,sound*,todo*}.txt
- dohtml doc/html/en/*
-
- domenu qdvdauthor.desktop
- doicon qdvdauthor.png
-}
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild
index 582e96efedf7..e5f941ed36b3 100644
--- a/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild
+++ b/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild,v 1.1 2008/03/16 22:31:44 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0.ebuild,v 1.2 2008/03/17 22:16:28 sbriesen Exp $
inherit eutils flag-o-matic qt3
@@ -38,7 +38,7 @@ src_unpack() {
cd "${S}"
# do not over-optimize (see bug #147250)
- replace-flags -O? -O2
+ replace-flags -O[s3] -O2
filter-flags -finline-functions
# set our C(XX)FLAGS
@@ -73,9 +73,9 @@ src_compile() {
}
src_install() {
- make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
- make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
- make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
+ emake -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
+ emake -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
+ emake -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
dobin bin/{qdvdauthor,qslideshow,qplayer}
dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc1.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc1.ebuild
deleted file mode 100644
index 236c38c9a06b..000000000000
--- a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0_rc1.ebuild,v 1.1 2007/05/16 06:10:56 sbriesen Exp $
-
-inherit eutils flag-o-matic qt3
-
-MY_P="${P/_rc*/}"
-
-DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
-HOMEPAGE="http://qdvdauthor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qdvdauthor/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xine mplayer"
-
-DEPEND=">=media-video/dvdauthor-0.6.11
- >=media-gfx/imagemagick-6.1.8.8
- >=media-video/mjpegtools-1.6.2
- >=media-video/dvd-slideshow-0.7.2
- xine? ( >=media-libs/xine-lib-1.1.0 )
- mplayer? ( media-video/mplayer )
- !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
- $(qt_min_version 3.2)"
-
-RDEPEND="${DEPEND}
- media-libs/netpbm
- media-video/videotrans
- media-sound/toolame
- media-sound/lame
- media-sound/sox"
-
-S="${WORKDIR}/${MY_P}"
-
-# TODO:
-# media-video/dvd-slideshow -> optional
-# installing further tools -> needs evaluation
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # do not over-optimize (see bug #147250)
- replace-flags -O? -O2
- filter-flags -finline-functions
-
- # set our C(XX)FLAGS
- for PRO in */*.pro */*/*.pro; do
- echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
- echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
- done
-
- # full-qualify qmake in configure and append -nocache (see bug #118697)
- sed -i -e "s:make;\?[[:space:]]*\$:make ${MAKEOPTS};:g" \
- -e "s:\(/qmake\):\1 -nocache QMAKE=\$QTDIR/bin/qmake:g" configure
-
- # fixing defaults from /usr/local/bin to gentoo default /usr/bin
- sed -i -e "s:/usr/local/bin:/usr/bin:g" doc/sound.txt \
- qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp
-}
-
-src_compile() {
- local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
-
- # select backend (VLC is currently broken)
- #use vlc && myconf="${myconf} --with-vlc-support"
- use xine && myconf="${myconf} --with-xine-support"
- use mplayer && myconf="${myconf} --with-mplayer-support"
-
- # if no backend selected, use XINE as default
- if ! use xine && ! use mplayer; then
- myconf="${myconf} --with-xine-support"
- fi
-
- ./configure --qt-dir="${QTDIR}" ${myconf} || die "configure failed"
-}
-
-src_install() {
- make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
- make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
- make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
-
- dobin bin/{qdvdauthor,qslideshow,qplayer}
- dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
-
- domenu qdvdauthor.desktop
- doicon qdvdauthor.png
-}
diff --git a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild b/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild
deleted file mode 100644
index 0833441fae68..000000000000
--- a/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-1.0.0_rc2.ebuild,v 1.1 2007/11/18 01:38:47 sbriesen Exp $
-
-inherit eutils flag-o-matic qt3
-
-DESCRIPTION="'Q' DVD-Author is a GUI frontend for dvdauthor written in Qt"
-HOMEPAGE="http://qdvdauthor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qdvdauthor/${P/_rc/-}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xine mplayer"
-
-DEPEND=">=media-video/dvdauthor-0.6.11
- >=media-gfx/imagemagick-6.1.8.8
- >=media-video/mjpegtools-1.6.2
- >=media-video/dvd-slideshow-0.7.2
- xine? ( >=media-libs/xine-lib-1.1.0 )
- mplayer? ( media-video/mplayer )
- !xine? ( !mplayer? ( >=media-libs/xine-lib-1.1.0 ) )
- $(qt_min_version 3.2)"
-
-RDEPEND="${DEPEND}
- media-libs/netpbm
- media-video/videotrans
- media-sound/toolame
- media-sound/lame
- media-sound/sox"
-
-S="${WORKDIR}/${P/_rc*/}"
-
-# TODO:
-# media-video/dvd-slideshow -> optional
-# installing further tools -> needs evaluation
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # do not over-optimize (see bug #147250)
- replace-flags -O? -O2
- filter-flags -finline-functions
-
- # set our C(XX)FLAGS
- for PRO in */*.pro */*/*.pro; do
- echo "QMAKE_CFLAGS_RELEASE = ${CFLAGS}" >> "${PRO}"
- echo "QMAKE_CXXFLAGS_RELEASE = ${CXXFLAGS}" >> "${PRO}"
- done
-
- # full-qualify qmake in configure and append -nocache (see bug #118697)
- sed -i -e "s:make;\?[[:space:]]*\$:make ${MAKEOPTS};:g" \
- -e "s:\(/qmake\):\1 -nocache QMAKE=\$QTDIR/bin/qmake:g" configure
-
- # fixing defaults from /usr/local/bin to gentoo default /usr/bin
- sed -i -e "s:/usr/local/bin:/usr/bin:g" doc/sound.txt \
- qdvdauthor/dialog*.cpp qdvdauthor/qslideshow/dialog*.cpp
-}
-
-src_compile() {
- local myconf="--prefix=/usr --build-qplayer --build-qslideshow"
-
- # select backend (VLC is currently broken)
- #use vlc && myconf="${myconf} --with-vlc-support"
- use xine && myconf="${myconf} --with-xine-support"
- use mplayer && myconf="${myconf} --with-mplayer-support"
-
- # if no backend selected, use XINE as default
- if ! use xine && ! use mplayer; then
- myconf="${myconf} --with-xine-support"
- fi
-
- ./configure --qt-dir="${QTDIR}" ${myconf} || die "configure failed"
-}
-
-src_install() {
- make -C qdvdauthor INSTALL_ROOT="${D}" install || die "qdvdauthor install failed"
- make -C qdvdauthor/qslideshow INSTALL_ROOT="${D}" install || die "qslideshow install failed"
- make -C qdvdauthor/qplayer INSTALL_ROOT="${D}" install || die "qplayer install failed"
-
- dobin bin/{qdvdauthor,qslideshow,qplayer}
- dodoc CHANGELOG README TODO doc/{ISO*,look*,sound*,todo*,render*}.txt
-
- domenu qdvdauthor.desktop
- doicon qdvdauthor.png
-}