summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-08 09:46:07 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-08 09:46:07 +0000
commite2abb3b99f279e63c63f90a260414ae6b4e0cd90 (patch)
treeef935e98690595512afef1d3e12932918bf75fba /media-video/spca5xx/spca5xx-20060402.ebuild
parentadd load path correctly, fixes bug 169588, reported by Ulrich Mueller <ulm@kp... (diff)
downloadgentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.tar.gz
gentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.tar.bz2
gentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.zip
Do not use pkg_setup vars before pkg_setup, bug 168051
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-video/spca5xx/spca5xx-20060402.ebuild')
-rw-r--r--media-video/spca5xx/spca5xx-20060402.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-video/spca5xx/spca5xx-20060402.ebuild b/media-video/spca5xx/spca5xx-20060402.ebuild
index 8322482e7543..8f18be0ad20a 100644
--- a/media-video/spca5xx/spca5xx-20060402.ebuild
+++ b/media-video/spca5xx/spca5xx-20060402.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060402.ebuild,v 1.1 2006/04/14 15:54:11 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060402.ebuild,v 1.2 2007/03/08 09:46:07 genstef Exp $
inherit linux-mod
@@ -16,9 +16,13 @@ DEPEND=""
RDEPEND=""
MODULE_NAMES="spca5xx(usb/video:)"
-BUILD_PARAMS="KERNELDIR=${KV_DIR}"
BUILD_TARGETS="default"
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
src_unpack() {
unpack ${A}
convert_to_m ${S}/Makefile