summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-03-23 14:33:10 +0000
committerSimon Stelling <blubb@gentoo.org>2005-03-23 14:33:10 +0000
commite4f7c00091348cffa0c5b3285f508e21bf6fb61a (patch)
tree28c40362f648b12b5c420e9d1b07de42b05e551f /media-video/sswf/sswf-1.7.1.ebuild
parentKeyworded ~sparc wrt #84992 (diff)
downloadgentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.tar.gz
gentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.tar.bz2
gentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.zip
#83996
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/sswf/sswf-1.7.1.ebuild')
-rw-r--r--media-video/sswf/sswf-1.7.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-video/sswf/sswf-1.7.1.ebuild b/media-video/sswf/sswf-1.7.1.ebuild
index 89e3cbec3eef..709b31d46145 100644
--- a/media-video/sswf/sswf-1.7.1.ebuild
+++ b/media-video/sswf/sswf-1.7.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/sswf-1.7.1.ebuild,v 1.2 2005/03/19 01:12:52 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/sswf-1.7.1.ebuild,v 1.3 2005/03/23 14:33:10 blubb Exp $
+
+inherit eutils
DESCRIPTION="A C++ Library and a script language tool to create Flash (SWF) movies up to version 6."
HOMEPAGE="http://sswf.sourceforge.net"
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc debug"
DEPEND="sys-libs/zlib
media-libs/jpeg
@@ -17,6 +19,13 @@ DEPEND="sys-libs/zlib
sys-devel/flex
sys-devel/bison"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/bitsize.patch
+ epatch ${FILESDIR}/sound_wave_t.patch
+}
+
src_compile() {
econf \
$(use_enable debug) \