summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-10 10:51:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-10 10:51:09 +0000
commitd32cb3462de7f74045f09886f110535f238a32e1 (patch)
treec6150fa472ceb465f2843a1a2fd2e9481ec324b4 /media-video/undvd/undvd-0.7.5.ebuild
parentAnd adjust depend accordingly. (diff)
downloadgentoo-2-d32cb3462de7f74045f09886f110535f238a32e1.tar.gz
gentoo-2-d32cb3462de7f74045f09886f110535f238a32e1.tar.bz2
gentoo-2-d32cb3462de7f74045f09886f110535f238a32e1.zip
Remove mpeg4ip from RDEPEND since it's obsolete; you should install separate application (mp4creator) for this.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/undvd/undvd-0.7.5.ebuild')
-rw-r--r--media-video/undvd/undvd-0.7.5.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/media-video/undvd/undvd-0.7.5.ebuild b/media-video/undvd/undvd-0.7.5.ebuild
index 49083390494b..0fdc76c7af9b 100644
--- a/media-video/undvd/undvd-0.7.5.ebuild
+++ b/media-video/undvd/undvd-0.7.5.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/undvd-0.7.5.ebuild,v 1.1 2009/06/27 12:37:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/undvd/undvd-0.7.5.ebuild,v 1.2 2009/07/10 10:51:09 ssuominen Exp $
-EAPI="2"
-
-inherit eutils
+EAPI=2
DESCRIPTION="Simple dvd ripping command line app"
HOMEPAGE="http://sourceforge.net/projects/undvd/"
@@ -13,9 +11,9 @@ SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="aac css ffmpeg matroska mp4 ogm xvid"
+IUSE="aac css ffmpeg matroska ogm xvid"
-DEPEND="sys-apps/coreutils
+RDEPEND="sys-apps/coreutils
>=dev-lang/perl-5.8.8
media-video/lsdvd
media-video/mplayer[encode,dvd,mp3,x264,aac?,xvid?]
@@ -23,10 +21,10 @@ DEPEND="sys-apps/coreutils
media-video/vobcopy )
ffmpeg? ( media-video/ffmpeg )
matroska? ( media-video/mkvtoolnix )
- mp4? ( media-video/mpeg4ip )
ogm? ( media-sound/ogmtools )"
-RDEPEND="${DEPEND}"
+DEPEND=""
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" DOC="/usr/share/doc/${PF}" \
+ install || die "emake install failed"
}