summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-07-03 21:30:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-07-03 21:30:49 +0000
commita7fce9ea7fb7a10b361e52171e99b2c3d630ff0a (patch)
tree0823fcf1c2085b5d2017bd675520d642b6925d63 /media-video/vlc/vlc-9999.ebuild
parentremove insecure version (bug #271759) - thanks rbu (diff)
downloadgentoo-2-a7fce9ea7fb7a10b361e52171e99b2c3d630ff0a.tar.gz
gentoo-2-a7fce9ea7fb7a10b361e52171e99b2c3d630ff0a.tar.bz2
gentoo-2-a7fce9ea7fb7a10b361e52171e99b2c3d630ff0a.zip
add ieee1394 for the master branch ebuild too and bump deps where needed
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/vlc/vlc-9999.ebuild')
-rw-r--r--media-video/vlc/vlc-9999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 6b93490148a0..83fa975c396f 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.17 2009/07/02 18:50:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.18 2009/07/03 21:30:49 aballier Exp $
EAPI="1"
@@ -47,12 +47,14 @@ SLOT="0"
KEYWORDS=""
IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394
- debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig +gcrypt ggi gnome gnutls hal httpd
- id3tag jack kate libass libcaca libnotify libproxy libsysfs libtiger libv4l2 lirc live lua matroska mmx modplug mp3 mpeg mtp
- musepack ncurses nsplugin ogg opengl optimisememory oss pda png pulseaudio pvr +qt4
- remoteosd rtsp run-as-root samba schroedinger sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib
- theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs wma-fixed
- X x264 xcb xinerama xml xosd xv zvbi"
+ debug dirac directfb dts dvb dvd fbcon fluidsynth +ffmpeg flac fontconfig
+ +gcrypt ggi gnome gnutls hal httpd id3tag ieee1394 jack kate libass libcaca
+ libnotify libproxy libsysfs libtiger libv4l2 lirc live lua matroska mmx
+ modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
+ pda png pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba schroedinger
+ sdl sdl-image seamonkey shine shout skins speex sse stream svg svga taglib
+ theora truetype twolame upnp v4l v4l2 vcdinfo vcdx vlm vorbis win32codecs
+ wma-fixed X x264 xcb xinerama xml xosd xv zvbi"
RDEPEND="
sys-libs/zlib
@@ -67,8 +69,8 @@ RDEPEND="
cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
cdio? ( >=dev-libs/libcdio-0.78.2 )
dbus? ( >=sys-apps/dbus-1.0.2 )
- dc1394? ( sys-libs/libraw1394
- <media-libs/libdc1394-1.9.99 )
+ dc1394? ( >=sys-libs/libraw1394-2.0.1
+ >=media-libs/libdc1394-2.0.2 )
dirac? ( >=media-video/dirac-0.10.0 )
directfb? ( dev-libs/DirectFB )
dts? ( media-libs/libdca )
@@ -88,6 +90,7 @@ RDEPEND="
hal? ( sys-apps/hal )
id3tag? ( media-libs/libid3tag
sys-libs/zlib )
+ ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
kate? ( >=media-libs/libkate-0.1.1 )
libass? ( >=media-libs/libass-0.9.5 media-libs/fontconfig )
@@ -266,7 +269,6 @@ src_compile () {
$(use_enable dc1394) \
$(use_enable debug) \
$(use_enable dts dca) \
- --disable-dv \
$(use_enable dvb) \
$(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
$(use_enable fbcon fb) \
@@ -280,6 +282,7 @@ src_compile () {
$(use_enable hal) \
$(use_enable httpd) \
$(use_enable id3tag) \
+ $(use_enable ieee1394 dv) \
$(use_enable jack) \
$(use_enable kate) \
$(use_enable libass) \