summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
commit0ea019e9af09d24b746f9ed0bb0cc79217280848 (patch)
tree2a68c1442ad2f43c36b91bf01fbba01984c22428 /media-video/xine-ui
parentrphil forgot the _01 in the directory name (diff)
downloadgentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.gz
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.bz2
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.zip
This is a bunch of gcc-3.1 fixes, updates and generally preparing to unmask
xine-0.9.10, when we do unmask it users of xine-d4d and xine-d5d will need to know that those plugins are not yet available for the new version.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog9
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.10-r11
-rw-r--r--media-video/xine-ui/xine-ui-0.9.10-r1.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index f7d0e45de140..275cefd3adbd 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.11 2002/06/16 17:36:21 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.12 2002/06/16 19:22:15 lostlogic Exp $
+
+*xine-ui-0.9.10-r1 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> xine-ui-0.9.10-r1.ebuild
+
+ Added gcc-3.1 support, ensure that DirectFB really gets diabled, again,
+ gcc-3.1 users will not be able to use DirectFB.
*xine-ui-0.9.9-r2 (16 Jun 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.10-r1 b/media-video/xine-ui/files/digest-xine-ui-0.9.10-r1
new file mode 100644
index 000000000000..017a038eb743
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.10-r1
@@ -0,0 +1 @@
+MD5 1811dba3177a40bd704adb6e806c700e xine-ui-0.9.10.tar.gz 2663431
diff --git a/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild b/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..aaa60c130e14
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild,v 1.1 2002/06/16 19:22:15 lostlogic Exp $
+
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ nls? ( sys-devel/gettext )
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( gnome-base/ORBit )"
+
+SLOT="0"
+
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}