summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-02-24 16:56:46 +0000
committerSteve Dibb <beandog@gentoo.org>2007-02-24 16:56:46 +0000
commit545e7b7ac01c2621c980452b24ea3a8417a96dbe (patch)
tree3a236c7ee7fd93b92195d289504970cfc5166737 /media-video
parentNew release candidate, using embedded ffmpeg unfortunately but with fixed dep... (diff)
downloadgentoo-2-545e7b7ac01c2621c980452b24ea3a8417a96dbe.tar.gz
gentoo-2-545e7b7ac01c2621c980452b24ea3a8417a96dbe.tar.bz2
gentoo-2-545e7b7ac01c2621c980452b24ea3a8417a96dbe.zip
another rebuild
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer-bin/files/digest-mplayer-bin-1.0_rc1-r33
-rw-r--r--media-video/mplayer-bin/mplayer-bin-1.0_rc1-r3.ebuild40
2 files changed, 43 insertions, 0 deletions
diff --git a/media-video/mplayer-bin/files/digest-mplayer-bin-1.0_rc1-r3 b/media-video/mplayer-bin/files/digest-mplayer-bin-1.0_rc1-r3
new file mode 100644
index 000000000000..acf090860322
--- /dev/null
+++ b/media-video/mplayer-bin/files/digest-mplayer-bin-1.0_rc1-r3
@@ -0,0 +1,3 @@
+MD5 3b2e7790b83de99bde30a454147e3d21 mplayer-bin-1.0_rc1-r3.tbz2 6725822
+RMD160 80be1d3270bbb67a50d08f417af2f7754fb2e1d8 mplayer-bin-1.0_rc1-r3.tbz2 6725822
+SHA256 7f0a452f7c4d08d820376c1615062e61ce7797d4a4f13b2b31ae6996d14d9611 mplayer-bin-1.0_rc1-r3.tbz2 6725822
diff --git a/media-video/mplayer-bin/mplayer-bin-1.0_rc1-r3.ebuild b/media-video/mplayer-bin/mplayer-bin-1.0_rc1-r3.ebuild
new file mode 100644
index 000000000000..890cd75bbbc8
--- /dev/null
+++ b/media-video/mplayer-bin/mplayer-bin-1.0_rc1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer-bin/mplayer-bin-1.0_rc1-r3.ebuild,v 1.1 2007/02/24 16:56:46 beandog Exp $
+
+inherit multilib
+
+DESCRIPTION="Pre-build mplayer binary for amd64 systems"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${PF}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RDEPEND=">=app-emulation/emul-linux-x86-baselibs-10.1
+ >=app-emulation/emul-linux-x86-soundlibs-10.0
+ >=app-emulation/emul-linux-x86-gtklibs-10.0
+ >=app-emulation/emul-linux-x86-sdl-10.0
+ >=app-emulation/emul-linux-x86-medialibs-10.1
+ >=media-libs/win32codecs-20061022-r1"
+S="${WORKDIR}"
+RESTRICT="strip"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Daniel Gryniewicz <dang@gentoo.org>
+ has_multilib_profile || die
+ ABI="x86"
+}
+
+src_install() {
+ cp -pPRvf ${WORKDIR}/* ${D}/
+ dosym /opt/mplayer-bin/bin/mplayer-bin /opt/mplayer-bin/bin/gmplayer-bin
+ dosed dosed -e "s/gmplayer/gmplayer-bin/" /opt/mplayer-bin/share/applications/mplayer.desktop
+ dosym /opt/mplayer-bin/share/applications/mplayer.desktop /usr/share/applications/mplayer-bin.desktop
+ dodir /opt/mplayer-bin/lib
+ dosym /usr/$(get_libdir)/win32 /opt/mplayer-bin/lib/win32
+}