summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-24 20:08:42 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-24 20:08:42 +0000
commit56a362d69db79e93c6eba6163bc267aa02e52c25 (patch)
treed45b003f3fcbfbd905c058ea235315857aac626b /media-video
parentFix automagic wayland depend (#529388) (diff)
downloadgentoo-2-56a362d69db79e93c6eba6163bc267aa02e52c25.tar.gz
gentoo-2-56a362d69db79e93c6eba6163bc267aa02e52c25.tar.bz2
gentoo-2-56a362d69db79e93c6eba6163bc267aa02e52c25.zip
Use new ffmpeg/libav USEs style, autoreconf is needed after applying the patches (#552224 by Marcin Jurkowski), use readme.gentoo.eclass.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/motion/ChangeLog10
-rw-r--r--media-video/motion/motion-3.2.12-r3.ebuild82
2 files changed, 90 insertions, 2 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 1147bf3565bc..9dc2cfb56421 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/motion
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.46 2014/12/28 16:00:19 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.47 2015/06/24 20:08:42 pacho Exp $
+
+*motion-3.2.12-r3 (24 Jun 2015)
+
+ 24 Jun 2015; Pacho Ramos <pacho@gentoo.org> +motion-3.2.12-r3.ebuild:
+ Use new ffmpeg/libav USEs style, autoreconf is needed after applying the
+ patches (#552224 by Marcin Jurkowski), use readme.gentoo.eclass.
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org>
motion-3.2.12-r2.ebuild:
diff --git a/media-video/motion/motion-3.2.12-r3.ebuild b/media-video/motion/motion-3.2.12-r3.ebuild
new file mode 100644
index 000000000000..d679d9997c79
--- /dev/null
+++ b/media-video/motion/motion-3.2.12-r3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.12-r3.ebuild,v 1.1 2015/06/24 20:08:42 pacho Exp $
+
+EAPI=5
+inherit autotools eutils readme.gentoo user
+
+DESCRIPTION="A software motion detector"
+HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE="ffmpeg libav mysql postgres +v4l"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+"
+# note: libv4l is only in dependencies for the libv4l1-videodev.h header file
+# used by the -workaround-v4l1_deprecation.patch.
+DEPEND="${RDEPEND}
+ v4l? ( virtual/os-headers media-libs/libv4l )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need to setup /etc/motion.conf before running
+motion for the first time.
+You can install motion detection as a service, use:
+rc-update add motion default
+"
+
+pkg_setup() {
+ enewuser motion -1 -1 -1 video
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/ffmpeg-1.patch \
+ "${FILESDIR}"/ffmpeg-2.patch \
+ "${FILESDIR}"/ffmpeg-3.patch \
+ "${FILESDIR}"/ffmpeg-4.patch \
+ "${FILESDIR}"/ffmpeg-5.patch \
+ "${FILESDIR}"/libav-9.patch \
+ "${FILESDIR}"/${P}-workaround-v4l1_deprecation.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with v4l) \
+ $(use_with ffmpeg) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ --without-optimizecpu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOC='CHANGELOG CODE_STANDARD CREDITS FAQ README' \
+ docdir=/usr/share/doc/${PF} \
+ EXAMPLES='thread*.conf' \
+ examplesdir=/usr/share/doc/${PF}/examples \
+ install
+
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/motion.initd-r2 motion
+ newconfd "${FILESDIR}"/motion.confd motion
+
+ mv -vf "${D}"/etc/motion{-dist,}.conf || die
+
+ readme.gentoo_create_doc
+}