summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-18 23:44:22 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-18 23:44:22 +0000
commit9dcf3cf7e02399ed0e410662dcfebeb33660cab1 (patch)
tree1638fce3a97332f7c5f71e88339a76a7da4ba777 /media-video
parentMask new media-video/rtmpdump snapshots for testing (diff)
downloadgentoo-2-9dcf3cf7e02399ed0e410662dcfebeb33660cab1.tar.gz
gentoo-2-9dcf3cf7e02399ed0e410662dcfebeb33660cab1.tar.bz2
gentoo-2-9dcf3cf7e02399ed0e410662dcfebeb33660cab1.zip
Add new media-video/rtmpdump snapshot. Required by new applications. Bug #488510
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/rtmpdump/ChangeLog11
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild66
2 files changed, 75 insertions, 2 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index f8f4732ad4c8..e0f7608a0332 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/rtmpdump
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.23 2012/11/25 10:53:36 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.24 2013/10/18 23:44:22 hwoarang Exp $
+
+*rtmpdump-2.4_p20131018 (18 Oct 2013)
+
+ 18 Oct 2013; Markos Chandras <hwoarang@gentoo.org>
+ +rtmpdump-2.4_p20131018.ebuild:
+ Add new media-video/rtmpdump snapshot. Required by new applications. Bug
+ #488510
25 Nov 2012; Markos Chandras <hwoarang@gentoo.org> rtmpdump-2.3.ebuild,
rtmpdump-2.4.ebuild, rtmpdump-9999.ebuild:
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild
new file mode 100644
index 000000000000..92995a886c78
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.4_p20131018.ebuild,v 1.1 2013/10/18 23:44:22 hwoarang Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+# the library is LGPL-2.1, the command is GPL-2
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="gnutls polarssl ssl"
+
+DEPEND="ssl? (
+ gnutls? ( net-libs/gnutls )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-0.14.0 ) )
+ !gnutls? ( !polarssl? ( dev-libs/openssl ) )
+ )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}"
+
+pkg_setup() {
+ if ! use ssl && ( use gnutls || use polarssl ) ; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+}
+
+src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
+}
+
+src_install() {
+ mkdir -p "${ED}"/${DESTTREE}/$(get_libdir)
+ emake DESTDIR="${ED}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
+ CRYPTO="${crypto}" install
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+}