summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-04 09:48:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-04 09:48:43 +0000
commitc50ba1e77614f875b48b283c86a01c46c57e63e4 (patch)
treef2e8a55186c0a54a55a71c68f139a6e99dc9b3ef /media-video
parentSet RESTRICT=test (bug #276687). (diff)
downloadgentoo-2-c50ba1e77614f875b48b283c86a01c46c57e63e4.tar.gz
gentoo-2-c50ba1e77614f875b48b283c86a01c46c57e63e4.tar.bz2
gentoo-2-c50ba1e77614f875b48b283c86a01c46c57e63e4.zip
give preference to -mcpu then -mtune then -march for setting cpu, this should match better the precision of the flags
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog7
-rw-r--r--media-video/ffmpeg/ffmpeg-2.2.10.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-2.4.3.ebuild4
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild4
4 files changed, 12 insertions, 7 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index bf5a083fe17b..773e9bab8993 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.807 2014/11/04 09:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.808 2014/11/04 09:48:43 aballier Exp $
+
+ 04 Nov 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-2.2.10.ebuild,
+ ffmpeg-2.4.3.ebuild, ffmpeg-9999.ebuild:
+ give preference to -mcpu then -mtune then -march for setting cpu, this should
+ match better the precision of the flags
04 Nov 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-2.2.10.ebuild,
ffmpeg-2.4.3.ebuild, ffmpeg-9999.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-2.2.10.ebuild b/media-video/ffmpeg/ffmpeg-2.2.10.ebuild
index a25383f1bc3e..6d490fbc01b9 100644
--- a/media-video/ffmpeg/ffmpeg-2.2.10.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.10.ebuild,v 1.2 2014/11/04 09:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.10.ebuild,v 1.3 2014/11/04 09:48:43 aballier Exp $
EAPI="5"
@@ -289,7 +289,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.4.3.ebuild b/media-video/ffmpeg/ffmpeg-2.4.3.ebuild
index 033310925f68..462fe2209bd1 100644
--- a/media-video/ffmpeg/ffmpeg-2.4.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.4.3.ebuild,v 1.2 2014/11/04 09:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.4.3.ebuild,v 1.3 2014/11/04 09:48:43 aballier Exp $
EAPI="5"
@@ -288,7 +288,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index eb52a537c5cc..e925dce4e483 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.175 2014/11/04 09:20:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.176 2014/11/04 09:48:43 aballier Exp $
EAPI="5"
@@ -289,7 +289,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break