summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-05-13 08:56:53 +0000
committerPeter Volkov <pva@gentoo.org>2007-05-13 08:56:53 +0000
commit4f3a2045b2b9752518696ff123dd5353b8f5e511 (patch)
treec2b59b3dbb09e5450a41d349d5e37ac86be81982 /net-analyzer/cacti
parentFix for sdl useflag bug #177335 (diff)
downloadgentoo-2-4f3a2045b2b9752518696ff123dd5353b8f5e511.tar.gz
gentoo-2-4f3a2045b2b9752518696ff123dd5353b8f5e511.tar.bz2
gentoo-2-4f3a2045b2b9752518696ff123dd5353b8f5e511.zip
lighttpd is stable on alpha and sparc so removing !archs from RDEPEND. Actually remove snmp from php check, bug #178263.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.6i-r1.ebuild6
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r4.ebuild10
3 files changed, 12 insertions, 11 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 21ce79dee18d..b3d5883cb0fb 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.97 2007/05/12 23:55:28 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.98 2007/05/13 08:56:53 pva Exp $
+
+ 13 May 2007; <pva@gentoo.org> cacti-0.8.6i-r1.ebuild,
+ cacti-0.8.6j-r4.ebuild:
+ lighttpd is stable on alpha and sparc so removing !archs from RDEPEND.
+ Actually remove snmp from php check, bug #178263.
12 May 2007; Luca Longinotti <chtekk@gentoo.org> cacti-0.8.6i-r1.ebuild,
cacti-0.8.6j-r4.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild b/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
index 392396c6e74c..367cd3be372a 100644
--- a/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild,v 1.7 2007/05/12 23:55:28 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild,v 1.8 2007/05/13 08:56:53 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -34,9 +34,7 @@ want_apache
need_php_cli
need_php_httpd
-# alpha doesn't have lighttpd keyworded yet
-# sparc doesn't have a stable keyword for lighttpd yet
-RDEPEND="!alpha? ( !sparc? ( !apache2? ( www-servers/lighttpd ) ) )
+RDEPEND="!apache2? ( www-servers/lighttpd )
snmp? ( net-analyzer/net-snmp )
net-analyzer/rrdtool
virtual/mysql
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild
index dcc7ca1a7fba..4d6a724154cf 100644
--- a/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild,v 1.6 2007/05/12 23:55:28 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild,v 1.7 2007/05/13 08:56:53 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -33,9 +33,7 @@ want_apache
need_php_cli
need_php_httpd
-# alpha doesn't have lighttpd keyworded yet
-# sparc doesn't have a stable keyword for lighttpd yet
-RDEPEND="!alpha? ( !sparc? ( !apache2? ( www-servers/lighttpd ) ) )
+RDEPEND="!apache2? ( www-servers/lighttpd )
snmp? ( net-analyzer/net-snmp )
net-analyzer/rrdtool
!bundled-adodb? ( dev-php/adodb )
@@ -63,9 +61,9 @@ pkg_setup() {
webapp_pkg_setup
has_php
if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml snmp
+ require_php_with_use cli mysql xml
elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml snmp expat
+ require_php_with_use cli mysql xml expat
fi
use bundled-adodb || require_php_with_use sockets
}