summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-06-06 19:39:40 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-06-06 19:39:40 +0000
commitc2b128a9aa5ccbe7ffb18703a43dab8cab66c93d (patch)
tree27e4585431e93578a321b6b74373aa4c4f030844 /net-analyzer/cacti
parentVersion bump. (diff)
downloadgentoo-2-c2b128a9aa5ccbe7ffb18703a43dab8cab66c93d.tar.gz
gentoo-2-c2b128a9aa5ccbe7ffb18703a43dab8cab66c93d.tar.bz2
gentoo-2-c2b128a9aa5ccbe7ffb18703a43dab8cab66c93d.zip
Version bump, security bug 181112
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r5.ebuild99
-rw-r--r--net-analyzer/cacti/files/cacti-0.8.6j-dos-large-values.patch30
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j-r515
4 files changed, 151 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 9246ea172bb2..e73b800c2e04 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.99 2007/06/02 19:44:46 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.100 2007/06/06 19:39:40 falco Exp $
+
+*cacti-0.8.6j-r5 (06 Jun 2007)
+
+ 06 Jun 2007; Raphael Marichez <falco@gentoo.org>
+ +files/cacti-0.8.6j-dos-large-values.patch, +cacti-0.8.6j-r5.ebuild:
+ Version bump, security bug 181112
02 Jun 2007; Lars Weiler <pylon@gentoo.org> cacti-0.8.6j-r4.ebuild:
Stable on ppc; bug #174551.
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild
new file mode 100644
index 000000000000..815c9d0d0357
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild,v 1.1 2007/06/06 19:39:40 falco Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES="ping_php_version4_snmpgetnext
+ tree_console_missing_hosts
+ thumbnail_graphs_not_working
+ graph_debug_lockup_fix"
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp bundled-adodb"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+RDEPEND="!apache2? ( www-servers/lighttpd )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ !bundled-adodb? ( dev-php/adodb )
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+
+ epatch "${FILESDIR}/${P}"-dos-large-values.patch
+
+ use bundled-adodb || sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"/usr/share/php/adodb/adodb.inc.php":' \
+ "${S}"/include/config.php || die "Adodb sed failed."
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ require_php_with_use cli mysql xml
+ elif [ $PHP_VERSION = 4 ] ; then
+ require_php_with_use cli mysql xml expat
+ fi
+ use bundled-adodb || require_php_with_use sockets
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ use bundled-adodb || rm -rf lib/adodb
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/cacti-0.8.6j-dos-large-values.patch b/net-analyzer/cacti/files/cacti-0.8.6j-dos-large-values.patch
new file mode 100644
index 000000000000..7398e962151b
--- /dev/null
+++ b/net-analyzer/cacti/files/cacti-0.8.6j-dos-large-values.patch
@@ -0,0 +1,30 @@
+diff -uNr -r cacti-0.8.6j-orig/graph_image.php cacti-0.8.6j/graph_image.php
+--- cacti-0.8.6j-orig/graph_image.php 2007-01-18 01:23:10.000000000 +0100
++++ cacti-0.8.6j/graph_image.php 2007-06-06 21:00:17.278210000 +0200
+@@ -51,22 +51,22 @@
+ $graph_data_array = array();
+
+ /* override: graph start time (unix time) */
+-if (!empty($_GET["graph_start"])) {
++if (!empty($_GET["graph_start"]) && $_GET["graph_start"] < 1600000000) {
+ $graph_data_array["graph_start"] = $_GET["graph_start"];
+ }
+
+ /* override: graph end time (unix time) */
+-if (!empty($_GET["graph_end"])) {
++if (!empty($_GET["graph_end"]) && $_GET["graph_end"] < 1600000000) {
+ $graph_data_array["graph_end"] = $_GET["graph_end"];
+ }
+
+ /* override: graph height (in pixels) */
+-if (!empty($_GET["graph_height"])) {
++if (!empty($_GET["graph_height"]) && $_GET["graph_height"] < 3000) {
+ $graph_data_array["graph_height"] = $_GET["graph_height"];
+ }
+
+ /* override: graph width (in pixels) */
+-if (!empty($_GET["graph_width"])) {
++if (!empty($_GET["graph_width"]) && $_GET["graph_width"] < 3000) {
+ $graph_data_array["graph_width"] = $_GET["graph_width"];
+ }
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5 b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5
new file mode 100644
index 000000000000..fbccf1df186f
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5
@@ -0,0 +1,15 @@
+MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
+RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
+SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337
+MD5 85a95eaef5fac31d5ca87cb915493cdd graph_debug_lockup_fix.patch 927
+RMD160 8bf2112cb537b330547b8b571cc573a0f3135123 graph_debug_lockup_fix.patch 927
+SHA256 c8ea30c6bf5764663d106d28b3308377a8c2003cc2afd3d0ba0102ed5fddee1b graph_debug_lockup_fix.patch 927
+MD5 bedf583646e59dd628d4aced7e83fdf3 ping_php_version4_snmpgetnext.patch 1262
+RMD160 94882973199b8e59c40ad43a132548862654f312 ping_php_version4_snmpgetnext.patch 1262
+SHA256 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170 ping_php_version4_snmpgetnext.patch 1262
+MD5 1a3c9580a1f94d991502c8650d18b617 thumbnail_graphs_not_working.patch 1515
+RMD160 6b228cab1bc99b3f20ddb4e1d45b467fc8dadf35 thumbnail_graphs_not_working.patch 1515
+SHA256 3b18602aed1aa8b9773a75a4e89413cd12ce2670fd185eae113de1aa2c1186bd thumbnail_graphs_not_working.patch 1515
+MD5 109afedcd49dc173da8c27fb23c322fe tree_console_missing_hosts.patch 771
+RMD160 d33f3916317e989b379d1188f3ed23b7d61a7a9e tree_console_missing_hosts.patch 771
+SHA256 5807bb408227b1c9f2ebecf220c048eb7c7148eee41fcd06fdc086124a206180 tree_console_missing_hosts.patch 771