summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-21 05:10:43 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-21 05:10:43 +0000
commit6e7cea239bc4cf7ed0011b449c89f95b8ce062c8 (patch)
tree898d2274f7ebc90170a7073455ef87b2851a6dbe /net-analyzer/dsniff
parenttouchups (diff)
downloadgentoo-2-6e7cea239bc4cf7ed0011b449c89f95b8ce062c8.tar.gz
gentoo-2-6e7cea239bc4cf7ed0011b449c89f95b8ce062c8.tar.bz2
gentoo-2-6e7cea239bc4cf7ed0011b449c89f95b8ce062c8.zip
ppc #27012
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog11
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r1.ebuild69
-rw-r--r--net-analyzer/dsniff/dsniff-2.3.ebuild4
-rw-r--r--net-analyzer/dsniff/files/2.3-libnet-1.0.patch183
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.3-r12
5 files changed, 264 insertions, 5 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index e59703f48655..41d3bf58336d 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.4 2003/07/23 15:43:49 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.5 2003/08/21 05:10:43 vapier Exp $
+
+*dsniff-2.3-r1 (21 Aug 2003)
+
+ 21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Patch to compile against SLOT-ed libnet-1.0.x #17772.
+
+*dsniff-2.3 (14 Nov 2002)
23 Jul 2003; Tavis Ormandy <taviso@gentoo.org> dsniff-2.3.ebuild:
~alpha
@@ -8,7 +15,5 @@
02 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> dsniff-2.3.ebuild :
Closes #14689.
-*dsniff-2.3 (14 Nov 2002)
-
14 Nov 2002; Jared Hudson <jhhudso@gentoo.org> : Initial import. Ebuild
submitted by foser <foser@gentoo.org>. Bug #6906
diff --git a/net-analyzer/dsniff/dsniff-2.3-r1.ebuild b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
new file mode 100644
index 000000000000..f8f6985c935b
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r1.ebuild,v 1.1 2003/08/21 05:10:43 vapier Exp $
+
+inherit eutils
+
+# dsniff needs to build it's own version of sys-libs/db, since the one
+# normally installed is for some reason unusable for dsniffs configure script.
+# The version is chosen as being the standard one around at the time i wrote
+# this ebuild, it's not set in stone.
+
+DB_VER="3.2.9"
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/dsniff/"
+SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
+ http://monkey.org/~dugsong/${PN}/${P}.tar.gz"
+
+# dsniff has it's own small license which is in the docs section
+LICENSE="DSNIFF"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+RDEPEND=">=net-libs/libpcap-0.7.1
+ >=net-libs/libnet-1.0.2a-r3
+ <net-libs/libnet-1.1
+ >=net-libs/libnids-1.16-r1
+ <net-libs/libnids-1.17
+ >=dev-libs/openssl-0.9.6e"
+
+# dependencies only for building our own sys-libs/db
+DEPEND="${RDEPEND}
+ virtual/glibc
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+
+src_unpack() {
+ unpack db-${DB_VER}.tar.gz
+ unpack ${P}.tar.gz
+
+ # Making sure data files get correctly installed and that dsniff
+ # can find them
+ # Working around dsniff b0rky config script
+ # Data stuff goes into /etc/dsniff
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+ sed -i "s:lib':':" configure || die "sed configure"
+ sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
+ sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
+}
+
+src_compile() {
+ cd ${WORKDIR}/db-${DB_VER}/dist
+ ./configure \
+ --host=${CHOST} \
+ --enable-compat185 || die "./configure of db-${DB_VER} failed"
+ emake || die "build of db-${DB_VER} failed"
+
+ # Another workaround around the crappy config script
+ cd ${S}
+ econf --with-db=../db-${DB_VER} || die
+ make || die
+}
+
+src_install() {
+ make install || die
+ dodoc CHANGES LICENSE README TODO
+}
diff --git a/net-analyzer/dsniff/dsniff-2.3.ebuild b/net-analyzer/dsniff/dsniff-2.3.ebuild
index d91e3ec07bc7..75a9dece0358 100644
--- a/net-analyzer/dsniff/dsniff-2.3.ebuild
+++ b/net-analyzer/dsniff/dsniff-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3.ebuild,v 1.4 2003/07/23 15:43:49 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3.ebuild,v 1.5 2003/08/21 05:09:19 vapier Exp $
# dsniff needs to build it's own version of sys-libs/db, since the one
# normally installed is for some reason unusable for dsniffs configure script.
@@ -18,7 +18,7 @@ SRC_URI="http://www.sleepycat.com/update/snapshot/db-${DB_VER}.tar.gz
# dsniff has it's own small license which is in the docs section
LICENSE="DSNIFF"
SLOT="0"
-KEYWORDS="x86 ~alpha"
+KEYWORDS="x86 ~ppc ~alpha"
RDEPEND=">=net-libs/libpcap-0.7.1
>=net-libs/libnet-1.0.2
diff --git a/net-analyzer/dsniff/files/2.3-libnet-1.0.patch b/net-analyzer/dsniff/files/2.3-libnet-1.0.patch
new file mode 100644
index 000000000000..dd1692a8a0cf
--- /dev/null
+++ b/net-analyzer/dsniff/files/2.3-libnet-1.0.patch
@@ -0,0 +1,183 @@
+diff -U 0 -r dsniff-2.3.orig/arpspoof.c dsniff-2.3/arpspoof.c
+--- dsniff-2.3.orig/arpspoof.c 2000-11-28 02:43:43.000000000 -0500
++++ dsniff-2.3/arpspoof.c 2003-08-19 14:51:56.094635632 -0400
+@@ -20 +20 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/configure dsniff-2.3/configure
+--- dsniff-2.3.orig/configure 2000-12-02 23:35:46.000000000 -0500
++++ dsniff-2.3/configure 2003-08-19 14:51:56.304603712 -0400
+@@ -3068 +3068 @@
+- if test -f $withval/include/libnet.h -a -f $withval/lib/libnet.a; then
++ if test -f $withval/include/libnet-1.0.h -a -f $withval/lib/libnet-1.0.a; then
+@@ -3071,4 +3071,4 @@
+- if test -f $withval/bin/libnet-config; then
+- CFLAGS="$CFLAGS `$withval/bin/libnet-config --defines`"
+- elif test -f $withval/libnet-config; then
+- CFLAGS="$CFLAGS `$withval/libnet-config --defines`"
++ if test -f $withval/bin/libnet-1.0-config; then
++ CFLAGS="$CFLAGS `$withval/bin/libnet-1.0-config --defines`"
++ elif test -f $withval/libnet-1.0-config; then
++ CFLAGS="$CFLAGS `$withval/libnet-1.0-config --defines`"
+@@ -3076 +3076 @@
+- CFLAGS="$CFLAGS `libnet-config --defines`"
++ CFLAGS="$CFLAGS `libnet-1.0-config --defines`"
+@@ -3079 +3079 @@
+- LNETLIB="-L$withval/lib -lnet"
++ LNETLIB="-L$withval/lib -lnet-1.0"
+@@ -3081 +3081 @@
+- { echo "configure: error: libnet.h or libnet.a not found in $withval" 1>&2; exit 1; }
++ { echo "configure: error: libnet-1.0.h or libnet-1.0.a not found in $withval" 1>&2; exit 1; }
+@@ -3086,2 +3086,2 @@
+- if test -f ${prefix}/include/libnet.h; then
+- CFLAGS="$CFLAGS `${prefix}/bin/libnet-config --defines`"
++ if test -f ${prefix}/include/libnet-1.0.h; then
++ CFLAGS="$CFLAGS `${prefix}/bin/libnet-1.0-config --defines`"
+@@ -3089,4 +3089,4 @@
+- LNETLIB="-L${prefix}/lib -lnet"
+- elif test -f /usr/include/libnet.h; then
+- CFLAGS="$CFLAGS `libnet-config --defines`"
+- LNETLIB="-lnet"
++ LNETLIB="-L${prefix}/lib -lnet-1.0"
++ elif test -f /usr/include/libnet-1.0.h; then
++ CFLAGS="$CFLAGS `libnet-1.0-config --defines`"
++ LNETLIB="-lnet-1.0"
+@@ -3115 +3115 @@
+- if test -f $withval/src/nids.h -a -f $withval/src/libnids.a; then
++ if test -f $withval/src/nids-1.0.h -a -f $withval/src/libnids-1.0.a; then
+@@ -3119,2 +3119,2 @@
+- NIDSLIB="-L$withval/src -lnids"
+- elif test -f $withval/include/nids.h -a -f $withval/lib/libnids.a; then
++ NIDSLIB="-L$withval/src -lnids-1.0"
++ elif test -f $withval/include/nids-1.0.h -a -f $withval/lib/libnids-1.0.a; then
+@@ -3124 +3124 @@
+- NIDSLIB="-L$withval/lib -lnids"
++ NIDSLIB="-L$withval/lib -lnids-1.0"
+@@ -3126 +3126 @@
+- { echo "configure: error: nids.h or libnids.a not found in $withval" 1>&2; exit 1; }
++ { echo "configure: error: nids-1.0.h or libnids-1.0.a not found in $withval" 1>&2; exit 1; }
+@@ -3131 +3131 @@
+- if test -f ${prefix}/include/nids.h; then
++ if test -f ${prefix}/include/nids-1.0.h; then
+@@ -3133,3 +3133,3 @@
+- NIDSLIB="-L${prefix}/lib -lnids"
+- elif test -f /usr/include/nids.h; then
+- NIDSLIB="-lnids"
++ NIDSLIB="-L${prefix}/lib -lnids-1.0"
++ elif test -f /usr/include/nids-1.0.h; then
++ NIDSLIB="-lnids-1.0"
+@@ -3151 +3151 @@
+-#include <nids.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/decode_portmap.c dsniff-2.3/decode_portmap.c
+--- dsniff-2.3.orig/decode_portmap.c 2000-12-15 15:13:29.000000000 -0500
++++ dsniff-2.3/decode_portmap.c 2003-08-19 14:51:56.350596720 -0400
+@@ -18,2 +18,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/dnsspoof.c dsniff-2.3/dnsspoof.c
+--- dsniff-2.3.orig/dnsspoof.c 2000-11-19 14:39:40.000000000 -0500
++++ dsniff-2.3/dnsspoof.c 2003-08-19 14:51:56.183622104 -0400
+@@ -24 +24 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/dsniff.c dsniff-2.3/dsniff.c
+--- dsniff-2.3.orig/dsniff.c 2000-12-01 16:27:15.000000000 -0500
++++ dsniff-2.3/dsniff.c 2003-08-19 14:51:56.352596416 -0400
+@@ -21,2 +21,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/filesnarf.c dsniff-2.3/filesnarf.c
+--- dsniff-2.3.orig/filesnarf.c 2000-12-15 15:16:58.000000000 -0500
++++ dsniff-2.3/filesnarf.c 2003-08-19 14:51:56.357595656 -0400
+@@ -22,2 +22,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/macof.c dsniff-2.3/macof.c
+--- dsniff-2.3.orig/macof.c 2000-11-14 10:50:55.000000000 -0500
++++ dsniff-2.3/macof.c 2003-08-19 14:51:56.192620736 -0400
+@@ -21 +21 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/mailsnarf.c dsniff-2.3/mailsnarf.c
+--- dsniff-2.3.orig/mailsnarf.c 2000-11-19 14:39:41.000000000 -0500
++++ dsniff-2.3/mailsnarf.c 2003-08-19 14:51:56.361595048 -0400
+@@ -21,2 +21,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/msgsnarf.c dsniff-2.3/msgsnarf.c
+--- dsniff-2.3.orig/msgsnarf.c 2000-12-15 15:12:19.000000000 -0500
++++ dsniff-2.3/msgsnarf.c 2003-08-19 14:51:56.369593832 -0400
+@@ -20,2 +20,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/record.c dsniff-2.3/record.c
+--- dsniff-2.3.orig/record.c 2000-11-14 10:51:02.000000000 -0500
++++ dsniff-2.3/record.c 2003-08-19 14:51:56.206618608 -0400
+@@ -22 +22 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/sshmitm.c dsniff-2.3/sshmitm.c
+--- dsniff-2.3.orig/sshmitm.c 2000-12-17 16:09:43.000000000 -0500
++++ dsniff-2.3/sshmitm.c 2003-08-19 14:51:56.210618000 -0400
+@@ -19 +19 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/tcp_raw.c dsniff-2.3/tcp_raw.c
+--- dsniff-2.3.orig/tcp_raw.c 2000-11-28 02:48:25.000000000 -0500
++++ dsniff-2.3/tcp_raw.c 2003-08-19 14:51:56.212617696 -0400
+@@ -15 +15 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/tcpkill.c dsniff-2.3/tcpkill.c
+--- dsniff-2.3.orig/tcpkill.c 2000-11-29 19:39:05.000000000 -0500
++++ dsniff-2.3/tcpkill.c 2003-08-19 14:51:56.214617392 -0400
+@@ -19 +19 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/tcpnice.c dsniff-2.3/tcpnice.c
+--- dsniff-2.3.orig/tcpnice.c 2000-11-29 19:39:05.000000000 -0500
++++ dsniff-2.3/tcpnice.c 2003-08-19 14:51:56.216617088 -0400
+@@ -21 +21 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/trigger.c dsniff-2.3/trigger.c
+--- dsniff-2.3.orig/trigger.c 2000-11-19 16:44:29.000000000 -0500
++++ dsniff-2.3/trigger.c 2003-08-19 14:51:56.376592768 -0400
+@@ -15,2 +15,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/urlsnarf.c dsniff-2.3/urlsnarf.c
+--- dsniff-2.3.orig/urlsnarf.c 2000-12-18 21:53:36.000000000 -0500
++++ dsniff-2.3/urlsnarf.c 2003-08-19 14:51:56.378592464 -0400
+@@ -24,2 +24,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/webmitm.c dsniff-2.3/webmitm.c
+--- dsniff-2.3.orig/webmitm.c 2000-12-03 00:13:28.000000000 -0500
++++ dsniff-2.3/webmitm.c 2003-08-19 14:51:56.229615112 -0400
+@@ -23 +23 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+diff -U 0 -r dsniff-2.3.orig/webspy.c dsniff-2.3/webspy.c
+--- dsniff-2.3.orig/webspy.c 2000-11-14 10:51:04.000000000 -0500
++++ dsniff-2.3/webspy.c 2003-08-19 14:51:56.381592008 -0400
+@@ -24,2 +24,2 @@
+-#include <libnet.h>
+-#include <nids.h>
++#include <libnet-1.0.h>
++#include <nids-1.0.h>
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3-r1 b/net-analyzer/dsniff/files/digest-dsniff-2.3-r1
new file mode 100644
index 000000000000..e1135460a43f
--- /dev/null
+++ b/net-analyzer/dsniff/files/digest-dsniff-2.3-r1
@@ -0,0 +1,2 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
+MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797