summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 16:22:01 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-05 16:22:01 +0000
commit9d98343156dd163cf6c25326b58b772a7c5f53cc (patch)
tree217bb668a605a286c0e51bd954906cbe5c3f901f /net-analyzer/gr-fosphor
parentMarked stable on AMD64 based on arch testing by Elijah "Armageddon" El Lazkan... (diff)
downloadgentoo-2-9d98343156dd163cf6c25326b58b772a7c5f53cc.tar.gz
gentoo-2-9d98343156dd163cf6c25326b58b772a7c5f53cc.tar.bz2
gentoo-2-9d98343156dd163cf6c25326b58b772a7c5f53cc.zip
Initial commit.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/ChangeLog9
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild58
-rw-r--r--net-analyzer/gr-fosphor/metadata.xml9
3 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/gr-fosphor/ChangeLog b/net-analyzer/gr-fosphor/ChangeLog
new file mode 100644
index 000000000000..4639e8959f1a
--- /dev/null
+++ b/net-analyzer/gr-fosphor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-analyzer/gr-fosphor
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gr-fosphor/ChangeLog,v 1.1 2013/11/05 16:22:01 chithanh Exp $
+
+*gr-fosphor-9999 (05 Nov 2013)
+
+ 05 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +gr-fosphor-9999.ebuild, +metadata.xml:
+ Initial commit.
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
new file mode 100644
index 000000000000..c30874da2627
--- /dev/null
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild,v 1.1 2013/11/05 16:22:01 chithanh Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
+HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="glfw qt4 wxwidgets"
+
+RDEPEND="qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ >=net-wireless/gnuradio-3.7_rc:0=[qt4?,wxwidgets?]
+ glfw? ( >=media-libs/glfw-3 )
+ virtual/opencl
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0
+ dev-util/cppunit
+"
+
+src_prepare() {
+ python_fix_shebang python/wx_sink_c.py
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ # tries to run OpenCL test program, but failing doesn't hurt
+ addpredict /dev/dri
+
+ local mycmakeargs="
+ $(cmake-utils_use_enable glfw GLFW)
+ $(cmake-utils_use_enable qt4 QT)
+ $(cmake-utils_use_enable wxwidgets WX)
+ -DENABLE_PYTHON=ON
+ "
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/gr-fosphor/metadata.xml b/net-analyzer/gr-fosphor/metadata.xml
new file mode 100644
index 000000000000..192bccb822ca
--- /dev/null
+++ b/net-analyzer/gr-fosphor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <use>
+ <flag name='glfw'>enable GLFW based interface</flag>
+ </use>
+</pkgmetadata>
+