summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-23 14:02:25 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-23 14:02:25 +0000
commit081e358f9334edcab69c6e0355ecbcb34896f65d (patch)
tree0a13672b6d148874a3dcd93eb9b2259a3eaf2c26 /net-analyzer/hping
parentMarked ~ppc (bug #297830). (diff)
downloadgentoo-2-081e358f9334edcab69c6e0355ecbcb34896f65d.tar.gz
gentoo-2-081e358f9334edcab69c6e0355ecbcb34896f65d.tar.bz2
gentoo-2-081e358f9334edcab69c6e0355ecbcb34896f65d.zip
Build the Tcl linker arguments more reliably (bug #247282).
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/ChangeLog6
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch16
-rw-r--r--net-analyzer/hping/hping-3_pre20051105-r1.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/net-analyzer/hping/ChangeLog b/net-analyzer/hping/ChangeLog
index de4a81fd19ac..1b89999c7aeb 100644
--- a/net-analyzer/hping/ChangeLog
+++ b/net-analyzer/hping/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/hping
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.47 2009/12/22 21:19:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.48 2009/12/23 14:02:25 jer Exp $
+
+ 23 Dec 2009; Jeroen Roovers <jer@gentoo.org>
+ hping-3_pre20051105-r1.ebuild, +files/hping-3_pre20051105-libtcl.patch:
+ Build the Tcl linker arguments more reliably (bug #247282).
22 Dec 2009; Jeroen Roovers <jer@gentoo.org> hping-2.0.0_rc3-r2.ebuild:
Do not install COPYING. Break up long line.
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
new file mode 100644
index 000000000000..4d374cf06eaf
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-libtcl.patch
@@ -0,0 +1,16 @@
+When anything libtcl (bug #247282) this will fail, and we're only finding out
+the version of the library anyway, so why not use TCL_VER, which is found using
+a slightly less fishy method. -JeR
+
+--- configure.org 2009-12-23 14:53:34.000000000 +0100
++++ configure 2009-12-23 14:56:34.000000000 +0100
+@@ -98,8 +98,7 @@
+ fi
+ if [ -n $USE_TCL ]
+ then
+- LIBPOSTFIX=`ls -1 /usr/local/lib/ /usr/lib | grep 'libtcl[0-9]' | grep so | sed -e 's/\.so.*//g' -e 's/libtcl//g' | sort -r | head -1`
+- TCL_LIB="-ltcl${LIBPOSTFIX} -lm -lpthread"
++ TCL_LIB="-ltcl${TCL_VER} -lm -lpthread"
+ fi
+
+ #
diff --git a/net-analyzer/hping/hping-3_pre20051105-r1.ebuild b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
index ed31c57c273d..b6794bd64ad1 100644
--- a/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
+++ b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105-r1.ebuild,v 1.2 2009/12/22 21:17:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105-r1.ebuild,v 1.3 2009/12/23 14:02:25 jer Exp $
inherit eutils multilib toolchain-funcs
@@ -27,7 +27,8 @@ src_unpack() {
"${FILESDIR}"/${P}.patch \
"${FILESDIR}"/bytesex.h.patch \
"${FILESDIR}"/${P}-tcl.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-libtcl.patch
# Correct hard coded values
sed -i Makefile.in \