summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-22 21:17:15 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-22 21:17:15 +0000
commit51bd90b00f248e5a3be145d58754293068bc35b1 (patch)
tree762dae6d36dc32936622ceb3cfafc965426a708b /net-analyzer/hping
parentVersion bump. (diff)
downloadgentoo-2-51bd90b00f248e5a3be145d58754293068bc35b1.tar.gz
gentoo-2-51bd90b00f248e5a3be145d58754293068bc35b1.tar.bz2
gentoo-2-51bd90b00f248e5a3be145d58754293068bc35b1.zip
Apply the same patches to hping-2 (see previous ChangeLog entry, bar the tcl stuff). Remove useless USE=debug (set -g through CFLAGS instead if you want, both v2 and v3).
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/ChangeLog10
-rw-r--r--net-analyzer/hping/files/hping-2.0.0_rc3-gentoo.patch20
-rw-r--r--net-analyzer/hping/hping-2.0.0_rc3-r2.ebuild51
-rw-r--r--net-analyzer/hping/hping-3_pre20051105-r1.ebuild10
4 files changed, 83 insertions, 8 deletions
diff --git a/net-analyzer/hping/ChangeLog b/net-analyzer/hping/ChangeLog
index 26e263d10989..f8574526ef6c 100644
--- a/net-analyzer/hping/ChangeLog
+++ b/net-analyzer/hping/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/hping
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.45 2009/12/22 20:26:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.46 2009/12/22 21:17:15 jer Exp $
+
+*hping-2.0.0_rc3-r2 (22 Dec 2009)
+
+ 22 Dec 2009; Jeroen Roovers <jer@gentoo.org> +hping-2.0.0_rc3-r2.ebuild,
+ +files/hping-2.0.0_rc3-gentoo.patch, hping-3_pre20051105-r1.ebuild:
+ Apply the same patches to hping-2 (see previous ChangeLog entry, bar the
+ tcl stuff). Remove useless USE=debug (set -g through CFLAGS instead if you
+ want, both v2 and v3).
*hping-3_pre20051105-r1 (22 Dec 2009)
diff --git a/net-analyzer/hping/files/hping-2.0.0_rc3-gentoo.patch b/net-analyzer/hping/files/hping-2.0.0_rc3-gentoo.patch
new file mode 100644
index 000000000000..d8f24bca5e83
--- /dev/null
+++ b/net-analyzer/hping/files/hping-2.0.0_rc3-gentoo.patch
@@ -0,0 +1,20 @@
+--- Makefile.in.org 2004-05-03 11:29:39.000000000 +0200
++++ Makefile.in 2009-12-22 21:55:58.000000000 +0100
+@@ -6,7 +6,7 @@
+ # $date: Sun Jul 25 17:56:15 MET DST 1999$
+ # $rev: 3$
+
+-CC= gcc
++CC?= gcc
+ AR=/usr/bin/ar
+ RANLIB=/usr/bin/ranlib
+ CCOPT= -O2 -Wall @PCAP_INCLUDE@
+@@ -43,7 +43,7 @@
+ $(RANLIB) $@
+
+ hping2: byteorder.h $(OBJ)
+- $(CC) -o hping2 $(CCOPT) $(DEBUG) $(OBJ) $(PCAP) @SOLARISLIB@
++ $(CC) -o hping2 $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) $(PCAP) @SOLARISLIB@
+ @echo
+ ./hping2 -v
+ @echo "use \`make strip' to strip hping2 binary"
diff --git a/net-analyzer/hping/hping-2.0.0_rc3-r2.ebuild b/net-analyzer/hping/hping-2.0.0_rc3-r2.ebuild
new file mode 100644
index 000000000000..886d56549918
--- /dev/null
+++ b/net-analyzer/hping/hping-2.0.0_rc3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc3-r2.ebuild,v 1.1 2009/12/22 21:17:15 jer Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}${PV//_/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap"
+
+S="${WORKDIR}/${MY_P//\.[0-9]}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/bytesex.h.patch \
+ "${FILESDIR}"/hping-bridge.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ sed -i Makefile.in \
+ -e "9s:gcc:$(tc-getCC):" \
+ -e "10s:/usr/bin/ar:$(tc-getAR):" \
+ -e "11s:/usr/bin/ranlib:$(tc-getRANLIB):" \
+ -e "s:/usr/local/lib:/usr/$(get_libdir):g"
+}
+
+src_compile() {
+ tc-export CC
+
+ # Not an autotools type configure:
+ sh configure || die "configure failed"
+
+ emake CCOPT="${CFLAGS}" DEBUG="" || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/sbin
+ dosbin hping2
+ dosym /usr/sbin/hping2 /usr/sbin/hping
+
+ doman docs/hping2.8
+ dodoc INSTALL KNOWN-BUGS NEWS README TODO AUTHORS BUGS CHANGES COPYING docs/AS-BACKDOOR docs/HPING2-IS-OPEN docs/MORE-FUN-WITH-IPID docs/*.txt
+}
diff --git a/net-analyzer/hping/hping-3_pre20051105-r1.ebuild b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
index 29f87150b579..ed31c57c273d 100644
--- a/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
+++ b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105-r1.ebuild,v 1.1 2009/12/22 20:26:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105-r1.ebuild,v 1.2 2009/12/22 21:17:15 jer Exp $
inherit eutils multilib toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
-IUSE="tcl debug"
+IUSE="tcl"
S="${WORKDIR}/${MY_P}"
@@ -45,11 +45,7 @@ src_compile() {
# Not an autotools type configure:
sh configure ${myconf} || die "configure failed"
- if use debug; then
- emake || die "make failed"
- else
- emake DEBUG="" || die "make failed"
- fi
+ emake DEBUG="" || die "emake failed"
}
src_install () {