summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-11-30 20:47:08 +0000
committerJeroen Roovers <jer@gentoo.org>2010-11-30 20:47:08 +0000
commitc00fe5f744fb8ccd9dd145c5461abc5144a4ec30 (patch)
treed635865cf882fd0f69f26e6261bb3fc2d13b48a4 /net-analyzer/hydra
parentSpelling, grammar. (diff)
downloadgentoo-2-c00fe5f744fb8ccd9dd145c5461abc5144a4ec30.tar.gz
gentoo-2-c00fe5f744fb8ccd9dd145c5461abc5144a4ec30.tar.bz2
gentoo-2-c00fe5f744fb8ccd9dd145c5461abc5144a4ec30.zip
Version bump by Anton Bolshakov (bug #346153).
(Portage version: 2.2.0_alpha6/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/ChangeLog7
-rw-r--r--net-analyzer/hydra/hydra-5.9.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-analyzer/hydra/ChangeLog b/net-analyzer/hydra/ChangeLog
index 29afb4fb7b62..06d62a51a05a 100644
--- a/net-analyzer/hydra/ChangeLog
+++ b/net-analyzer/hydra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/hydra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.42 2010/10/24 15:35:20 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.43 2010/11/30 20:47:08 jer Exp $
+
+*hydra-5.9 (30 Nov 2010)
+
+ 30 Nov 2010; Jeroen Roovers <jer@gentoo.org> +hydra-5.9.ebuild:
+ Version bump by Anton Bolshakov (bug #346153).
24 Oct 2010; Brent Baude <ranger@gentoo.org> hydra-5.7.ebuild:
stable ppc, bug 341133
diff --git a/net-analyzer/hydra/hydra-5.9.ebuild b/net-analyzer/hydra/hydra-5.9.ebuild
new file mode 100644
index 000000000000..82dd10544cda
--- /dev/null
+++ b/net-analyzer/hydra/hydra-5.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/hydra-5.9.ebuild,v 1.1 2010/11/30 20:47:08 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="http://www.thc.org/thc-hydra/"
+SRC_URI="http://freeworld.thc.org/releases/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="
+ dev-libs/openssl
+ gtk? ( >=x11-libs/gtk+-1.2 )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:-O2:$(CPPFLAGS) $(CFLAGS):g' \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s/-//' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die "sed failed"
+}
+
+src_configure() {
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ ./configure \
+ --prefix=/usr \
+ $(use gtk && echo --disable-xhydra) \
+ || die "configure failed"
+
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=-lcrypto:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ Makefile || die "pruning vars"
+
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DLIBOPENSSL -DLIBSSH:' \
+ -e '/^XLIBS=/s:$: -lssl -lssh:' \
+ Makefile || die "adding ssl"
+ fi
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf || die "econf failed"
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+ if use gtk ; then
+ cd hydra-gtk && \
+ emake || die "emake hydra-gtk failed"
+ fi
+}
+
+src_install() {
+ dobin hydra pw-inspector || die "dobin failed"
+ if use gtk ; then
+ dobin hydra-gtk/src/xhydra || die "gtk"
+ fi
+ dodoc CHANGES README TODO
+}