summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-05-24 23:18:32 +0000
committerPeter Volkov <pva@gentoo.org>2009-05-24 23:18:32 +0000
commitd7b5875bbcbbbd447f54199cb6a9957db6780db8 (patch)
tree933618b99c16e3287113862dc1186f452714217d /net-analyzer/hydra
parentVersion bump (diff)
downloadgentoo-2-d7b5875bbcbbbd447f54199cb6a9957db6780db8.tar.gz
gentoo-2-d7b5875bbcbbbd447f54199cb6a9957db6780db8.tar.bz2
gentoo-2-d7b5875bbcbbbd447f54199cb6a9957db6780db8.zip
Fixed http-form module crashes when run, bug #209116, thank deanx for report. Fixed build problem with _FORTIFY_SOURCE, bug #263146, thank Jonathan-Christofer Demay for the patch.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/ChangeLog12
-rw-r--r--net-analyzer/hydra/files/hydra-5.4-_FORTIFY_SOURCE.patch12
-rw-r--r--net-analyzer/hydra/hydra-5.4-r1.ebuild67
3 files changed, 89 insertions, 2 deletions
diff --git a/net-analyzer/hydra/ChangeLog b/net-analyzer/hydra/ChangeLog
index f4e6277ae54e..5b12ff25d7f6 100644
--- a/net-analyzer/hydra/ChangeLog
+++ b/net-analyzer/hydra/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/hydra
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.26 2008/01/18 18:31:47 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.27 2009/05/24 23:18:32 pva Exp $
+
+*hydra-5.4-r1 (24 May 2009)
+
+ 24 May 2009; Peter Volkov <pva@gentoo.org> +hydra-5.4-r1.ebuild,
+ +files/hydra-5.4-_FORTIFY_SOURCE.patch:
+ Fixed http-form module crashes when run, bug #209116, thank deanx for
+ report. Fixed build problem with _FORTIFY_SOURCE, bug #263146, thank
+ Jonathan-Christofer Demay for the patch.
18 Jan 2008; Raúl Porcel <armin76@gentoo.org> -hydra-4.4.ebuild,
-hydra-5.3.ebuild:
diff --git a/net-analyzer/hydra/files/hydra-5.4-_FORTIFY_SOURCE.patch b/net-analyzer/hydra/files/hydra-5.4-_FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..dc9b0ec6e9cb
--- /dev/null
+++ b/net-analyzer/hydra/files/hydra-5.4-_FORTIFY_SOURCE.patch
@@ -0,0 +1,12 @@
+diff -Naur hydra-5.4-src-orig/hydra-gtk/src/callbacks.c hydra-5.4-src-patch/hydra-gtk/src/callbacks.c
+--- hydra-5.4-src-orig/hydra-gtk/src/callbacks.c 2005-09-22 15:19:27.000000000 +0000
++++ hydra-5.4-src-patch/hydra-gtk/src/callbacks.c 2009-03-20 17:59:40.000000000 +0000
+@@ -663,7 +663,7 @@
+
+ text = gtk_text_buffer_get_text(outputbuf, &start, &end, TRUE);
+
+- fd = open(filename, O_CREAT | O_TRUNC | O_WRONLY);
++ fd = open(filename, O_CREAT | O_TRUNC | O_WRONLY, S_IRUSR | S_IWUSR);
+ if ( fd > 0 ) {
+ write(fd, text, strlen(text));
+ close(fd);
diff --git a/net-analyzer/hydra/hydra-5.4-r1.ebuild b/net-analyzer/hydra/hydra-5.4-r1.ebuild
new file mode 100644
index 000000000000..6283a2368b90
--- /dev/null
+++ b/net-analyzer/hydra/hydra-5.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/hydra-5.4-r1.ebuild,v 1.1 2009/05/24 23:18:32 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="http://www.thc.org/thc-hydra/"
+SRC_URI="http://www.thc.org/releases/${P}-src.tar.gz"
+
+LICENSE="HYDRA GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl"
+
+DEPEND="gtk? ( >=x11-libs/gtk+-1.2 )
+ ssl? (
+ dev-libs/openssl
+ =net-libs/libssh-0.11
+ )"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile.am || die "sed failed"
+ epatch "${FILESDIR}/${P}-_FORTIFY_SOURCE.patch"
+ epatch "${FILESDIR}/${P}-free-without-malloc.patch"
+}
+
+src_compile() {
+ if use gtk ; then
+ ./configure --prefix=/usr || die "configure failed"
+ else
+ ./configure --prefix=/usr --disable-xhydra || die "configure failed"
+ fi
+
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ Makefile || die "pruning vars"
+
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DLIBOPENSSL -DLIBSSH:' \
+ -e '/^XLIBS=/s:=:=-lcrypto -lssl -lssh:' \
+ Makefile || die "adding ssl"
+ fi
+ emake || die "make failed"
+
+ if use gtk ; then
+ cd hydra-gtk
+ econf
+ emake || die "emake hydra-gtk failed"
+ fi
+}
+
+src_install() {
+ dobin hydra pw-inspector || die "dobin failed"
+ if use gtk ; then
+ dobin hydra-gtk/src/xhydra || die "gtk"
+ fi
+ dodoc CHANGES README TODO
+}