summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-08-19 04:43:25 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-08-19 04:43:25 +0000
commita2c2f4703cb22ea3e947cd16045379fe97d5f1ff (patch)
treed3160ce509efc957f8c26d23b91f67f9699f3f4e /net-analyzer/icinga
parentRemove old; keep it to sysadmin herd, drop me. (diff)
downloadgentoo-2-a2c2f4703cb22ea3e947cd16045379fe97d5f1ff.tar.gz
gentoo-2-a2c2f4703cb22ea3e947cd16045379fe97d5f1ff.tar.bz2
gentoo-2-a2c2f4703cb22ea3e947cd16045379fe97d5f1ff.zip
cleanup and new init, thanks flameeyes :D
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/icinga')
-rw-r--r--net-analyzer/icinga/ChangeLog8
-rwxr-xr-xnet-analyzer/icinga/files/icinga-init.d-261
-rw-r--r--net-analyzer/icinga/files/ido2db-init.d-238
-rw-r--r--net-analyzer/icinga/icinga-1.7.1-r1.ebuild255
-rw-r--r--net-analyzer/icinga/icinga-1.7.1-r4.ebuild (renamed from net-analyzer/icinga/icinga-1.7.1-r2.ebuild)9
-rw-r--r--net-analyzer/icinga/icinga-1.7.1.ebuild254
6 files changed, 110 insertions, 515 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index e809a0651dfb..38857c4310e4 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/icinga
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.20 2012/08/17 20:53:12 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.21 2012/08/19 04:43:24 prometheanfire Exp $
+
+*icinga-1.7.1-r4 (19 Aug 2012)
+
+ 19 Aug 2012; Matthew Thode <prometheanfire@gentoo.org>
+ +icinga-1.7.1-r4.ebuild, +files/icinga-init.d-2, +files/ido2db-init.d-2:
+ updating initscripts
*icinga-1.7.1-r3 (17 Aug 2012)
diff --git a/net-analyzer/icinga/files/icinga-init.d-2 b/net-analyzer/icinga/files/icinga-init.d-2
new file mode 100755
index 000000000000..85f64ad554dd
--- /dev/null
+++ b/net-analyzer/icinga/files/icinga-init.d-2
@@ -0,0 +1,61 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/icinga-init.d-2,v 1.7 2012/08/19 04:43:25 prometheanfire Exp $
+
+: ${ICINGACFG:=/etc/icinga/icinga.cfg}
+
+extra_commands="checkconfig"
+extra_started_commands="reload"
+
+command=/usr/sbin/icinga
+command_args="-d ${ICINGACFG}"
+
+get_config() {
+ sed -n -e 's:^[ \t]*'$1'=\([^#]\+\).*:\1:p' \
+ "${ICINGACFG}"
+}
+
+pidfile=$(get_config lock_file)
+start_stop_daemon_args="-e HOME=/var/lib/icinga"
+
+depend() {
+ need net
+ use dns logger firewall mysql postgresql ido2db
+}
+
+checkconfig() {
+ # Silent Check
+ ${command} -v ${ICINGACFG} &>/dev/null && return 0
+ # Now we know there's problem - run again and display errors
+ ${command} -v ${ICINGACFG}
+ eend $? "Configuration Error. Please fix your configfile"
+}
+
+reload()
+{
+ checkconfig || return 1
+ ebegin "Reloading configuration"
+ kill -HUP $(cat ${pidfile}) &>/dev/null
+ eend $?
+}
+
+start_pre() {
+ checkpath -d -o icinga:icinga $(get_config temp_path) $(dirname $(get_config lock_file)) $(dirname $(get_config log_file)) $(dirname $(get_config status_file))
+ checkpath -f -o icinga:icinga $(get_config log_file)
+ rm -f $(get_config command_file)
+}
+
+stop_post() {
+ rm -f $(get_config command_file)
+ rm -r /tmp/icinga
+}
+
+svc_restart() {
+ checkconfig || return 1
+ ebegin "Restarting icinga"
+ svc_stop
+ svc_start
+ eend $?
+}
+
diff --git a/net-analyzer/icinga/files/ido2db-init.d-2 b/net-analyzer/icinga/files/ido2db-init.d-2
new file mode 100644
index 000000000000..74ca1c286ac3
--- /dev/null
+++ b/net-analyzer/icinga/files/ido2db-init.d-2
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d-2,v 1.1 2012/08/19 04:43:25 prometheanfire Exp $
+
+get_config() {
+ sed -n -e 's:^[ \t]*'$1'=\([^#]\+\).*:\1:p' \
+ "${IDO2DBCFG}"
+}
+
+command=/usr/sbin/ido2db
+command_args="-c ${IDO2DBCFG}"
+pidfile="$(get_config lock_file)"
+
+depend() {
+ config "${IDO2DBCFG}"
+
+ need net
+ use dns logger firewall
+
+ case $(get_config db_servertype) in
+ mysql)
+ need mysql ;;
+ pgsql)
+ need postgresql ;;
+ esac
+}
+
+IDO2DBSOCKET="$(get_config socket_name)"
+
+start_pre() {
+ if [ -S "${IDO2DBSOCKET}" ] ; then
+ ewarn "Strange, the socket file already exist in \"${IDO2DBSOCKET}\""
+ ewarn "it will be removed now and re-created by ido2db"
+ ewarn "BUT please make your checks."
+ rm -f "${IDO2DBSOCKET}"
+ fi
+}
diff --git a/net-analyzer/icinga/icinga-1.7.1-r1.ebuild b/net-analyzer/icinga/icinga-1.7.1-r1.ebuild
deleted file mode 100644
index 3c4eacf61c73..000000000000
--- a/net-analyzer/icinga/icinga-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,255 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.7.1-r1.ebuild,v 1.1 2012/06/25 18:58:02 prometheanfire Exp $
-
-EAPI=2
-
-inherit depend.apache eutils multilib toolchain-funcs user versionator
-
-DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
-HOMEPAGE="http://www.icinga.org/"
-#MY_PV=$(delete_version_separator 3)
-#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-#S=${WORKDIR}/${PN}-${MY_PV}
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+apache2 debug eventhandler +idoutils lighttpd +mysql perl +plugins postgres ssl +vim-syntax +web"
-DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
- perl? ( dev-lang/perl )
- virtual/mailx
- web? (
- media-libs/gd[jpeg,png]
- lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
- apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
- )
- !net-analyzer/nagios-core"
-RDEPEND="${DEPEND}
- plugins? ( net-analyzer/nagios-plugins )"
-RESTRICT="test"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup nagios
- enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/fix-prestripped-binaries-1.7.0.patch"
-}
-
-src_configure() {
- local myconf
-
- myconf="$(use_enable perl embedded-perl)
- $(use_with perl perlcache)
- $(use_enable idoutils)
- $(use_enable ssl)
- $(use_enable debug DEBUG0)
- $(use_enable debug DEBUG1)
- $(use_enable debug DEBUG2)
- $(use_enable debug DEBUG3)
- $(use_enable debug DEBUG4)
- $(use_enable debug DEBUG5)
- --disable-statuswrl
- --with-cgiurl=/icinga/cgi-bin
- --with-log-dir=/var/log/icinga
- --libdir=/usr/$(get_libdir)
- --bindir=/usr/sbin
- --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
- --datarootdir=/usr/share/icinga/htdocs
- --localstatedir=/var/lib/icinga
- --sysconfdir=/etc/icinga
- --with-lockfile=/var/run/icinga/icinga.lock
- --with-temp-dir=/tmp/icinga
- --with-temp-file=/tmp/icinga/icinga.tmp"
-
- if use idoutils ; then
- myconf+=" --with-ido2db-lockfile=/var/run/icinga/ido2db.lock
- --with-icinga-chkfile=/var/lib/icinga/icinga.chk
- --with-ido-sockfile=/var/lib/icinga/ido.sock
- --with-idomod-tmpfile=/tmp/icinga/idomod.tmp"
- fi
-
- if use eventhandler ; then
- myconfig+=" --with-eventhandler-dir=/etc/icinga/eventhandlers"
- fi
-
- if use plugins ; then
- myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
- else
- myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
- fi
-
- if use !apache2 && use !lighttpd ; then
- myconf+=" --with-command-group=icinga"
- else
- if use apache2 ; then
- myconf+=" --with-httpd-conf=/etc/apache2/conf.d"
- myconf+=" --with-command-group=apache"
- elif use lighttpd ; then
- myconf+=" --with-command-group=lighttpd"
- fi
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- tc-export CC
-
- emake icinga || die "make failed"
-
- if use web ; then
- emake DESTDIR="${D}" cgis || die
- fi
-
- if use idoutils ; then
- emake DESTDIR="${D}" idoutils || die
- fi
-}
-
-src_install() {
- dodoc Changelog README UPGRADING || die
-
- if ! use web ; then
- sed -i -e '/cd $(SRC_\(CGI\|HTM\))/d' Makefile || die
- fi
-
- emake DESTDIR="${D}" install{,-config,-commandmode} || die
-
- if use idoutils ; then
- emake DESTDIR="${D}" install-idoutils || die
- fi
-
- if use eventhandler ; then
- emake DESTDIR="${D}" install-eventhandlers || die
- fi
-
- newinitd "${FILESDIR}"/icinga-init.d icinga || die
- newconfd "${FILESDIR}"/icinga-conf.d icinga || die
- if use idoutils ; then
- newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
- newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
- insinto /usr/share/icinga/contrib/db
- doins -r module/idoutils/db/* || die
- fi
- # Apache Module
- if use web ; then
- if use apache2 ; then
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}"/icinga-apache.conf 99_icinga.conf || die
- elif use lighttpd ; then
- insinto /etc/lighttpd
- newins "${FILESDIR}"/icinga-lighty.conf lighttpd_icinga.conf || die
- else
- ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
- ewarn "out-of-the-box. Since you are not using one of them, you"
- ewarn "have to configure your webserver accordingly yourself."
- fi
- fi
-
- if use eventhandler ; then
- dodir /etc/icinga/eventhandlers || die
- fowners icinga:icinga /etc/icinga/eventhandlers || die
- fi
-
- fowners -R root:root /usr/$(get_libdir)/icinga || die
- cd "${D}" || die
- find usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
- find usr/$(get_libdir)/icinga/cgi-bin -type f -exec fperms 755 {} +
- dodir /var/run/icinga || die
- fowners icinga:icinga /var/run/icinga || die
-
- keepdir /etc/icinga
- keepdir /var/lib/icinga
- keepdir /var/lib/icinga/archives
- keepdir /var/lib/icinga/rw
- keepdir /var/lib/icinga/spool/checkresults
-
- if use apache2 ; then
- webserver=apache
- elif use lighttpd ; then
- webserver=lighttpd
- else
- webserver=icinga
- fi
-
- fowners icinga:icinga /var/lib/icinga || die "Failed chown of /var/lib/icinga"
- fowners -R icinga:${webserver} /var/lib/icinga/rw || die "Failed chown of /var/lib/icinga/rw"
-
- fperms 6755 /var/lib/icinga/rw || die "Failed Chmod of ${D}/var/lib/icinga/rw"
- fperms 0750 /etc/icinga || die "Failed chmod of ${D}/etc/icinga"
-}
-
-pkg_postinst() {
- if use web ; then
- elog "This does not include cgis that are perl-dependent"
- elog "Currently traceroute.cgi is perl-dependent"
- elog "Note that the user your webserver is running as needs"
- elog "read-access to /etc/icinga."
- elog
- if use apache2 || use lighttpd ; then
- elog "There are several possible solutions to accomplish this,"
- elog "choose the one you are most comfortable with:"
- elog
- if use apache2 ; then
- elog " usermod -G icinga apache"
- elog "or"
- elog " chown icinga:apache /etc/icinga"
- elog
- elog "Also edit /etc/conf.d/apache2 and add a line like"
- elog "APACHE2_OPTS=\"\$APACHE2_OPTS -D ICINGA\""
- elog
- elog "Icinga web service needs user authentication. If you"
- elog "use the base configuration, you need a password file"
- elog "with a password for user \"icingaadmin\""
- elog "You can create this file by executing:"
- elog "htpasswd -c /etc/icinga/htpasswd.users icingaadmin"
- elif use lighttpd ; then
- elog " usermod -G icinga lighttpd "
- elog "or"
- elog " chown icinga:lighttpd /etc/icinga"
- elog "Also edit /etc/lighttpd/lighttpd.conf and add 'include \"lighttpd_icinga.conf\"'"
- fi
- elog
- elog "That will make icinga's web front end visable via"
- elog "http://localhost/icinga/"
- elog
- else
- elog "IMPORTANT: Do not forget to add the user your webserver"
- elog "is running as to the icinga group!"
- fi
- else
- ewarn "Please note that you have installed Icinga without web interface."
- ewarn "Please don't file any bugs about having no web interface when you do this."
- ewarn "Thank you!"
- fi
- elog
- elog "If you want icinga to start at boot time"
- elog "remember to execute:"
- elog " rc-update add icinga default"
- elog
- elog "If your kernel has /proc protection, icinga"
- elog "will not be happy as it relies on accessing the proc"
- elog "filesystem. You can fix this by adding icinga into"
- elog "the group wheel, but this is not recomended."
- elog
- if [ -d "${ROOT}"/var/icinga ] ; then
- ewarn
- ewarn "/var/icinga was moved to /var/lib/icinga"
- ewarn "please move the files if this was an upgrade"
- if use idoutils ; then
- ewarn "and edit /etc/ido2db.cfg to change the location of the files"
- ewarn "it accesses"
- fi
- ewarn
- ewarn "The \"mv /var/icinga /var/lib/\" command works well to move the files"
- ewarn "remove /var/icinga afterwards to make this warning disappear"
- fi
-}
diff --git a/net-analyzer/icinga/icinga-1.7.1-r2.ebuild b/net-analyzer/icinga/icinga-1.7.1-r4.ebuild
index 0356c9f51b7c..24ce36b4a66e 100644
--- a/net-analyzer/icinga/icinga-1.7.1-r2.ebuild
+++ b/net-analyzer/icinga/icinga-1.7.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.7.1-r2.ebuild,v 1.1 2012/07/09 20:44:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.7.1-r4.ebuild,v 1.1 2012/08/19 04:43:24 prometheanfire Exp $
EAPI=2
@@ -22,8 +22,7 @@ DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
virtual/mailx
web? (
media-libs/gd[jpeg,png]
- lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
- apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
+ lighttpd? ( www-servers/lighttpd )
)
!net-analyzer/nagios-core"
RDEPEND="${DEPEND}
@@ -125,10 +124,10 @@ src_install() {
emake DESTDIR="${D}" install-eventhandlers || die
fi
- newinitd "${FILESDIR}"/icinga-init.d icinga || die
+ newinitd "${FILESDIR}"/icinga-init.d-2 icinga || die
newconfd "${FILESDIR}"/icinga-conf.d icinga || die
if use idoutils ; then
- newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
+ newinitd "${FILESDIR}"/ido2db-init.d-2 ido2db || die
newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
insinto /usr/share/icinga/contrib/db
doins -r module/idoutils/db/* || die
diff --git a/net-analyzer/icinga/icinga-1.7.1.ebuild b/net-analyzer/icinga/icinga-1.7.1.ebuild
deleted file mode 100644
index 363f580f2e45..000000000000
--- a/net-analyzer/icinga/icinga-1.7.1.ebuild
+++ /dev/null
@@ -1,254 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.7.1.ebuild,v 1.1 2012/06/18 18:23:28 prometheanfire Exp $
-
-EAPI=2
-
-inherit depend.apache eutils multilib toolchain-funcs user versionator
-
-DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
-HOMEPAGE="http://www.icinga.org/"
-#MY_PV=$(delete_version_separator 3)
-#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
-#S=${WORKDIR}/${PN}-${MY_PV}
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+apache2 debug eventhandler +idoutils lighttpd +mysql perl +plugins postgres ssl +vim-syntax +web"
-DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
- perl? ( dev-lang/perl )
- virtual/mailx
- web? (
- media-libs/gd[jpeg,png]
- lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
- apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
- )
- !net-analyzer/nagios-core"
-RDEPEND="${DEPEND}
- plugins? ( net-analyzer/nagios-plugins )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup nagios
- enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/fix-prestripped-binaries-1.7.0.patch"
-}
-
-src_configure() {
- local myconf
-
- myconf="$(use_enable perl embedded-perl)
- $(use_with perl perlcache)
- $(use_enable idoutils)
- $(use_enable ssl)
- $(use_enable debug DEBUG0)
- $(use_enable debug DEBUG1)
- $(use_enable debug DEBUG2)
- $(use_enable debug DEBUG3)
- $(use_enable debug DEBUG4)
- $(use_enable debug DEBUG5)
- --disable-statuswrl
- --with-cgiurl=/icinga/cgi-bin
- --with-log-dir=/var/log/icinga
- --libdir=/usr/$(get_libdir)
- --bindir=/usr/sbin
- --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
- --datarootdir=/usr/share/icinga/htdocs
- --localstatedir=/var/lib/icinga
- --sysconfdir=/etc/icinga
- --with-lockfile=/var/run/icinga/icinga.lock
- --with-temp-dir=/tmp/icinga
- --with-temp-file=/tmp/icinga/icinga.tmp"
-
- if use idoutils ; then
- myconf+=" --with-ido2db-lockfile=/var/run/icinga/ido2db.lock
- --with-icinga-chkfile=/var/lib/icinga/icinga.chk
- --with-ido-sockfile=/var/lib/icinga/ido.sock
- --with-idomod-tmpfile=/tmp/icinga/idomod.tmp"
- fi
-
- if use eventhandler ; then
- myconfig+=" --with-eventhandler-dir=/etc/icinga/eventhandlers"
- fi
-
- if use plugins ; then
- myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
- else
- myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
- fi
-
- if use !apache2 && use !lighttpd ; then
- myconf+=" --with-command-group=icinga"
- else
- if use apache2 ; then
- myconf+=" --with-httpd-conf=/etc/apache2/conf.d"
- myconf+=" --with-command-group=apache"
- elif use lighttpd ; then
- myconf+=" --with-command-group=lighttpd"
- fi
- fi
-
- econf ${myconf}
-}
-
-src_compile() {
- tc-export CC
-
- emake icinga || die "make failed"
-
- if use web ; then
- emake DESTDIR="${D}" cgis || die
- fi
-
- if use idoutils ; then
- emake DESTDIR="${D}" idoutils || die
- fi
-}
-
-src_install() {
- dodoc Changelog README UPGRADING || die
-
- if ! use web ; then
- sed -i -e '/cd $(SRC_\(CGI\|HTM\))/d' Makefile || die
- fi
-
- emake DESTDIR="${D}" install{,-config,-commandmode} || die
-
- if use idoutils ; then
- emake DESTDIR="${D}" install-idoutils || die
- fi
-
- if use eventhandler ; then
- emake DESTDIR="${D}" install-eventhandlers || die
- fi
-
- newinitd "${FILESDIR}"/icinga-init.d icinga || die
- newconfd "${FILESDIR}"/icinga-conf.d icinga || die
- if use idoutils ; then
- newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
- newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
- insinto /usr/share/icinga/contrib/db
- doins -r module/idoutils/db/* || die
- fi
- # Apache Module
- if use web ; then
- if use apache2 ; then
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}"/icinga-apache.conf 99_icinga.conf || die
- elif use lighttpd ; then
- insinto /etc/lighttpd
- newins "${FILESDIR}"/icinga-lighty.conf lighttpd_icinga.conf || die
- else
- ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
- ewarn "out-of-the-box. Since you are not using one of them, you"
- ewarn "have to configure your webserver accordingly yourself."
- fi
- fi
-
- if use eventhandler ; then
- dodir /etc/icinga/eventhandlers || die
- fowners icinga:icinga /etc/icinga/eventhandlers || die
- fi
-
- fowners -R root:root /usr/$(get_libdir)/icinga || die
- cd "${D}" || die
- find usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
- find usr/$(get_libdir)/icinga/cgi-bin -type f -exec fperms 755 {} +
- dodir /var/run/icinga || die
- fowners icinga:icinga /var/run/icinga || die
-
- keepdir /etc/icinga
- keepdir /var/lib/icinga
- keepdir /var/lib/icinga/archives
- keepdir /var/lib/icinga/rw
- keepdir /var/lib/icinga/spool/checkresults
-
- if use apache2 ; then
- webserver=apache
- elif use lighttpd ; then
- webserver=lighttpd
- else
- webserver=icinga
- fi
-
- fowners icinga:icinga /var/lib/icinga || die "Failed chown of /var/lib/icinga"
- fowners -R icinga:${webserver} /var/lib/icinga/rw || die "Failed chown of /var/lib/icinga/rw"
-
- fperms 6755 /var/lib/icinga/rw || die "Failed Chmod of ${D}/var/lib/icinga/rw"
- fperms 0750 /etc/icinga || die "Failed chmod of ${D}/etc/icinga"
-}
-
-pkg_postinst() {
- if use web ; then
- elog "This does not include cgis that are perl-dependent"
- elog "Currently traceroute.cgi is perl-dependent"
- elog "Note that the user your webserver is running as needs"
- elog "read-access to /etc/icinga."
- elog
- if use apache2 || use lighttpd ; then
- elog "There are several possible solutions to accomplish this,"
- elog "choose the one you are most comfortable with:"
- elog
- if use apache2 ; then
- elog " usermod -G icinga apache"
- elog "or"
- elog " chown icinga:apache /etc/icinga"
- elog
- elog "Also edit /etc/conf.d/apache2 and add a line like"
- elog "APACHE2_OPTS=\"\$APACHE2_OPTS -D ICINGA\""
- elog
- elog "Icinga web service needs user authentication. If you"
- elog "use the base configuration, you need a password file"
- elog "with a password for user \"icingaadmin\""
- elog "You can create this file by executing:"
- elog "htpasswd -c /etc/icinga/htpasswd.users icingaadmin"
- elif use lighttpd ; then
- elog " usermod -G icinga lighttpd "
- elog "or"
- elog " chown icinga:lighttpd /etc/icinga"
- elog "Also edit /etc/lighttpd/lighttpd.conf and add 'include \"lighttpd_icinga.conf\"'"
- fi
- elog
- elog "That will make icinga's web front end visable via"
- elog "http://localhost/icinga/"
- elog
- else
- elog "IMPORTANT: Do not forget to add the user your webserver"
- elog "is running as to the icinga group!"
- fi
- else
- ewarn "Please note that you have installed Icinga without web interface."
- ewarn "Please don't file any bugs about having no web interface when you do this."
- ewarn "Thank you!"
- fi
- elog
- elog "If you want icinga to start at boot time"
- elog "remember to execute:"
- elog " rc-update add icinga default"
- elog
- elog "If your kernel has /proc protection, icinga"
- elog "will not be happy as it relies on accessing the proc"
- elog "filesystem. You can fix this by adding icinga into"
- elog "the group wheel, but this is not recomended."
- elog
- if [ -d "${ROOT}"/var/icinga ] ; then
- ewarn
- ewarn "/var/icinga was moved to /var/lib/icinga"
- ewarn "please move the files if this was an upgrade"
- if use idoutils ; then
- ewarn "and edit /etc/ido2db.cfg to change the location of the files"
- ewarn "it accesses"
- fi
- ewarn
- ewarn "The \"mv /var/icinga /var/lib/\" command works well to move the files"
- ewarn "remove /var/icinga afterwards to make this warning disappear"
- fi
-}