summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-27 12:06:14 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-27 12:06:14 +0000
commit6e33d00cfe7538bba210c9b96bfb75d87480c60d (patch)
tree4fbaee601f561e5f4621d6094625da020575b9ae /net-analyzer/ifmetric/ifmetric-0.3.ebuild
parentstable on amd64 (diff)
downloadgentoo-2-6e33d00cfe7538bba210c9b96bfb75d87480c60d.tar.gz
gentoo-2-6e33d00cfe7538bba210c9b96bfb75d87480c60d.tar.bz2
gentoo-2-6e33d00cfe7538bba210c9b96bfb75d87480c60d.zip
Initial commit for bug 90262.
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'net-analyzer/ifmetric/ifmetric-0.3.ebuild')
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/ifmetric/ifmetric-0.3.ebuild b/net-analyzer/ifmetric/ifmetric-0.3.ebuild
new file mode 100644
index 000000000000..f3e1f931cf3f
--- /dev/null
+++ b/net-analyzer/ifmetric/ifmetric-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifmetric/ifmetric-0.3.ebuild,v 1.1 2005/04/27 12:06:14 ka0ttic Exp $
+
+DESCRIPTION="A Linux tool for setting the metrics of all IPv4 routes attached to a given network interface at once."
+HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
+SRC_URI="http://0pointer.de/lennart/projects/ifmetric/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# NOTE: this app is linux-only, virtual/os-headers therefore is incorrect
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+
+src_compile() {
+ # man page and HTML are already generated
+ econf --disable-xmltoman --disable-lynx || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+ dohtml doc/README.html
+}