summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-24 13:58:11 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-24 13:58:11 +0000
commita80d32d994fc3673b42e94b335d38d7a2603c2fa (patch)
treee843fd6a11d9fad75eadd8bb7d3c5b92fade0839 /net-analyzer/macchanger/macchanger-1.5.0.ebuild
parentVersion bump and optimisation fix (Manifest recommit) (diff)
downloadgentoo-2-a80d32d994fc3673b42e94b335d38d7a2603c2fa.tar.gz
gentoo-2-a80d32d994fc3673b42e94b335d38d7a2603c2fa.tar.bz2
gentoo-2-a80d32d994fc3673b42e94b335d38d7a2603c2fa.zip
Moved datadir to /lib. Closes #57046; bump
Diffstat (limited to 'net-analyzer/macchanger/macchanger-1.5.0.ebuild')
-rw-r--r--net-analyzer/macchanger/macchanger-1.5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/macchanger/macchanger-1.5.0.ebuild b/net-analyzer/macchanger/macchanger-1.5.0.ebuild
new file mode 100644
index 000000000000..e4280799e54e
--- /dev/null
+++ b/net-analyzer/macchanger/macchanger-1.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/macchanger/macchanger-1.5.0.ebuild,v 1.1 2004/07/24 13:58:11 eldad Exp $
+
+DESCRIPTION="Utility for viewing/manipulating the MAC address of network interfaces"
+HOMEPAGE="http://www.alobbs.com/macchanger"
+LICENSE="GPL-2"
+
+SRC_URI="ftp://ftp.gnu.org/gnu/macchanger/${P}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+SLOT="0"
+
+DEPEND="virtual/libc"
+
+
+src_compile() {
+ # Shared data is installed below /lib, see Bug #57046
+ econf \
+ --bindir=/sbin \
+ --datadir=/lib \
+ || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+ dodir /usr/bin
+ dosym /sbin/macchanger /usr/bin/macchanger
+ dosym /lib/macchanger /usr/share/macchanger
+}