summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-06-04 23:09:49 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-06-04 23:09:49 +0000
commitbd026d88ed0c1a82b9f2658637cc47e6836ccb42 (patch)
treea50424524d0f370c2952a5c3e2183ad911dff273 /net-analyzer/metasploit/metasploit-2.4-r1.ebuild
parentAdded ~sparc keyword wrt bug #93807. (diff)
downloadgentoo-2-bd026d88ed0c1a82b9f2658637cc47e6836ccb42.tar.gz
gentoo-2-bd026d88ed0c1a82b9f2658637cc47e6836ccb42.tar.bz2
gentoo-2-bd026d88ed0c1a82b9f2658637cc47e6836ccb42.zip
bug 95048
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/metasploit/metasploit-2.4-r1.ebuild')
-rw-r--r--net-analyzer/metasploit/metasploit-2.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/metasploit/metasploit-2.4-r1.ebuild b/net-analyzer/metasploit/metasploit-2.4-r1.ebuild
new file mode 100644
index 000000000000..8cad2376dd5d
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-2.4-r1.ebuild,v 1.1 2005/06/04 23:09:49 vanquirius Exp $
+
+MY_P="${P/metasploit/framework}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="The Metasploit Framework is an advanced open-source platform for developing, testing, and using vulnerability exploit code."
+HOMEPAGE="http://www.metasploit.org/"
+SRC_URI="http://metasploit.com/tools/${MY_P}-snapshot.tar.gz"
+# Note: the suffix snapshot might not exist in the next release
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-SSLeay
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey"
+
+src_install() {
+ dodir /usr/lib/
+ dodir /usr/bin/
+
+ # should be as simple as copying everything into the target...
+ cp -a ${S} ${D}usr/lib/metasploit || die
+
+ # and creating symlinks in the /usr/bin dir
+ cd ${D}/usr/bin
+ ln -s ../lib/metasploit/msf* ./ || die
+ chown -R root:root ${D}
+
+ newinitd ${FILESDIR}/msfweb.initd msfweb || die "newinitd failed"
+ newconfd ${FILESDIR}/msfweb.confd msfweb || die "newconfd failed"
+}
+
+pkg_postinst() {
+ ewarn "You may wish to perform a metasploit update to get"
+ ewarn "the latest modules (e.g. run 'msfupdate -u')"
+}