summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-09-08 01:08:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-09-08 01:08:14 +0000
commitd809059420cb81070ef42d6e4a4b382adb12a561 (patch)
tree74a3123897718fb33211f4856f5933f9837e80d1 /net-analyzer/munin
parentFix bug #146362 and version bump. (diff)
downloadgentoo-2-d809059420cb81070ef42d6e4a4b382adb12a561.tar.gz
gentoo-2-d809059420cb81070ef42d6e4a4b382adb12a561.tar.bz2
gentoo-2-d809059420cb81070ef42d6e4a4b382adb12a561.zip
Bug #146429, try to have a minimal version, might not work right yet.
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'net-analyzer/munin')
-rw-r--r--net-analyzer/munin/ChangeLog7
-rw-r--r--net-analyzer/munin/files/digest-munin-1.3.2-r13
-rw-r--r--net-analyzer/munin/munin-1.3.2-r1.ebuild111
3 files changed, 120 insertions, 1 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 7b6f71d6d199..490274d4ed25 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.1 2006/07/11 09:18:47 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.2 2006/09/08 01:08:14 robbat2 Exp $
+
+*munin-1.3.2-r1 (08 Sep 2006)
+
+ 08 Sep 2006; Robin H. Johnson <robbat2@gentoo.org> +munin-1.3.2-r1.ebuild:
+ Bug #146429, try to have a minimal version, might not work right yet.
*munin-1.3.2 (11 Jul 2006)
diff --git a/net-analyzer/munin/files/digest-munin-1.3.2-r1 b/net-analyzer/munin/files/digest-munin-1.3.2-r1
new file mode 100644
index 000000000000..3bc37b06a1a9
--- /dev/null
+++ b/net-analyzer/munin/files/digest-munin-1.3.2-r1
@@ -0,0 +1,3 @@
+MD5 9eef4a53626cee0e088391c5deb8bd51 munin_1.3.2.tar.gz 309319
+RMD160 7bcc16d00ad28731041015ef240144ed0c4fdeb4 munin_1.3.2.tar.gz 309319
+SHA256 964887d3af5b5b1fadbabb4c887095820613ea06c768251d6a9c37fa35efcc40 munin_1.3.2.tar.gz 309319
diff --git a/net-analyzer/munin/munin-1.3.2-r1.ebuild b/net-analyzer/munin/munin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..245656f7b56a
--- /dev/null
+++ b/net-analyzer/munin/munin-1.3.2-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-1.3.2-r1.ebuild,v 1.1 2006/09/08 01:08:14 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Munin Server Monitoring Tool"
+HOMEPAGE="http://munin.sourceforge.net"
+SRC_URI="mirror://sourceforge/munin/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc minimal munin-irc munin-dhcp munin-surfboard munin-apache munin-squid"
+
+# Upstream's listing of required modules is NOT correct!
+DEPEND_COM="dev-lang/perl
+ dev-perl/net-server
+ sys-process/procps
+ dev-perl/Net-SSLeay
+ dev-perl/Net-SNMP
+ dev-perl/DateManip
+ virtual/perl-Time-HiRes
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ !minimal? ( dev-perl/HTML-Template
+ net-analyzer/rrdtool )
+ munin-irc? ( dev-perl/Net-IRC )
+ munin-dhcp? ( dev-perl/Net-Netmask dev-perl/libwww-perl )
+ munin-surfboard? ( dev-perl/libwww-perl )
+ munin-apache? ( dev-perl/libwww-perl )
+ munin-squid? ( virtual/perl-MIME-Base64 )"
+ # Sybase isn't supported in Gentoo
+ #munin-sybase? ( dev-perl/DBD-Sybase )
+
+DEPEND="${DEPEND_COM}
+ doc? ( app-text/htmldoc
+ app-text/html2text )"
+RDEPEND="${DEPEND_COM}
+ virtual/cron"
+
+pkg_setup() {
+ enewgroup munin
+ enewuser munin 177 -1 /var/lib/munin munin
+}
+
+src_unpack() {
+ unpack ${A}
+ # upstream needs a lot of DESTDIR loving
+ # and Gentoo location support
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-Makefile.patch
+ # Fix noise in the plugins
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-plugin-cleanup.patch
+ # Make it work with new versions of Rrdtool where : in COMMENT blocks must
+ # be escaped!
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-rrdtool-comments.patch
+}
+
+src_compile() {
+ emake build build-man || die "build/build-man failed"
+ if use doc; then
+ emake build-doc || die "build-doc failed"
+ fi
+}
+
+src_install() {
+ local dirs
+ dirs="/var/log/munin /var/lib/munin"
+ dirs="${dirs} /var/lib/munin/plugin-state"
+ dirs="${dirs} /var/run/munin/plugin-state"
+ keepdir ${dirs}
+
+ emake DESTDIR="${D}" install-main install-man install-node install-node-plugins || die "install failed"
+ fowners munin:munin ${dirs}
+
+ if use doc; then
+ emake DESTDIR="${D}" install-doc install-man || die "install docs failed"
+ fi
+
+ insinto /etc/munin/plugin-conf.d/
+ newins ${FILESDIR}/${P}-plugins.conf munin-node
+
+ # make sure we've got everything in the correct directory
+ insinto /var/lib/munin
+ newins ${FILESDIR}/${P}-crontab crontab
+ newinitd ${FILESDIR}/munin-init.d munin-node
+ dodoc ChangeLog INSTALL README-apache-cgi.in README.api logo.eps
+ munin-doc-base.html munin-faq-base.html TODO.plugins
+ newdoc server/TODO TODO.server
+ newdoc node/TODO TODO.node
+}
+
+pkg_config() {
+ crontab -l -u munin 2>/dev/null | grep --silent '.*'
+ if [ $? -eq 0 ]; then
+ die "Crontab already install for user munin. Not overwriting."
+ fi
+ einfo "Press enter to install the default crontab for the munin master"
+ einfo "installation from /var/lib/munin/crontab"
+ einfo "If you have a large site, you may wish to customize it."
+ read
+ crontab -u munin /var/lib/munin/crontab
+}
+
+pkg_postinst() {
+ einfo "Please start munin-node via /etc/init.d/munin-node."
+ einfo "To have munin's cronjob automatically configured for you if this is"
+ einfo "your munin master installation, please:"
+ einfo "emerge --config net-analyzer/munin"
+}