summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-09-23 03:35:07 +0000
committerChris White <chriswhite@gentoo.org>2005-09-23 03:35:07 +0000
commit55c1aca7b282625659cbc52d01b6b6513b997bdf (patch)
tree06855941b7cbcfc2a6ca4fc03aa56d3f9c05bdae /net-analyzer/mwcollect/mwcollect-2.1.2.ebuild
parentversion bump 0.9.0 (diff)
downloadgentoo-2-55c1aca7b282625659cbc52d01b6b6513b997bdf.tar.gz
gentoo-2-55c1aca7b282625659cbc52d01b6b6513b997bdf.tar.bz2
gentoo-2-55c1aca7b282625659cbc52d01b6b6513b997bdf.zip
Version bump. Thanks to upstream for the heads up.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-analyzer/mwcollect/mwcollect-2.1.2.ebuild')
-rw-r--r--net-analyzer/mwcollect/mwcollect-2.1.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/mwcollect/mwcollect-2.1.2.ebuild b/net-analyzer/mwcollect/mwcollect-2.1.2.ebuild
new file mode 100644
index 000000000000..6ffa02cf3dfe
--- /dev/null
+++ b/net-analyzer/mwcollect/mwcollect-2.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mwcollect/mwcollect-2.1.2.ebuild,v 1.1 2005/09/23 03:35:07 chriswhite Exp $
+
+DESCRIPTION="mwcollect collects worms and other autonomous spreading malware"
+HOMEPAGE="http://www.mwcollect.org/"
+MY_PV="2.1.2"
+MY_P=${PN}${MY_PV}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://download.mwcollect.org/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ net-misc/curl"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:CXXFLAGS = .*:CXXFLAGS = ${CXXFLAGS} -D LINUX -D_GNU_SOURCE -g -Wall:" \
+ Makefile.LINUX || die "CFLAGS patching failed"
+}
+
+src_compile() {
+ emake -f Makefile.LINUX || die "emake failed"
+}
+
+src_install() {
+ dosbin bin/mwcollectd
+ insinto /usr/$(get_libdir)/mwcollect
+ doins bin/modules/*
+
+ sed -e "s#\./bin/modules#/usr/$(get_libdir)/mwcollect#g" \
+ mwcollectd.conf.dist > mwcollectd.conf.gentoo \
+ || die "sed failed"
+
+ insinto /etc/mwcollect
+ doins mwcollectd.conf.gentoo \
+ || die "newins mwcollectd.conf failed"
+
+ dodoc README*
+
+ newinitd ${FILESDIR}/initd mwcollectd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/confd mwcollectd
+}